ASUS Router und OpenVPN

psimon87

Cadet 1st Year
Dabei seit
Aug. 2012
Beiträge
9
Hallo Leute,

habe seite heute einen neuen ASUS Router der unter anderem einen OPEN VPN Server anbietet.

Die Verbindung klappt auch (bekomme die IP 192.168.0.xxx) einwandfrei allerdings habe ich keinen Zugriff auf mein Netzwerk zuhause obwohl der Router die Routing Tabelle automatisch setzt.

Das einzige was klappt ist der Zugriff auf 192.168.1.1 also auf den Router

Vielleicht findet von euch ja jemand den Fehler:

VPN Einstellungen
Nach dem Verbinden schaut die Routing Tabelle wie folgt aus (xx.xxx.238.x ist meine IP Adresse)
und das Protokoll spuckt folgendes aus
Sep 10 21:56:43 openvpn[2139]: 89.144.235.111:50805 TLS: Initial packet from [AF_INET]89.144.235.111:50805, sid=5cacf2f6 3869caa0
Sep 10 21:56:44 openvpn[2139]: 89.144.235.111:50805 VERIFY OK: depth=1, C=TW, ST=TW, L=Taipei, O=ASUS, CN=RT-AC56U, emailAddress=me@myhost.mydomain
Sep 10 21:56:44 openvpn[2139]: 89.144.235.111:50805 VERIFY OK: depth=0, C=TW, ST=TW, L=Taipei, O=ASUS, CN=client, emailAddress=me@myhost.mydomain
Sep 10 21:56:45 openvpn[2139]: 89.144.235.111:50805 PLUGIN_CALL: POST /usr/lib/openvpn-plugin-auth-pam.so/PLUGIN_AUTH_USER_PASS_VERIFY status=0
Sep 10 21:56:45 openvpn[2139]: 89.144.235.111:50805 TLS: Username/Password authentication succeeded for username 'vpnuser1'
Sep 10 21:56:45 openvpn[2139]: 89.144.235.111:50805 Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
Sep 10 21:56:45 openvpn[2139]: 89.144.235.111:50805 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Sep 10 21:56:45 openvpn[2139]: 89.144.235.111:50805 Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
Sep 10 21:56:45 openvpn[2139]: 89.144.235.111:50805 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
Sep 10 21:56:45 openvpn[2139]: 89.144.235.111:50805 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
Sep 10 21:56:45 openvpn[2139]: 89.144.235.111:50805 [client] Peer Connection Initiated with [AF_INET]89.144.235.111:50805
Sep 10 21:56:45 openvpn[2139]: client/89.144.235.111:50805 MULTI_sva: pool returned IPv4=192.168.0.6, IPv6=(Not enabled)
Sep 10 21:56:45 openvpn[2139]: client/89.144.235.111:50805 MULTI: Learn: 192.168.0.6 -> client/89.144.235.111:50805
Sep 10 21:56:45 openvpn[2139]: client/89.144.235.111:50805 MULTI: primary virtual IP for client/89.144.235.111:50805: 192.168.0.6
Sep 10 21:56:46 openvpn[2139]: client/89.144.235.111:50805 PUSH: Received control message: 'PUSH_REQUEST'
Sep 10 21:56:46 openvpn[2139]: client/89.144.235.111:50805 send_push_reply(): safe_cap=940
Sep 10 21:56:46 openvpn[2139]: client/89.144.235.111:50805 SENT CONTROL [client]: 'PUSH_REPLY,route 192.168.1.0 255.255.255.0,dhcp-option DNS 192.168.1.1,route 192.168.0.1,topology net30,ping 15,ping-restart 60,ifconfig 192.168.0.6 192.168.0.5' (status=1)
Vielleicht hat ja jemand einen Tipp für mich :)

Danke schonmal im voraus

Grüße
Patrick
 
Zuletzt bearbeitet:

psimon87

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
Aug. 2012
Beiträge
9
@azereus: Also so wie sich deine Frage anhört fehlt da ein Eintrag :rolleyes:

Ich dachte das macht die Routing Tabelle :rolleyes: Habe dort nichts eingetragen da ich gesehen habe das nach der Verbindung die Einträge vorhanden waren. Muss dazusagen habe früher ein paar mal einen VPN Tunnel (über normales PPTP) zu meinem Server hergestellt das ging aber alles nur so - sagen wir mal es hat halt funktioniert :D - wobei man aber auch Sagen muss das waurde auf einem Windows Home Server mittels "Routing- und RAS" eingerichtet und da hat er ja schön brav alles selbst in die Routing Tabelle des Servers gelegt. Sonst habe ich überhaupt keine Erfahrung mit VPN. Ich dachte mir nur ich versuch es einfach mal wenn der Router die Funktion schon anbietet.
 
Zuletzt bearbeitet:

Raijin

Admiral
Dabei seit
Nov. 2007
Beiträge
9.586
Kleiner, aber feiner Tip: Wähle für das VPN und das Heimnetz unbedingt ein anderes Subnetz!

Bist du zB im Hotel oder beim Kumpel, wo im LAN genau das Subnetz deines VPNs verwendet wird, kannst du deinen VPN-Tunnel vergessen. Doppeltes Subnetz am LAN- bzw. TUN/TAP-Adapter -> Aus die Maus

Auch das Heimnetz sollte man anders wählen, weil sich sonst ein ähnliches Problem ergeben kann. Der Tunnel wird zwar hergestellt, aber es kann keine Route in das Heimnetz gesetzt werden, weil es bereits eine Route gibt: Ins Hotel-/Kumpel-LAN.


Vorschlag:

Heimnetz: 192.168.123.0
VPN: 10.11.12.0

Such dir irgendwelche Netze aus dem Bereich 10.0.0.0 - 10.255.255.255 bzw. 192.168.0.0 - 192.168.255.255 bzw. 172.16.0.0 - 172.31.255.255. Am Besten auch jeweils aus einem anderen bereich, so sieht man sofort ohne nachzudenken "das ist eine VPN-IP". Die richtige Subnetz-Wahl ist bei VPNs ungeheuer wichtig. Im LAN-only ist das Jacke wie Hose, aber sobald man mehrere Subnetze mit einem VPN-Tunnel überbrückt, ist es wichtig, dass man keine Überschneidungen hat. Gerade die unteren 192er Netze sind extrem häufig!

Das ist so als wenn du in Berlin einen Brief zur Post bringst mit der Adresse "Bahnhofstraße 1" ohne Angabe der Stadt. Der Postbote bringt den Brief tendentiell in die Berliner Bahnhofsstraße obwohl du eigentlich nach Hamburg schreiben wolltest.. Oder war es doch Leipzig? Frankfurt? Wo gab's die Bahnhofsstraße nochmal? Oh.. Die gibt es überall.....


Zu deinem eigentlich Problem: Wenn ich das Webinterface richtig interpretiere, sollte "Push LAN to Clients" heißen, dass die Route ins LAN hinter dem VPN-Server zum VPN-Client ge"push"ed wird. Die Route scheint auch ok, aber es spielen noch ein paar andere Dinge mit rein. Deine Quell-IP ist ja nicht aus dem HeimLAN. Evtl. reagiert das Zielsystem (zB PC) nicht richtig und antwortet einfach nicht auf einen Ping aus einem fremden Netzwerk. Firewall-Einstellungen prüfen.. Die Frage ist auch ob der Router den Ping überhaupt ins LAN weiterleitet.
 
Zuletzt bearbeitet:

psimon87

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
Aug. 2012
Beiträge
9
Danke für die ausführliche Antwort. Werde mir das ganze nächste Woche mal anschauen und dann nochmal berichten :)
 
Top