automatischer Start

CED999

Lieutenant
Dabei seit
Juni 2011
Beiträge
860
Hallo Alle,

ich habe folgendes Problem ich nutze einen USB mit Hardware Verschlüsselung. Ich nutze Win7 64 bit. Bis jetzt war es immer so ich stecke den Stick rein und es startet automatisch die Software auf dem Stick, die mir die Passworteingabe anzeigt damit ich den Stick öffnen kann.

Es ist jetzt so, dass ich zu Testzwecken mein System mit einer AcronisCD gebootet habe und dann den Stick eingesteckt habe. Acronis sagte mir dann das wäre ein CD Laufwerk und seit diesem Moment startet der Stick unter Windows nicht mehr automatisch, ich kann die Software starten passwort eingeben - alles ganz normal. Nur er startet auch nicht mehr automatisch wenn ich die automatische Wiedergabe für alle Medien angebe.

Was hat Acronis mit dem Stick gemacht? Und wie fixe ich das

P.S. Der Stick hat eine Einstellung auf default zurücksetzen, was ich auch gemacht habe- hilft aber nichts...
 
Dabei seit
Aug. 2011
Beiträge
147
Ich kenne mich da jetzt nicht so gut aus, aber gibt es auf dem Stick eine unverschlüsselte autorun.inf?
 

CED999

Lieutenant
Ersteller dieses Themas
Dabei seit
Juni 2011
Beiträge
860
Sieht so aus als ob Du dich ganz gut auskennst :) Ja gibt es..
 

Yakomo

Lt. Commander
Dabei seit
Dez. 2008
Beiträge
2.018
Wäre recht gut, wenn du noch den Stick nennen könntest.
Dann kann jemand der etwas ähnliches besitzt oder jemand der Lust hat zu googeln dir besser helfen.

EDIT:
Merci!

Zur *.inf: Die sieht gut aus, vorausgesetzt SecureDataUSBDrive.exe befindet sich wirklich in keinem Unterordner!?
 
Zuletzt bearbeitet:

CED999

Lieutenant
Ersteller dieses Themas
Dabei seit
Juni 2011
Beiträge
860
[AutoRun]
icon=SecureDataUSBDrive.ico
open=SecureDataUSBDrive.exe
label=Verbatim Secure Data USB Drive

und so sieht das aus...
Ergänzung ()

Hi Yakomo,

Secure Data oder Secure'n'Go (stand beides auf der Packung) von Verbatim...
Ergänzung ()

Ja ist so die Dateien liegen direkt drauf.. Hat das was mit Treibern in Windwos zu tun? funktioniert das auslesen der .inf nur wenn ein bestimmter Treiber für das Gerät installiert ist?
Ist irgendwie schon komisch...
 

Yakomo

Lt. Commander
Dabei seit
Dez. 2008
Beiträge
2.018
Wenn du keine allzu wichtigen Dinge auf deinem Stick hast, könntest du mal probieren, ihn mit der Herstellersoftware zu aktualisieren.

Direktdownload: http://www.verbatim.de/de_7/binarydata_u3updater-1-0-5-5-verbatimeurope-41-1-0-0-exe_3859.exe
Herstellerseite: http://www.verbatim.de/de_7/downloads_drivers_337_0_1.html

(muss mit Adminrechten gestartet werden)

EDIT: Kann ich anhand der von dir gegebenen Informationen nicht wissen. :p
Laut deiner *.inf wird auch keine driver.exe sondern SecureDataUSBDrive.exe gestartet... ggf. manuell abändern! Aber nicht das ich dann Schuld bin, wenn was anderes nicht geht, weil die SecureDataUSBDrive.exe nicht gestartet wird ;)
 
Zuletzt bearbeitet:

CED999

Lieutenant
Ersteller dieses Themas
Dabei seit
Juni 2011
Beiträge
860
Hi danke für die Mühe aber das ist es nciht.. Die Software auf der Seite ist auch nicht die Software die auf dem Stick ist, da mache ich eher was kaputt. Punkt ist die driver.exe startet ja wenn ich drauf doppelclicke - d.h. "softwaremäßig" funktioniert alles. Der Prozess scheitert am Anfang die autorun.inf wird nicht ausgeführt.

Cheers
 
Dabei seit
Aug. 2011
Beiträge
147
Trag doch einfach mal die Zeile open=driver.exe zusätzlich in die autorun.inf mit ein. Das könnte schon reichen.
 

CED999

Lieutenant
Ersteller dieses Themas
Dabei seit
Juni 2011
Beiträge
860
Also das Problem ist folgendermaßen:

Ich verstehe die Logik zwar nicht (die autorun.inf verweist doch schon richtig auf open=..... wie soll er jertzt eine nicht vorhanden "driver.exe finden"??) - wollte es aber trotzdem machen, nur leider lässt mich der Stick einfach nicht.

Der Stick ist in zwei Partitionen unterteilt, die erste ist nicht verschlüsselt, da liegen die Dateien drauf wie autorun.inf und worauf die autorun.inf verweist. Die zweite ist die verschlüsselte Partition die dann nach eingabe des Passwoert geöffnet wird.

Wenn ich nun versuche die Autorun.inf zu speichern passiert folgendes: Windows sagt mir ich soll einen Datenträger in Laufwerk G einlegen und im Arbeitsplatz ändert sich die Anzeige von Laufwerk G in ein CD Laufwerk...

Hersteller Hotline hat natürlich auch keinen Plan.. Deswegen einen neuen Stick kaufen, ist jetzt nicht die Welt aber schon unnötig irgendwie. Oder beabsichtig der Hersteller das etwa
 

Yakomo

Lt. Commander
Dabei seit
Dez. 2008
Beiträge
2.018
Also das Problem ist folgendermaßen:

Ich verstehe die Logik zwar nicht (die autorun.inf verweist doch schon richtig auf open=..... wie soll er jertzt eine nicht vorhanden "driver.exe finden"??)][...]
Wie jetzt, du sagst doch selber:
Hi danke für die Mühe aber das ist es nciht.. [...]
Punkt ist die driver.exe startet ja wenn ich drauf doppelclicke - d.h. "softwaremäßig" funktioniert alles. [...]
Hersteller Hotline hat natürlich auch keinen Plan.. Deswegen einen neuen Stick kaufen, ist jetzt nicht die Welt aber schon unnötig irgendwie. Oder beabsichtig der Hersteller das etwa
Ich kann mir ehrlichgesagt nicht vorstellen, dass der Fehler so gravierend ist, dass man Ihn nicht mehr beheben kann. Hast du es eigentlich schon mal an einem anderen PC getestet?!.

Wenn es nicht geht, dann versuche dein Glück und tausche ihn um. Musst nur glaubhaft versichern, dass du nichts mit dem "Fehler" zutun hast...
(So alt wird er ja noch nicht sein oder?)
 
Zuletzt bearbeitet:

CED999

Lieutenant
Ersteller dieses Themas
Dabei seit
Juni 2011
Beiträge
860
Hi,

also in meinem Post gestern von 19:05 steht doch genau drin was in der Autorun.inf steht:

"open=SecureDataUSBDrive.exe"

der Post klang nun etwas so als ob ich screiben soll:

open=drive.exe

was für mich keinen Sinn machen würde....

Cheers
 
Dabei seit
Aug. 2011
Beiträge
147
Ich hatte dich so verstanden, dass du, um auf die verschlüsselten Daten zu zugreifen die Datei driver.exe im Stammverzeichnis deines Stick ausführens musst. Damit das automatisch geschehen kann, würde ich einfach zusätzlich den Befehl open=driver.exe in die autorun.inf eintragen.
Den Befehl
open=driver.exe
kannst du dabei einfach unter den Eintrag
open=SecureDataUSBDrive.exe
in die autorun.inf schreiben.
Also ein mögliches Beispiel wäre dann:

[AutoRun]
icon=SecureDataUSBDrive.ico
open=SecureDataUSBDrive.exe
open=driver.exe
label=Verbatim Secure Data USB Drive

Der Sinn der dahinter steckt ist ein ganz einfacher, du hattest geschrieben, dass du die driver.exe immer manuell ausführen musst, was vorher nicht der Fall war. Durch den Eintrag wird die Datei aus dem Autostart heraus aufgerufen.

Bei deinem Schreibschutz Problem, habe ich mit einem kurzen Google Versuch (na gut, es war Bing aber wer will da schon kleinlich sein) auf folgender Seite (klick)einen interessanten Eintrag gefunden:

Mein USB-Stick ist schreibgeschützt - wie bekomme ich das weg?

Immer wieder höre ich Klagen, USB-Sticks könnten an einem bestimmten Rechner nicht mehr beschrieben werden. Insbesondere scheint das beim Formatieren zu passieren. Eine definitive Lösung habe ich dafür auch nicht, es sei denn den Schreibschutz-Schalter am USB-Stick :-)
Eine häufige Ursache für solche Probleme scheint zu sein, dass viele ihren USB-Stick nicht abmelden, ehe sie ihn abziehen. Windows speichert viel Verwaltungsinformation im Cache und schreibt manches erst später auf das Speichermedium. Folglich gibt es Zeiten, in denen die Verwaltungsinformation auf dem Massenspeicher inkonsistent ist. Das Abmelden stellt sicher, dass alle Daten auch auf den Massenspeicher (sprich USB-Stick) geschrieben werden.
Mögliche Maßnahmen:

In der Registry kann man per USB angeschlossene Massenspeichergeräte schreibschützen: Der Schlüssel HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\StorageDevicePolicies kann einen DWort-Eintrag "WriteProtect" enthalten.

  • Wert 0 = Schreibschutz ist nicht aktiviert
  • Wert 1 = Schreibschutz ist aktiviert
Vielleicht hilft dir das weiter. Sämtlich Rechtschreib- und Grammtikfehler schiebe ich auf das halbe Glas Wein, dass ich noch nicht ausgetrunken habe.
Ergänzung ()

Hab gerade ein bisschen zur autorun.inf gelesen und festgestellt, dass ein zweiter "open=programm" Befehl nicht zulässig ist. Schade.
 
Zuletzt bearbeitet:
Top