DTS Sound & Symbole im Systray

crusher143

Cadet 4th Year
Dabei seit
Sep. 2005
Beiträge
89
Hi Leute,

also folgendes Problem, alle Videos funzen soweit nur bei Videos mit DTS Sound fehlt der Sound. Nun hab ich nachgeschaut ob ich einen DTS Codec finde aber pustekuchen bis auf AC3 Filter nix gefunden aber den hab ich ja installiert. Der scheint unter Windows7 auch nicht richtig zu funktionieren oder ? Jedenfalls seh ich im Konfg. Tool wenn ein AC3 Film läuft beim EQ. gar nix aber immerhin funzen AC3 Filme einwandfrei.

Kann es sein das DTS im moment von Windows 7 nicht supportet wird oder so ? Ansonsten wäre ich für einen Link dankbar wo ich mir einen DTS Codec downloaden kann oder liegts an was ganz anderem ? Ich hab ka .... bin echt genervt.

Das andere sind die Symbole im Systray da scheint Windows 7 auch nach lust und laune Icons mal auszublenden und mal anzuzeigen egal was ich eingestellt habe.

Über jeden Tipp dankbar.
 
Bei mir gehen alle Filme mit DTS Sound (DVD´s und Mkv´s) ohne Probleme bei Win 7 Ultimate x64.
VLC Player und Media Player Classic.
Als Codec nutze ich Fddshow
 
Mhhh interessant, ich hab mal diesen VLC Player gedownloadet und installiert dort funktioniert der Sound auch bei DTS Filmen. Aber das muss doch auch mit Windows Media Player funzen, in XP isses auch kein Problem.

Also die Codecs sind dann ja drauf aber wieso will Media Player nicht ? :x.
 
Der Mediaplayer ist da oft ein wenig eigen.

Teste mal das Win7 Codec Package von Shark007. Wenn du ne 64bit Version hast, musst du auch noch das 64bit Addon installieren.

Damit sollte auch alles im Mediaplayer abspielbar sein.
 
Hi da bin ich wieder :p

Also das Codec Pack von Shark läuft bei mir mal gar nicht gut, da spielt er nicht mal die mkv Videos ab wenn ich sie in .mpg umbenenne, mit anderen Packs kein Problem nur wie gesagt der DTS Sound will nicht über Windows Media Player aber mit Sharks geht so ziemlich nix ausser normale Videos.

Ich hab nur die 32bit Version von Windows 7 und zwar Ultimate, und als Soundkarte hab ich die Sounblaster X-Fi Titanium.
 
Zuletzt bearbeitet:
Zuletzt bearbeitet:
Danke für die Mühe, leider kann ich den Treiber unter Windows 7 nicht installieren da er mit einer Fehlermeldung abbricht.

Glaub auch ehrlich gesagt nicht das es daran liegt, hatte bischen umgeguckt und da gab es dieses Pack das war vom letzten Jahr das man sich seine Soundkarten upgraden kann um zu encoden nicht decoden .... aber ich hab bei meiner nachgeschaut und ich kann DTS Digital aktivieren nur will ich ja nicht encoden sondern decoden ^^.

Keine Ahnung mehr, hab schon ettliches probiert aber will einfach nicht unter Windows Media Player, werde dann wohl DTS Filme unter dem VLC Player abspielen müssen :X. Ausser es hat natürlich noch jemand den rettenden Tipp :p.

Ansonsten danke an alle.
 
So, ich habe mit dem Treiber noch mal eine andere Möglichkeit ausprobiert.

Die .exe-Datei erst mal in einem Ordner entpacken. WinRar kann die Sache, falls Du den Befehlssatz nicht kennst. Gebe zu, ich derzeit auch nicht.

Danach gehst Du auf die Installations-Datei und wählst mit der anderen Maustaste:

Behandeln von Kompatibilitätsproblemen - Probleme behandeln (die untere Variation)

Haken an: Das Programm war in früheren Versionen etc. - Windows Vista auswählen

Programm starten und den Rest wirst Du kennen.

Eine andere Möglichkeit fällt mir leider auch nicht mehr ein. Zumindest wird der Treiber ohne Fehlermeldung installiert.
 
Also wenn du Probleme mit dem Codec von Shark hast, liegt bei dir definitv irgendwas mit den Codecs im argen.

Ich habe das Codec-Package auf 5 oder 6 Rechnern mit Win7 installiert und bei allen funktioniert die Wiedergabe sowohl im Mediaplayer als auch im Mediacenter wunderbar. OHNE umzubenennen oder ähnliches.

Vielleicht solltest du mal alle zusätzlich installierten Codecs nochmal entfernen und dann das Shark-Package neu installieren.
 
Wie wird denn ein Codec übersetzt? Durch Software oder wird hierfür auch die Hardware benötigt?
 
Es gibt natürlich auch Hardwareencoding, aber prinzipiell wird das per Software realisiert.
 
Wofür brauche ich denn dann eine Soundkarte oder einen Chip?
 
Zuletzt bearbeitet:
Also das Windows 7 war ja eine Neuinstallation da war nix drauf, als erstes hatte ich dieses Pack von Shark installiert aber es will nicht. Ich meine klar normale Filme und alles läuft ja wunderbar aber sobald ich .mkv abspielen will oder es umbenenne in .mpg will es mit den Shark Codecs nicht da kommt immer der Fehler das er nicht weiß was er mit der Datei anfangen soll.

Mit anderen Packs gehts nur geht der Sound nicht :(. Das ist immer das erste was ich mache, Windows installieren, Treiber und erstmal Codecs und austesten.

Beim VLC Player scheint er die Codecs mit integriert zu haben, ich hatte alle Codecs deinstalliert und er hat trotzem die mkvs abgespielt mit Sound sogar ^^. Oben im Menu zeigt er mir bei den Sound Codecs auch an German DTS bla bla ...

Installier ich diesen AC3/DTS Decoder und wähle aus das er sich bei AC3/DTS files einschalten soll funktionierts auch bei AC3, bei DTS allerdings nicht also man sieht ja immer das Symbol im Systray vom AC3 Decoder. Bei DTS allerdings schaltet er sich nicht mal ein obwohl es eingestellt ist hmmm.

Ich werd jetzt mal diesen Treiber da oben von Noobinator probieren aber erhoffe mir nachdem ich schon soviel probiert habe nicht wirklich allzuviel. Hatte ja sogar schon einen DTS Decoder auf koreanisch installiert weil jemand im Netz auch Probleme mit Windows 7 und DTS im Windows Media Player hatte, ging aber auch nicht.

EDIT: Also das DDL Pack das hab ich sogar schon installiert, das war bei meinen Treibern mit dabei also er sagt ja bei der Installation das das gleiche Pack schon installiert ist und ob ich das mit der Version ersetzen möchte also ich glaube das brauch ich dann gar nicht aus testen, trotzdem danke.

EDIT2: wie ich gerade sehe geht der Sound bei Videos mit LPCM auch nicht im Windows Media Player, WTF Ist das ich hab selber noch von nem anderen Codec Pack nur die Sound Codecs installiert und da war alles dabei, AC3, DTS, LPCM usw ... und trotzdem gehts nicht ... man ich dreh hier langsam ab :X
 
Zuletzt bearbeitet:
Du hast doch oben geschrieben, dass du schon den AC3 Filter drauf hattest, bevor du den Sharkcodec installiert hast.

Das könnte je nachdem Probleme bereiten.

Der "Fehler", dass der Mediaplayer dir sagt, dass er mit der Datei nix anfangen kann, ist kein wirklicher Fehler. Einfach auf trotzdem öffnen klicken und schon läuft die MKV-Datei auch im Mediaplayer.

Wenn du die Datei umbenennst, versucht der Mediaplayer die wohl mit nem anderen Codec darzustellen.

Sharkpackage drauf, die MKV mim Mediaplayer öffnen, auf die Frage ob die Datei trotzdem geöffnet werden soll mit JA antworten und schon sollte es laufen ;)
 
Also ich hab jetzt Windows 7 komplett neu installiert, Partition gelöscht / formatiert und neu drauf. Danach hab ich versucht ein Video mit LPCM wiederzugeben, ging. MKV ging nicht war klar, hab dann Sharks Codec Pack installiert, LPCM geht immer noch wunderbar immerhin ein Fortschritt. MKV geht nicht (ich weiss was du meinst das man den Start der Datei trotzdem erzwingt diese Option kam aber gar nicht), in mpg umbenannt dann gehts aber der Sound immer noch nicht.

Dann hab ich Soundtreiber installiert, meine Boardtreiber, Grafiktreiber etc ... geht immer noch nicht hab dann den VLC Player installiert und dort ausprobiert, geht.

Nachdem ich dann hier dein Post gelesen habe bin ich in die "Standardprogramme" Verwaltung gegangen und hab .mkv für Windows Media Player zugewiesen weil ich es eben ausprobieren wollte und nun startet er mkv über Windows Media Player und der Sound geht auch oO.

Ich denke mal das Problem lag daran das ich die mkv in mpg umbenannt habe und er deswegen es falsch abgespielt hat. Komisch find ich das trotzdem, ich mach das schon seit jeher so in XP auch mit .VOB Files und hatte nie Probleme.

Hier in Windows 7 hatte ich damit ja auch keine Probleme eigentlich ausser das Video File hat DTS Sound.

Wie dem auch sei bin nun glücklich das alles funzt =)

Danke an alle für die Tipps und Mühe.

TLDR: ^^ mkv Endung bei "Standardprogramme" MANUELL (warum er das nicht automatisch gemacht hat ??? keine Ahnung) dem Windows Media Player hinzufügen und Dateiendungen halt in .mkv lassen dann geht alles.
 
Sehr schön :)

Das Problem beim Ändern der Dateiendung liegt daran, dass der Mediaplayer für bestimmte Endungen bestimmte Codecs nutzt.
Bei VOB-Dateien und anderen mag das kein Problem sein, bei den MKV-Dateien ist das eher ungünstig.

Hauptsache es funktioniert :)
 
Zurück
Top