Externe Festplatte wird beim Datentransfer immer langsamer

Point Loma

Lieutenant
Registriert
Juli 2008
Beiträge
853
Ich habe mir eine neue Festplatte gekauft und versuche jetzt Daten drauf zu spielen.

Ich nutze Linux Mint, das Dateiformat der Festplatte ist NTFS.

Der Datentransfer beginnt bei ca. 130mb/s und wird dann immer langsamer, nach 1-2 Minuten sind es nur noch 4mb/s, Tendenz fallend. S.M.A.R.T zeigt keine Auffälligkeiten. Formatieren hat nicht geholfen. Verschiedene USB-Ports brachten auch keine Besserung.
In /etc/modules habe ich bereits xhci_hcd eingefügt, um sicher zu gehen, dass der USB3.0-Treiber geladen wird. Auch keine Besserung.

Was kann ich noch machen? Für Hilfe bin ich dankbar.
 
Die Geschwindigkeit ist abhängig von der Art der Dateien. Ist es ein großer Image, dann läuft es viel schneller, als wenn es kleine Dateien sind. Dann bricht die Leserate massiv ein
 
Evlt. kommen nach kurzer Zeit viele kleine Dateien (möglicherweise TXT oder JPG Files oder sowas), dass erzeugt sehr viele IOs und da werden Datenträger i.d.R. recht langsam... Lass den copy doch einfach laufen und schau was passiert.

Würde prognostizieren, dass die Transferrate auch wieder ansteigt, wenn große Files (z.B. ISOs) dran sind...
 
Nein, daran liegt es nicht. Ist unabhängig der Dateigröße.
 
Da greifen vielleicht noch andere Programme auf die neue Festplatte zu. Z. B. Antivirenprogramme, die heutzutage gerne ständig und überall was scannen(im Hintergrund) müssen. Eventuell mal abschalten. Teste auch mal die Geschwindigkeit beim kopieren von der neuen Platte auf die vorhandenen Laufwerke.
 
Nutzt Du das Original Kabel? Ohne Verlängerung? Direkt an einem USB 3 Port? Kabel sind bei USB 3 auch immens wichtig.
 
NOTAUS schrieb:
Da greifen vielleicht noch andere Programme auf die neue Festplatte zu. Z. B. Antivirenprogramme, die heutzutage gerne ständig und überall was scannen(im Hintergrund) müssen. Eventuell mal abschalten. Teste auch mal die Geschwindigkeit beim kopieren von der neuen Platte auf die vorhandenen Laufwerke.

Keine weiteren programme greifen drauf zu. Antivirenprogramm habe ich nicht.
Ergänzung ()

BlubbsDE schrieb:
Nutzt Du das Original Kabel? Ohne Verlängerung? Direkt an einem USB 3 Port? Kabel sind bei USB 3 auch immens wichtig.

Ja, Originalkabel, keine Verlängerung.
 
Lese- UND Schreibcache aktiviert?
 
Probier's doch einfach aus, hast doch nichts zu verlieren... :rolleyes:
 
Hast du schon mal geschaut, wie es sich verhält, wenn du ein für Linux geeignetes Dateisystem nutzt?
 
Wie wird die Partition gemountet (manuell/fstab/auto)? Und wie sieht Ausgabe von "mount" aus?
Ergänzung ()

Schreibcache aktiviert?

hdparm -W /dev/sdX
 
Du hast ja jetzt schon einiges versucht..
Teste aber doch bitte noch zwei weitere Dinge:

(1) falls Du die Möglichkeit hast: testen, ob sich die Platte an einem anderen PC genauso verhält, um ausschließen zu können, dass es nicht evtl. an anderen Komponenten liegt

(2) die Platte per SeaTools auf Fehler analysieren lassen
 
Eine 2.5" mit 5TB dürfte selbst bei 15mm Bauhöhe wahrscheinlich SMR haben, oder? Mehr als 3TB bietet nur Seagate in 2.5" an und nur Seagate nutzt meines Wissen bei 2.5" HDDs überhaupt SMR. Dann kann man nur die paar GB des OnDisk Caches schnell beschrieben und danach kann die Schreibrate teils massiv einbrechen.
 
Zurück
Oben