Fedora 11 Auflösung/boot-probleme

HeavensBlade

Cadet 4th Year
Dabei seit
Feb. 2007
Beiträge
109
Hallo zusammen,

Ich hab auf meinen Media PC jetzt mal Fedora Core 11 gemacht.
Hab den PC an meinem Monitor installiert und dann an den Fernseher geschlossen um ihn als Media PC zu nutzen. Bei dem Fernseher handelt es sich um einen Philips 42" mit 1920*1080 Pixeln. Der PC erkennt aber nur einen Philips 40" und lässt eine Maximale Auflösung von 1360*768 zu. Nachdem ich dann eine xorg.conf erstellt habe die so:
Code:
Section "Screen"
	SubSection "Display"
		Depth     24
		Modes    "1920x1080"
aussieht, bleibt der Rechner beim boot hängen. Um genau zu sein
Code:
atd starten:
Kann mir jemand helfen?
 

Epyx

Lt. Junior Grade
Dabei seit
Feb. 2006
Beiträge
333
hmm hatte ich nach nam Kernelupdate auch. Da hat der Treiber für meine Nvidia-Graka Zicken gemacht. Hatte ihn dann deinstalliert und erst einmal den freien nouveau benutzt bis ein neues kmode-packet bei rpmfusion verfügbar war.
 

HeavensBlade

Cadet 4th Year
Ersteller dieses Themas
Dabei seit
Feb. 2007
Beiträge
109
naja gut, aber wie kann ich was am system machen wenn der rechner nicht mehr bootet?
 
C

CaptainStor

Gast
Hallo,

versuche nicht die Auflösungen manuell ein zu stellen, um das richtig zu machen müsste man nämlich noch mehr eingeben, vertikale und horizontale Bildwiederholfrequenz und sowas. Die neueren Geräte unterstützen alle DPMS oder DMPM, am besten ist es eins von beiden als Parameter in xorg.conf an zu geben. Musste halt ausprobieren was von beiden funktioniert.
Meine xorg.conf sieht so aus:

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder26)  Fri Jan 11 14:26:48 PST 2008

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    FontPath        "/home/gege/.fonts/"
#    FontPath        "/usr/share/fonts/TrueType"
#    RgbPath         "/usr/share/X11/rgb"
    ModulePath      "/usr/lib64/xorg/modules"
    FontPath        "/usr/share/fonts/misc/"
#    FontPath        "/usr/share/fonts/TTF/"
#    FontPath        "/usr/share/fonts/OTF"
#    FontPath        "/usr/share/fonts/Type1/"
#    FontPath        "/usr/share/fonts/100dpi/"
#    FontPath        "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
    Load           "glx"
    Load           "extmod"
    Load           "xtrap"
    Load           "record"
#    Load           "GLcore"
    Load           "dbe"
#    Load           "dri"
    Load           "freetype"
    Load           "type1"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbRules" "xorg"
    Option         "XkbLayout" "de"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "AllowEmptyInput" "off"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mouse0"
    Option         "Corepointer"
    Option         "Emulate3Buttons" "no"
    Option         "Buttons" "9"
    Option         "ZAxisMapping" "4 5"
#    Option         "ButtonMapping" "1 2 3 4 5 8 9 6 7"
    Option         "Resolution" "2000"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Card0"
    Driver         "nvidia"
    VendorName     "nVidia Corporation"
    BoardName      "Unknown Board"
    Option      "AddARGBGLXVisuals" "True"
    Option      "UseEvents"         "False"
    Option      "RenderAccel"       "True"
    Option      "XAANoOffscreenPixmaps"
    Option      "TexturedVideo" "on"
#    Option      "VideoOverlay" "off"
#    Option      "OpenGLOverlay" "on"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "DPMS" "true"
    Option         "Coolbits" "1"
    Option         "NoLogo" "true"
    Option         "RenderAccel" "true"
    Option         "AllowGLXWithComposite" "true"
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "enable"
EndSection
Versuchs erstmal mit DPMS in "Section "Screen" und "Section Monitor", wenns damit nicht klappt dann mit DMPM. Ich habe Gentoo Linux aufm Rechner, wenn ich aus irgend einem Grund Linux nicht hochfahren kann nehme ich die Gentoo CD und mounte meine Festplatte per Hand, kannste auch mal versuchen.
 

janfal

Cadet 1st Year
Dabei seit
Dez. 2006
Beiträge
15
Kannst du mit strg+alt+F2 auf einen konsole umschalten? wenn ja logge dich ein und benenne die /etc/X11/xorg.conf um, lösche sie oder leere sie. wenn dir ne grafische oberfläche lieber ist musst du von einer live cd starten.

wenn nein probiere mal am anfang des bootprozesses die taste "I" wiederholt zu drücken. du solltest dann in den interactive boot modus kommen, wo du das starten jedes dienstes bestätigen musst. Wenn dann am ende X/Xorg gestartet werden soll verhinderst du das und wechselst wie oben beschrieben in eine textconsole...
 

Grugeschu

Lt. Commander
Dabei seit
Juli 2006
Beiträge
1.602
Für Medien würde ich eher Debian oder Ubuntu nehmen, denn ich finde da ist Fedora mit einer der schlechtesten Distris ....

Aber zum Thema, hast du schon mal geguckt was xrandr sagt was du für Monitore hast?
Lösch die config und mach mit nvidia-config oder wie es bei Nvidia auch heißen mag eine neue.
Kann es sein das du einfach nur zu viel Hz für deinen Fernseher angegeben hast?
 

r34ln00b

Lieutenant
Dabei seit
Feb. 2006
Beiträge
1.004
Und das soll man dir glauben, ohne jegliche Argumente?
Ich würde erstmal auch als Tipp nennen, die xorg.conf von Fedora neu-erstellen zu lassen.
 
Top