GRUB findet Windows 7 Loader nicht

vollsparte

Ensign
Registriert
Juli 2015
Beiträge
165
Hallo Leute,
habe direkt nach dem einen gelösten Problem schon das nächste.
Habe gezwungenerweise meinen Rechner neu aufsetzen müssen. Hatte vorher ein Triple Boot System (Win7/Win7/Xubuntu).
Ein Win7 auf SSD alleine, das andere Win7 mit Xubuntu auf einer anderen SSD.
Nun habe ich die größere SSD mit den 2 Betriebssystemen formatiert, Windows neu drauf, danach Linux neu drauf.

Das hat auch funktioniert und ich konnte mit GRUB entweder Xubuntu oder Win7 auswählen.

Nun ist es so, dass ich das andere Win7 auch da drin haben wollte, also EasyBCD her, das fand aber leider keine bcd Dateien und konnte daher auch nichts einstellen.

Also Win7 Reparaturinstallation (die mehrmals fehlgeschlagen ist) um den Bootloader wiederherzustellen und jetzt sind alle Windows Loader weg. Ich kann im Moment nur noch über Xubuntu arbeiten. Das ist leider problematisch, da ich bis Montag eine Abgabe habe und dafür Microsoft Office brauche...

Wenn mir jemand sagen könnte, was ich machen muss damit ich 1. wieder mein Windows booten kann und 2. wie ich danach das zweite Win7 einbinden kann (Egal ob über GRUB oder über Windowsloader, welcher nach Auswahl im GRUB geladen wird - so wie es früher war) dann wäre das wunderbar!

Übrigens: Diese ominöse 100mb Partition von Windows 7, die üblicherweise vorhanden ist (System-reserviert) ist nicht da.
 
Hast du eine Installation vielleicht im UEFI, die andere im BIOS Mode installiert? Wenn ja, dann ist das die Lösung. GRUB bzw. auch Windows erkennt nur UEFI - UEFI, oder BIOS - BIOS.
 
vollsparte schrieb:
Wenn mir jemand sagen könnte, was ich machen muss damit ich 1. wieder mein Windows booten kann und 2. wie ich danach das zweite Win7 einbinden kann
Das Ganze noch mal von vorn, ohne EasyBCD. Windows auf die große SSD installieren. Das Windows auf der kleinen SSD hat von dort aus gesehen einen Laufwerksbuchstaben. Angenommen, dieser Laufwerksbuchstabe ist Y, dann bindest Du es mit

bcdboot Y:\Windows /l de-de

(als Administrator ausgeführt) in den Bootmanager ein und erzeugst damit einen Dual Boot. Diesen bindest Du anschließend, notfalls per Neuinstallation von Xubuntu, in GRUB ein.

Gruß, VZ ;)
 
... und wenn es ganz eillig gehen soll: Win7 unter Linux virtualisieren, Office drauf, arbeiten, Montag fertig sein ;)
 
Volume Z schrieb:
Das Ganze noch mal von vorn, ohne EasyBCD.

Wirklich alles, aber bitte nicht nochmal Windows installieren. Das dauert einen ganzen Tag alles wieder herzurichten und ich war gerade fertig geworden...

Mein PC hat zwar UEFI, aber ich benutze die Legacy Option (habe ja kein Windows 8 oder höher).

GRUB findet einen Windows 7 Loader, aber der ist da, wo eigentlich gar kein Windows installiert ist (Datengrab)

sda und sdb, die beiden SSDs, nimmt er nicht an.
Ich schätze mal es liegt an der fehlenden 100mb Partition, die wurde irgendwie nicht erstellt. Würde es helfen, bzw. ist es möglich, eine solche anzulegen?
 
Dann ist es einfach so, dass der Bootloader auf Deiner Datengrab HDD gelandet ist. Das passiert, wenn man Windows installiert und die Laufwerke angeschlossen lässt, auf denen Windows nicht drauf soll.

Windows installiert den Bootlader auf dem ersten erkannten Laufwerk. Und das muss nicht das Laufwerk sein, auf dem Du dann Windows installierst.

Du kannst versuchen, alle nicht Windows Laufwerke abklemmen. Die Windows DVD booten und den Bootloader reparieren zu lassen von der Reparaturfunktion.
 
Ich muss dazu sagen: Der Bootloader auf sdc ist schon vorher da gewesen, hat aber natürlich nie funktioniert. Vielleicht erkennt GRUB den auch nur als Boot weil es dort einen Ordner namens "Windows" gibt...

Ich bin gerade dabei mir mit Gparted eine 150MB Partition anzulegen mit dem Namen "System Reserved". Evtl versteht der Windows Reparaturdienst dann was er zu tun hat. Selbst wenn es mir Xubuntu dabei zerlegt: Das kann ich in 10 Minuten nachinstallieren :D

Ich werd da gleich nochmal alles ausprobieren und mich dann melden
Ergänzung ()

Bin jetzt schon etwas weiter. Habe mit Gparted die ganze Windows Partition nach Rechts geschoben und eine "System Reserved" Partition von 150mb angelegt mit dem Flag "boot". Danach konnte die Reparatur DVD die Windows Systeme finden und in den Bootloader schreiben. Funktioniert auch, allerdings kriege ich jetzt beim Win7 auf der großen SSD ein "Desktop wird vorbereitet" und dann startet er in ein temporäres Profil. Lasse gerade chkdsk laufen, hoffentlich bekriegt sich das wieder.
Ergänzung ()

Soooooooooo

Ich habs geschafft.
Habe mit müh und not regedit zum laufen gebracht und dort den hkey local machine/system/mounteddevices gelöscht. Danach hat er sich die richtigen Laufwerksbuchstaben wieder gesucht und ich konnte normal starten. Was bin ich froh!
 
Zurück
Oben