Laufwerksbuchstaben ändern sich - dadurch dann Problem mit Truecrypt

Hypocrisy

Admiral
Dabei seit
Nov. 2006
Beiträge
8.601
Moin,

hab n XPPro SP3. Läuft schon ewig. Truecrypt soll nach Systemstart einen Container mounten. Soweit kein Problem.
ABER:
Seit einiger Zeit nimmt Windows beim Start einen anderen Buchstaben für das DVD Laufwerk (D anstatt M), so dass D dann nicht mehr zum mounten verfügbar ist.

Kann man Windows irgendwo zwingen, immer denselben Buchstaben zu nehmen?

Danke.
Tobi
 

baFh

Captain
Dabei seit
Mai 2004
Beiträge
3.711
jo, computerverwaltung und dann datenträgerverwaltung, rechtsklick auf laufwerk und buchstaben ändern. geht auch anders über den arbeitsplatz, hab´ aber vergessen wie :lol:
 

Hypocrisy

Admiral
Ersteller dieses Themas
Dabei seit
Nov. 2006
Beiträge
8.601
Ja, wie ich den Buchstaben wieder ändern kann is doch pillepalle. Ich will, dass Windows unter keinen Umständen einen anderen verwendet, als den eingestellten.

Idee?

thx.
 

frogger9

Commodore
Dabei seit
Feb. 2008
Beiträge
4.193
dazu solltest du dir den Registry-Schüssel

HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices

ansehen. Dort sind alle DosDevices\ Buchstaben eingetragen, die Windows für die Volumes schon mal verwendet hat.
 

baFh

Captain
Dabei seit
Mai 2004
Beiträge
3.711
oh, entschuldigung für pillepalletips :lol:

anderer vorschlag:
finde heraus, was du in deinem system selbst verfummelt hast. bei meinen rechnern haben sich bis auf usb-LW-buchsteben nämlich noch keine sonstigen laufwerksbuchstaben von alleine verstellt. viel spass noch.

bis denne
 

Hypocrisy

Admiral
Ersteller dieses Themas
Dabei seit
Nov. 2006
Beiträge
8.601
Ja bei mir ja auch noch nie - bis jetzt....

Das Einzige was mir einfällt, sind ca. 4x Grakatreiber und Grakaumbauten in den letzten Wochen. Aber die haben m.E. wenig mit der internen LW-Vergabe zu tun.

Komisch ist auch, dass es nur ab und zu passiert. Die letzten drei Starts inkl. dem aktuellen lief es ohne Probleme.

Und des mit dem pillepalle ist ja nicht so gemeint. ;)


ach ja @ frogger9:

Deinen registry Tipp vertehe ich nicht. Bei LW D steht dort: TrueCryptVolume.
Was soll mir das nun helfen? An den HEX-Codes will ich nicht "verschlimm-basteln".
 
Zuletzt bearbeitet:

frogger9

Commodore
Dabei seit
Feb. 2008
Beiträge
4.193
am HEX-Code darfst du nichts ändern, sondern nur am DosDevices.

Aus zB. \DosDevices\D: macht man dann \DosDevices\M:
 
C

chiro*

Gast
Ahh sehr schön! :)
Da das mit dem Laufwerkbuchstaben hier gerade erwähnt wird: Wie ändert man das den nun in der registry? Einfach nur umbennen oder wahrscheinlicher die Variablen ändern? Und wenn ja wie?

Gruß, chiro*
 

frogger9

Commodore
Dabei seit
Feb. 2008
Beiträge
4.193
Zuletzt bearbeitet:

Hypocrisy

Admiral
Ersteller dieses Themas
Dabei seit
Nov. 2006
Beiträge
8.601
Okay, also simples Umbenennen.
Ist ja wirklich merkwürdig bei mir. Es tritt halt seit einigen Tagen nicht reproduzierbar auf.
PC wird normal runtergefahren und beim nächsten Start -zarong!!!!- ist das CDROM D:

Nun gut, wenn das wieder so sein sollte, werde ich nochmal schauen, ob in der registry dann auch was anderes steht, als jetzt (D: = TC-Volume).

thx so far.
Tobi
 
Top