MBR von C:\ defekt nach ziehen von USB Sticks während PC aus ist?!?

Radamant

Cadet 3rd Year
Dabei seit
Nov. 2008
Beiträge
41
Hallo zusammen,
ich weiß, die Überschrift liest sich wie Voodoo. Ich bin seit 25 Jahren mehr oder weniger aktiv an PCs und würde mich nicht als Neuling aber auch nicht als Guru bezeichnen. So etwas ist mir aber noch nie untergekommen und da ich nicht mal eine Ahnung habe wo ich nach Ursachen suchen sollte, wollte ich mal nachfragen, ob sowas überhaupt möglich ist. Die Vorgeschichte:

  • im ausgeschalteten Zustand habe ich einmal eine USB Festplatte abgezogen und ein anderes Mal einen USB Stick an verschiedenen USB-Ports
  • beim nächsten Booten, startete Win 10 einfach nicht mehr, der Bildschirm blieb nach der BIOS-Auflistung schwarz
  • UEFI Bootoptionen (Legacy und UEFI) brachten keinen Erfolg
  • Windows Boot-Stick wurde erstellt, Windowsreparatur erfolglos
  • über /bootrec und /fixmbr war die Wiederherstellung möglich
  • v.a. beim ersten Mal (nach Entfernung der Festplatte) war es ein riesiger Aufwand mit Neuinstallation, Images wiederherstellen etc, dauerte einen kompletten Tag

Die Fakten:
  • Win 10 ist auf einer SSD installiert
  • Die Partitionen sind intakt
  • Alle Dateien sind vorhanden
  • Es scheint ein Problem mit GPT und oder dem MBR zu geben
Beide Male hat der Rechner wie immer heruntergefahren, beim nächsten Start ist o.g. Problem aufgetreten. Entweder war das reiner Zufall oder es lag am abziehen der USB-Geräte im ausgeschalteten Zustand. Normalerweise mache ich das nicht, aber beide Male vor den Problemen habe ich eben dies gemacht und es scheint mir die einzige Gemeinsamkeit zu sein, die einen Zusammenhang erklären könnte.

Ist sowas möglich? Während der PC AUS ist?! Wie kann da der MBR der SSD drauf gehen? Es können ja keine Informationen auf die SSD geschrieben werden, wenn der PC aus ist?!
Wo suche ich am besten? Kann sowas am Motherboard liegen (MSI X370 Gaming Pro Carbon)?
Kann es etwas mit Stromspitzen o.ä. beim abziehen der USB-Geräte zu tun haben?

Ich bin wirklich ratlos, habe per google nichts gefunden, würde das aber in Zukunft sehr gerne vermeiden. Eure Meinung hierzu würde mich wirklich interessieren, da ich es mir absolut nicht erklären kann.

Vielen Dank und schöne Feiertage!
 

PSYcHoDeLiC

Cadet 4th Year
Dabei seit
Mai 2003
Beiträge
124
Ich hab da ganz stark den Schnellstart-Modus von Windows 10 in Verdacht. Dieser hatte bei mir auch diverse Probleme gemacht, unter anderem beim Abstecken von USB-Geräten im "ausgeschaltetem" Zustand. (Im Schnellstart-Modus wird der PC nicht wirklich runter gefahren sondern in eine Art Hibernate-Mode geschalten)

Ausschalten kannst du diesen auf 2 Wege:

Systemsteuerung - Energieoptionen - Links "Auswählen was beim Drücken des Netzschalters geschehen soll" - "Einige Einstellungen sind momentan nicht verfügbar" anklicken - Häckchen bei Schnellstart-Modus weg

Oder so wie ichs mache: Administrative Eingabeaufforderung und den Befehl "powercfg -H off" <-- Damit wird der Hibernate Modus generell deaktiviert und damit auch der Schnell-Start.
 

Radamant

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Nov. 2008
Beiträge
41
Ich hab da ganz stark den Schnellstart-Modus von Windows 10 in Verdacht.

Ausschalten kannst du diesen auf 2 Wege:

Systemsteuerung - Energieoptionen - Links "Auswählen was beim Drücken des Netzschalters geschehen soll" - "Einige Einstellungen sind momentan nicht verfügbar" anklicken - Häckchen bei Schnellstart-Modus weg

Oder so wie ichs mache: Administrative Eingabeaufforderung und den Befehl "powercfg -H off" <-- Damit wird der Hibernate Modus generell deaktiviert und damit auch der Schnell-Start.
Ich weiß nicht, ob das die Lösung ist, aber es hört sich plausibel an und der Modus war bei mir in der Tat an, wovon ich gar nichts wusste :/ (danke Windows!).
Vielen Dank auf jeden Fall für den Tipp. Ich werde ihn aber jetzt nicht auf Wirksamkeit hin untersuchen :D! Ich habe aber ein Gefühl, dass das durchaus sein könnte.
 

Kick-Ass

Banned
Dabei seit
Nov. 2018
Beiträge
51
Ich habe aber ein Gefühl, dass das durchaus sein könnte.
Er ist es ganz bestimmt! Seitdem es Windows 7 gibt, habe ich grundsätzlich bei all meinen Rechnern den Schnellstart-Modus deaktiviert, schließlich steigt durch besagten der Verschleißlevel der SSDs immens an und Probleme verursacht er noch obendrein! Die paar Sekunden schnellerer Start des Betriebssystems kann man sich getrost sparen.

--> Achte aber bitte darauf, das noch großen Windows-Updates der Schnellstart-Modus auch mal wieder von selbst anspringen bzw. sich aktivieren kann! Microsoft halt, aber bei Apple sieht's ja auch nicht besser aus. ^^
 

Radamant

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Nov. 2008
Beiträge
41
Da ich gerne gefährlich und riskant lebe, habe ich es eben nach dem Erstellen eines Images getestet.

Kiste aus --> USB abgezogen --> kein Problem.

Ihr seid die Besten!

Aber was für ein krasser Bug ist das bitte? Man zieht den USB Stick raus, wenn man denkt die Kiste sei aus und das Bootsystem wird zerschossen?! Ziemlich indiskutabel.
 

Kick-Ass

Banned
Dabei seit
Nov. 2018
Beiträge
51
Aber was für ein krasser Bug ist das bitte? Man zieht den USB Stick raus, wenn man denkt die Kiste sei aus und das Bootsystem wird zerschossen?! Ziemlich indiskutabel.
Also bei uns in der Uni kam es in meinem Beisein bereits einmal vor, dass ein stationärer PC - der für Präsentationszwecke genutzt wurde - Systemdateien für den Schnellstart teilweise auf den USB-Stick abgelegt hat, evtl. da die SSD des Rechners komplett voll war?! Naja, wir wussten es selber nicht so genau, aber als der USB-Stick abgezogen wurde, ging bei ihm nichts mehr. Erst nach wieder anstöpseln des Sticks ließ er sich wieder problemlos booten. Nachdem der Schnellstart deaktiviert wurde, kam das Problem nie wieder vor.
 
Zuletzt bearbeitet:

PSYcHoDeLiC

Cadet 4th Year
Dabei seit
Mai 2003
Beiträge
124
Bei dem 2. Weg übers powercfg bleibts auch nach einem Main-Release aus (der Auswahl-Punkt ist dann gar nicht vorhanden), während bei Variante 1 nach einem Main-Release das Häckchen wieder gesetzt ist.
 

Radamant

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Nov. 2008
Beiträge
41
Also bei uns in der Uni kam es in meinem Beisein bereits einmal vor, dass ein stationärer PC - der für Präsentationszwecke genutzt wurde - Systemdateien für den Schnellstart teilweise auf den USB-Stick abgelegt hat, evtl. da die SSD des Rechners komplett voll war?!
Meine SSD ist definitiv nicht voll. Das kann nicht der Grund sein.

Ich habe sicherheitshalber auch Methode 2 von Psychodelic durchgeführt.

Nochmals vielen Dank. Das kann ein richtige ätzendes und zeitaufwändiges Problem werden. Vom Datenverlust ohne Images mal abgesehen.
 
Top