Netzlaufwerke werden automatisch verbunden/überprüft

Cralaw

Cadet 2nd Year
Dabei seit
Apr. 2011
Beiträge
16
Guten Morgen zusammen,

ich besitze ein NAS namens QNAP TS-412 mit 4 WD 3TB Green im Raid 5, welches ich in meinem Heimnetzwerk eingerichtet habe. Dort habe ich ein paar Dateifreigaben erstellt und diese mit einem Benutzernamen und Passwort versehen.

Auf meinem Windows 7 PC greife ich auf das Netzlaufwerk zu und habe auch eingestellt, dass sich das Netzlaufwerk automatisch verbinden soll. Man muss somit kein Benutzername und Passwort mehr eingeben, wenn diese einmal eingetragen sind. Funktioniert!

Das NAS ist so konfiguriert, dass sich die Festplatten nach einer bestimmen Zeit abschalten und bei Gebrauch/Anfrage wieder anschalten. Die Methode funktioniert einwandfrei. Greife ich auf das Netzlaufwerk zu, starten die Festplatten wieder.

Zunächst hatte ich das Problem, dass die Festplatten des NAS direkt starten, wenn der PC gestartet wird. Das konnte ich über einen Registry-Eintrag am PC ändern: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\NetworkProvider --> Erstellung DWORD mit RestoreConnection auf Wert 0. Die Festplatten des NAS starten nun nicht mehr direkt mit.

Das letzte Problem ist aber, wenn ich den Arbeitsplatz aufrufe, fragt der PC anscheinend direkt den Benutzernamen und das Passwort auf dem NAS ab und die Festplatten starten direkt durch. Es wird hierbei nur der Arbeitsplatz aufgerufen (bspw.: Windows + E) und nichts weiteres gedrückt. Schließe ich den Arbeitsplatz und warte die gewisse Zeit zum Herunterfahren der Festplatten, funktioniert dies auch super.
Aber den Arbeitsplatz öffnet man nicht nur einmal am Tag, sondern öfter :( Das NAS läuft immer wieder auf vollen Touren an.
Das würde ich gerne irgendwie unterbinden.

Gibt es hierfür auch einen Registry-Schlüssel oder eine Einstellung in Windows?

Die Festplatten sollen nur anlaufen, wenn ich wirklich darauf zugreife. Ergo Doppelklick auf das Netzlaufwerk.

Ich weiß, es würde den Workarround geben, dass ich den Benutzernamen und das PW nicht speichern würde, aber das möchte ich eigentlich nicht. Außer es gibt keine richtige Lösung für das Problem.

Ich hoffe ihr könnt mir helfen :)

Viele Grüße
Cralaw
 

Atkatla

Lt. Commander
Dabei seit
Dez. 2007
Beiträge
1.620
Hatte das gleiche Problem. Habe letztlich mangels Alternative die Netzlaufwerk-Mappings (Laufwerksbuchstaben) gelöscht und greife auf die Freigaben über \\server\freigabe zu.
 

BadBigBen

Captain
Dabei seit
Feb. 2012
Beiträge
3.773
Schon mit nem Shortcut (aka Verknüpfung) auf dem Desktop (oder irgendwo anderst, zB. My Documents) probiert?
 
Zuletzt bearbeitet:

Cralaw

Cadet 2nd Year
Ersteller dieses Themas
Dabei seit
Apr. 2011
Beiträge
16
Hallo zusammen,

nach längerer Abwesenheit konnte ich die Tipps testen.

Ich habe Verknüpfungen erstellt, diese mit den Netzwerkadressen und den Anmeldeinformationen gefüttert, und unter den Favoriten im Windows Explorer abgelegt (wenn der Arbeitsplatz geöffnet wird, direkt links oben zu finden). Finde das ist eine recht gute Lösung, da ich nun die Netzwerkverbindungen aufrufen kann, wann ich will. Man hat sie immer im Blick.

Die Festplatten des NAS starten auch nur dann, wenn ich wirklich die Verknüpfung öffne und nicht, wenn ich den Arbeitsplatz starte.

Dass es mit den Netzlaufwerken nicht direkt zu lösen ist, ist zwar schade, aber der Workaround ist dafür gut.

Vielen Dank für die Hilfe :)

Gruß
Cralaw
 
Top