[Raspberry Pi]Internetradio funktioniert nach 24h-Disconnect nicht mehr

Engelsen

Lt. Commander
Dabei seit
Apr. 2009
Beiträge
1.995
Moin zusammen,

habe mir hier einen RasPi als Internetradio zusammengebastelt. Dieser funktioniert über WLAN problemlos bis der 24h-Disconnect einsetzt.

Danach kommt keine Musik mehr aus den Boxen, auch wenn der Pi wieder mit dem Internet verbunden ist.

ALso habe ich folgendes gemacht. Ich habe ein kleines Skript gebaut, welches nach dem Disconnect folgendes macht:

Code:
#!/bin/bash

sudo mpc clear &
        sudo sleep 2
        sudo mpc volume 100 &
        sudo mpc random off &
        sudo mpc consume off &
        sudo sleep 2
        sudo mpc load "radio" &
        sudo sleep 5
        mpc play &
echo "Alles erledigt" &
date >> /home/restart.log &
echo ------------------ >> /home/restart.log &


exit 0
Das Ganze ist über einen Cron geregelt... (leider sehe ich grade, dass dieser auch nicht funktioniert :()

Code:
59 7    * * *   root    bash /home/go.sh
Welchen Fehler mache ich da? Bin schon von RaspBian auf Volumio umgestiegen... Brachte aber auch keinen Erfolg....

Wenn ich bei MPDroid auf Stop und anschließend auf Play drücke, startet der Stream sofort ...

Vielen Dank für jeden Denkanstoß :)
 

Suxxess

Vice Admiral
Dabei seit
Feb. 2005
Beiträge
6.803
Funktioniert es denn wenn du es manuell ausführst als root?

Und wozu brauchst du 20x sudo wenn du das eh als Root ausführen willst?
Und das "&" ? Wozu soll das gut sein? Wo hast du denn das Script aufgegabelt?
( Im Normalfall sollte & das beenden unterbinden aber in dem Zusammenhang wirkt das etwas deplaziert )
 
Zuletzt bearbeitet:

d2boxSteve

Commander
Dabei seit
Apr. 2010
Beiträge
2.996
In der crontab gehen keine Parameter.
Du musst dort das "bash" weglassen.
Im Script selber referenzierst du doch schon auf die bash?

Ahja, das script braucht das execute-Flag dafür.
 

Engelsen

Lt. Commander
Ersteller dieses Themas
Dabei seit
Apr. 2009
Beiträge
1.995
Das Skript war aus dem Volumio-Forum.

Funktioniert es denn wenn du es manuell ausführst als root?
Ja.

Ok hab es wie folgt angepasst:

skript:
Code:
#!/bin/bash
mpc clear
        sleep 2
        mpc volume 100
        mpc random off
        mpc consume off
        sleep 2
        mpc load "radio"
        sleep 5
        mpc play
echo "Alles erledigt"
date >> /home/restart.log
echo ------------------ >> /home/restart.log
exit 0
cron:
Code:
59 7    * * *   root    /home/go.sh
Sollte gehen ... oder?

chmod +x hab ich auf die Datei angewendet.
 
Zuletzt bearbeitet:

Suxxess

Vice Admiral
Dabei seit
Feb. 2005
Beiträge
6.803
Code:
#!/bin/bash
mpc clear
sleep 2
mpc volume 100
mpc random off
mpc consume off
sleep 2
mpc load "radio"
sleep 5
mpc play
echo "Alles erledigt"
date >> /home/restart.log
echo ------------------ >> /home/restart.log
exit 0
Versuch mal das Script manuell auszuführen. :)
 

Engelsen

Lt. Commander
Ersteller dieses Themas
Dabei seit
Apr. 2009
Beiträge
1.995
@Suxxess

Läuft! Ich guck mal, ob das Radio morgen früh wieder geht, wenn ich die Boxen wieder anschalte :)

Der Crontab sollte ja nun hoffentlich funktionieren ...
Ergänzung ()

Ich bins nochmal ... Also leider startet der Cronjob nicht :( .. Wenn ich die Datei von Hand ausführe, klappt es wunderbar.

Code:
root@volumio:~# ls -l /home/go.sh
-rwxr-xr-x 1 root root 284 Sep  9 17:27 /home/go.sh
So sehen die Berechtigungen der Datei aus. Da ich sie aber eh als root ausführe sollte das doch klappen ...

Hier nochmal der Crontab:
Code:
50 7    * * *   root    /home/go.sh
@EDIT:

Klappt leider immer noch nicht. Hat vielleicht noch jemand eine Idee??

@Noch ein Edit:

Habe grade gesehen, dass Volumio den Cronprozess nach einem Neustart killt... Ich habe das nun deaktiviert und hoffe, dass es morgen funktioniert ...
 
Zuletzt bearbeitet:
Top