Ruckeln von Videos bei Abruf über Fritz-NAS

Memono

Cadet 3rd Year
Dabei seit
Dez. 2007
Beiträge
57
Guten Tag,

habe das Problem, dass Videos sich immer wieder mal für ca. 30 Sekunden aufhängen, wenn ich diese am Handy ansehen will. Die Videos sind auf einem USB 3.0 USB-Stick an der Fritzbox 7530. Wenn ich die gleichen Dateien über den PC ansehen will überspringt der Player teilweise einfach 1-2 Minuten des Videos. Die Bandbreite sollte eigentlich ausreichen und liegt beim Schreiben und Lesen über 25MB/s. Beim lokalen Abspielen der selben Videos kommt es zu keinem Problem, also liegt es auch nicht an der Datei selbst. Insgesamt könnte man meinen, dass Fritz-NAS sich nach einer gewissen Zeit kurz abschaltet und dadurch dieses Verhalten zu Tage kommt. Allerdings habe ich alle Settings in dieser Richtung auf maximale Leistung gestellt, um das auszuschließen (sowieso sollte das eigentlich nicht passieren, wenn man gerade aktiv darauf zugreift). Wenn ich die Datei über einen 2. PC ansehen will, dann geht das ebenfalls - also wird es wohl auch nicht am Netzwerk selbst liegen... Was kann ich noch probieren? Welche Infos benötigt ihr noch?

Danke für eure Meinungen!
 

DMHas

Lt. Commander
Dabei seit
Sep. 2005
Beiträge
1.517
Sehr wahrscheinlich reicht die Leistung der Fritzbox nicht aus, um durchgehend zu streamen. Aus eigener Erfahrung kenne ich das Problem. Schaue dir mal die Auslastung des Prozessors (Fritzbox) beim Streamen an.
(Ich bin dann selber auf ein "richtiges" Nas umgestiegen und glücklich damit.)
 
Zuletzt bearbeitet:

Cool Master

Fleet Admiral
Dabei seit
Dez. 2005
Beiträge
30.483

till69

Commander
Dabei seit
Jan. 2010
Beiträge
2.938
Eine 7530 hat einen QuadCore SoC (4 x 716Mhz)
Über USB3 sind locker 40MByte/s drin. (mit FritzOS 7.xx)

Also definitiv KEIN CPU Problem ;)

Die gleiche Hardware (FB 4040) mit OpenWRT schafft über 100MByte/s am USB3 Port.
 

DMHas

Lt. Commander
Dabei seit
Sep. 2005
Beiträge
1.517
@till69: Ich will hier keine Grundsatzdiskussion betreiben. Meine Erfahrung zeigt, das die Geschwindigkeiten des Fritz-NAS für einfachere Dateioperationen vollkommen reicht. (Aber schon 2 Zugriffe auf die angeschossene Festplatte verlaufen sehr zäh - leider sind hier Theorie und Praxis zwei Paar Schuhe.) Die von dir aufgezeigten Werte reichen natürlich aus, dennoch denke ich das der Prozessor (ARM Cortex A7) das begrenzende System ist.

Als Gedankenanstoß: die 7530 (IPQ4019 SoC) & die 4040 (IPQ4018 SoC) - haben beide eine ARM Cortex A7 CPU, aber die Aufgabengebiete sind unterschiedlich - Stichwort: DSL-Modem + DECT-Telefonie. Das erklärt warum die 4040 viel bessere USB-Werte zeigt und stützt die These der limitierenden CPU.)
 

Memono

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Dez. 2007
Beiträge
57
Erst einmal danke für die Antworten.

Ich glaube eher nicht, dass es an der CPU liegt. Die Auslastung der CPU steigt beim Streamen der Datei nur um ca. 5% an - auf 74%. Was ich allerdings ein wenig komisch finde ist, dass die Auslastung standardmäßig bereits bei knapp 70% liegt. Auslastung während des Streams:

Anmerkung 2019-10-31 121619.png


An der Bandbreite liegt es wohl auch nicht. Das Video läuft bis zu diesen Stellen außerdem ja absolut flüssig. Lesend habe ich eben auch im Schnitt ca. 45MB/s. Was mir allerdings auffällt ist, dass die Übertragung ziemlich stark schwankt..

Anmerkung 2019-10-31 121400.png


Kopieren einer einer 1,5GB Datei vom Fritz-NAS auf PC - Peaks 50MB/s aber eben schwanked bis zu 500KB/s runter (keine Ahnung, ob das normal ist).

Was mir noch aufgefallen ist, sind die komischen Werte der Temperatur... vor allem, weil z.B. um 6 Uhr die Fritzbox quasi gar nicht in Nutzung war - ist das ein Bug?

Anmerkung 2019-10-31 121723.png


Zum Thema neues NAS-System: Ich habe quasi nur die Anforderung mal eben das ein oder andere Video auf mein Handy/PC zu streamen und dachte, dass das igrendwie mit dem Fritz-NAS machbar sein sollte. Würde jetzt eher ungern dafür noch einmal extra ein komplettes NAS-System kaufen wollen.
 

Cool Master

Fleet Admiral
Dabei seit
Dez. 2005
Beiträge
30.483
Kopieren einer einer 1,5GB Datei vom Fritz-NAS auf PC - Peaks 50MB/s aber eben schwanked bis zu 500KB/s runter (keine Ahnung, ob das normal ist).
Da sieht man schon, dass es an der CPU liegt. 50 MB/s peak = sehr schlecht. Da das ganze über Gigabit läuft müsste das bei gut dem doppelten liegen und zwar konstant. Wenn ich etwas auf mein NAS kopiere liegt das bei ~115 MB/s durchgehend. Ja, je nach Datei (kleine Dateien) kann es auch mal etwas einbrechen aber niemals auf 500 KB/s.

Für mich sieht das so aus als würde die FritzBox die CPU drosseln da sie wohl zu warm wird oder sie einfach nicht genug Leistung für das vorhaben hat.
 

Uridium

Lt. Commander
Dabei seit
Juni 2005
Beiträge
1.366
Über welchen Dienst werden die Dateien denn freigegeben (smb/cifs, nfs, ftp..), bzw. welche Software stellt die Verbindung dazu auf dem Handy bereit?
Passiert das auch bei einem System, dass via Ethernet (also nicht WiFi) angebunden ist?
 
Zuletzt bearbeitet:

Memono

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Dez. 2007
Beiträge
57
@Cool Master Mir ist bewusst, dass das kein guter Wert für ein NAS-System ist - aber effektiv brauche ich für mein Vorhaben ja nur ca. 1MB/s damit alles flüssig läuft. Das wird doch diese Box noch stämmen können.. :mad:

@Uridium Über SMB. In meinem Ausgangspost meinte ich "Wenn ich die gleichen Dateien über den PC ansehen will überspringt der Player teilweise einfach 1-2 Minuten des Videos " - dieser PC ist dabei per LAN angeschlossen.
 

Uridium

Lt. Commander
Dabei seit
Juni 2005
Beiträge
1.366
Die Mutter aller Lösungen hast Du bereits ausprobiert (Fritzbox Neustart)?
Dauerbelastung der CPU sieht schon eigenartig aus, als würde ein Prozess hängen.
 

DMHas

Lt. Commander
Dabei seit
Sep. 2005
Beiträge
1.517
Ich finde die Last auch sehr hoch (bei 74% sind ja 3 Kerne vollausgelastet). Die Fritzbox neustarten und dann nochmals testen, wie von Uridium empfohlen und dann nochmals testen. (Glaube aber kaum, dass es sich bessern wird.)

Edit: Der Screenshot zeigt den Energieverbrauch und nicht die CPU-Auslastung!
 
Zuletzt bearbeitet: (Energieverbrauch statt CPU-Auslastung)

Memono

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Dez. 2007
Beiträge
57
Habe sie noch nicht neugestartet, da ich das in letzter Zeit zu oft getan habe und die Telekom meine Leitung schon als instabil eingestuft hatte...

Nach dem Neustart ist die Auslastung der CPU immer noch bei ca. 70%. Mit Deaktiveren des 2,4Ghz WLANs, welches ich sowieso nicht brauche, liegt sie nun bei 67%. In der Statistik sind die durchschnittlichen Werte aber irgendwie wesentlich geringer. Diese entspräche ja eher so max. 20%:

Anmerkung 2019-10-31 133632.png


Ich formatiere den USB-Stick gerade mal auf ext4 - bezweifle stark, dass das einen Unterschied macht, aber wird sicherlich auch nicht schaden.
 

Cool Master

Fleet Admiral
Dabei seit
Dez. 2005
Beiträge
30.483
Bedenke aber, dass du mit ext4 ohne Zusatzprogramme das Teil unter Windows nicht mehr beschreiben oder lesen kannst.
 

Memono

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Dez. 2007
Beiträge
57
Ja, ich weiß. Das ist aber kein Problem.

Also das Beschreiben ist immer noch schwankend, aber lesend habe ich jetzt sehr stabile 80MB/s. Da diese Probleme teilweise erst nach 10mins des Streamens aufgekommen sind muss ich das später noch testen. Aber sieht schon mal vielversprechend aus. Ich gebe dann noch einmal Rückmeldung.
 

DMHas

Lt. Commander
Dabei seit
Sep. 2005
Beiträge
1.517

Memono

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Dez. 2007
Beiträge
57
Anmerkung 2019-10-31 155201.png


Im Zeitraum der letzten beiden "Striche" habe ich das Video gleichzeitig am Handy und PC gestreamt - soweit war kein Aussetzer jeglicher Art festzustellen. Das Kopieren einer Datei auf den PC vom Fritz-NAS aus geht teilweise sogar mit (nicht schwankenden) knapp 100MB/s - das Beschreiben aber nur mit im Schnitt 10MB/s und wieder so mit einem Zickzack-Verlauf wie vorher generell zu beobachten war... muss die Fritzbox da irgendwie was an das Format anpassen oder wie kann das sein? Für meine Zwecke ist das zwar nicht so schlimm, aber trotzdem komisch.
 

Memono

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Dez. 2007
Beiträge
57
Auf jeden Fall mehr als 10MB/s - glaube ca. 50MB/s waren es.

Ok, ich glaube ich habe das falsch gedeutet mit dem Zickzack-Verlauf. Im Explorer sieht es ganz ordentlich aus

Beim Schreiben hat man aber das Gefühl, als würde nach anfänglichen 30MB/s irgenwas auf ~10MB/s drosseln.

Von NAS auf PC:

lesen explorer.jpg


von PC auf NAS:

schreiben explorer.jpg


@Uridium Irgendeine Cache-Geschichte hatte ich auch schon in Vermutung, aber habe leider keinen Shell-Zugang zur Fritzbox und will da jetzt im Moment auch nicht noch mehr rumbasteln wegen oben schon beschriebener Problematik mit dem VDSL-Anschluss.
 
Top