Leserartikel Ständiges Aufwachen von Windows 10 verhindern

Bob.Dig

Lt. Commander
Dabei seit
Dez. 2006
Beiträge
1.134
Windows 10 für längere Zeit in den Sleep-Modus (Energie sparen) zu versetzen ist auf manchen System fast unmöglich.
Es hat mich einige Zeit gebraucht, bis ich folgende Lösung gefunden habe.

Grundsätzlich können auch einzelne Peripherie-Geräte oder veraltete Treiber den PC ständig aufwecken, aber auch Windows 10 selbst weigert sich beharrlich längere Zeit zu schlafen, anders als es noch Windows 7 tat.

Du gehörst zu den erfahrenen Nutzern und hast diese Punkte vermutlich schon bedacht, der Vollständigkeit halber seien sie hier trotzdem erwähnt.

Du hast in den Power-Options den Wake-Timern (Zeitgebern) die Erlaubnis zum Aufwecken des PCs entzogen.
Capture99.PNG
Windows beachtet diese Einstellung anscheinend nicht für alle Tasks aber damit kannst du diese immerhin etwas eingrenzen.

Auch hast Du es den Netzwerkadaptern im PC verboten, den Rechner zu wecken. Dafür solltest Du jeden Netzwerkadapter im Gerätemanager so einstellen, wie hier abgebildet:
Capture6.PNG
Manche Geräte im Netzwerk wecken sogar unaufgefordert PCs per WoL auf, also zu Testzwecken am Besten wie gezeigt ganz deaktivieren.

In einer Admin-Powershell gibst Du folgendes ein um die Wake-Timer, also die Störenfriede, zu identifizieren:
Get-ScheduledTask | where {$_.settings.waketorun}
Code:
TaskPath                                       TaskName                          State
--------                                       --------                          -----
\Microsoft\Windows\.NET Framework\             .NET Framework NGEN v4.0.30319... Disabled
\Microsoft\Windows\.NET Framework\             .NET Framework NGEN v4.0.30319... Disabled
\Microsoft\Windows\InstallService\             WakeUpAndContinueUpdates          Disabled
\Microsoft\Windows\InstallService\             WakeUpAndScanForUpdates           Disabled
\Microsoft\Windows\SharedPC\                   Account Cleanup                   Disabled
\Microsoft\Windows\UpdateOrchestrator\         Backup Scan                       Ready
\Microsoft\Windows\UpdateOrchestrator\         Reboot_AC                         Disabled
Bei allen Tasks mit State:Ready solltest Du das Aufwecken im Taskplaner deaktivieren. Bei einigen wird dies wegen mangelnder Rechte nicht möglich sein. Dennoch kann das Deaktivieren bei denen wo es geht schon ausreichen.

Wer trotzdem gleich weiter machen möchte benötigt dazu im Falle mangelnder Rechte psexec.exe.
Kopiere dir diese z.B. auf C:\.
Dann startest Du in einer Admin- Befehlszeile oder Powershell:
C:\psexec -i -s cmd.exe
In der nun geöffneten Befehlszeile gibst Du folgendes ein:
%windir%\system32\taskschd.msc /s

Jetzt kannst Du das Aufwecken durch die einzelnen Tasks deaktivieren
Capture1.PNG

oder wenn das nicht geht oder den Zweck nicht erfüllt gleich den ganzen Task.
Capture2.PNG

Anschließend noch mal testen mit:
Get-ScheduledTask | where {$_.settings.waketorun}
Done.

psexec.exe kann nun wieder gelöscht werden.

Bei mir sieht es anschließend so aus:
Code:
TaskPath                                       TaskName                          State
--------                                       --------                          -----
\Microsoft\Windows\.NET Framework\             .NET Framework NGEN v4.0.30319... Disabled
\Microsoft\Windows\.NET Framework\             .NET Framework NGEN v4.0.30319... Disabled
\Microsoft\Windows\InstallService\             WakeUpAndContinueUpdates          Disabled
\Microsoft\Windows\InstallService\             WakeUpAndScanForUpdates           Disabled
\Microsoft\Windows\SharedPC\                   Account Cleanup                   Disabled
\Microsoft\Windows\UpdateOrchestrator\         Reboot_AC                         Disabled
Windows 10 schläft nun durchgehend bis ich es z.B. per WoL wecke.

Nachtrag: Es kann sein, dass einzelne Tasks durch z.B. Windows Update wieder reaktiviert werden, aber dann ist deren Frequenz doch eher selten, augenscheinlich z.B. 14 Tage. Dagegen könnte es möglicherweise helfen die entsprechenden Tasks im Explorer unter C:\Windows\System32\Tasks zu ändern und anschließend schreibzuschützen. Dafür muss aber auch erst deren Besitz übernommen werden etc. Zu dieser Variante würde ich also erst greifen, wenn obiges Verfahren zu keinem zufriedenstellenden Ergebnis führt.
 
Zuletzt bearbeitet:

Toaster05

Commander
Dabei seit
Okt. 2013
Beiträge
2.647
Nett, aber man sollte vllt. dazu schreiben, dass das nur für "Energie sparen" und den ganzen Mist zählt.. meine Kiste ist noch nie selbständig Hochgefahren um irgendwelche Updates zu machen..

richtig Herunterfahren und fertig ist das Gedöns..
 

LinuxGaming

Cadet 4th Year
Dabei seit
Feb. 2019
Beiträge
127
Trifft das auf alle Versionen Windows 10 Versionen (1803 - 1809 - 1903) zu ? Bitte das mal schreiben lieber TE.

Persönlich habe ich da etwas gelesen in einen Post, in Zusammenhang mit der 1903.
 

Bob.Dig

Lt. Commander
Ersteller dieses Themas
Dabei seit
Dez. 2006
Beiträge
1.134
Es betrifft Win10 durchgehend seit Beginn an.

Da das ein Leserartikel und Tut sein soll müsst ihr aber nicht darauf antworten, wenn ihr gar nicht betroffen seit, weil ihr z.B. nicht den Sleep-Modus benutzt. Das Verhalten wird hier wohl vor allem Leute stören, die Win10 als Home(Storage-)server einsetzen, so ist es zumindest bei mir.
 
Zuletzt bearbeitet:

LinuxGaming

Cadet 4th Year
Dabei seit
Feb. 2019
Beiträge
127
Persönlich ist bei mir der Schuldige die Netzwerkkarte. Stelle ich in den Netzwerkoptionen das passende ein, WakeUP, dann läuft es bei mir perfekt. So ist es bei mir und bei anderen wahrscheinlich wieder anders.
 

ed_lumen

Commander
Dabei seit
März 2008
Beiträge
2.122
hier reaktiviert windows alle deaktivierten dienste selbst. den erfolg von bob.dig habe ich leider nicht. hier kommt big brother orchestrator wieder und wieder.
 

Bob.Dig

Lt. Commander
Ersteller dieses Themas
Dabei seit
Dez. 2006
Beiträge
1.134
@ed_lumen Ich habe einen Nachtrag verfasst. Vielleicht ist das was für dich. Bist Du dir denn sicher, dass die Dienste, die wieder aktiv sind noch wirklich störend sind? Ich muss nämlich gestehen, dass es schon viele Monate her ist, dass ich meinen "Filer" ruhig gestellt habe und ich nicht mehr hundertprozentig sicher bin, wie ich nun die mit dem PS-Befehl ermittelten Tasks wirklich gekillt habe, psexec oder Exporer. Aber was ich gemacht habe, es hat gewirkt. ;)
 

LukS

Commander
Dabei seit
Dez. 2009
Beiträge
2.513
Das Verhalten ist mir auch schon öffter ungut aufgefallen. Ist bei mir auch seit Anfang Win 10 immer wieder vorgekommen. Ist echt nervig.
Muss ich bei Zeiten mal zu Hause probieren.
 

ed_lumen

Commander
Dabei seit
März 2008
Beiträge
2.122
der wie oben beschrieben deaktivierte universal orchestrator idle start aktiviert sich (bei mir) selbsttätig neu. das rezept wirkt nicht. die spionage-software aus dem hause MS ist stärker.
 

Zubz3ro

Cadet 2nd Year
Dabei seit
Okt. 2010
Beiträge
31
kann ich bestätigen. UpdateOrchestrator reaktiviert sich immer wieder von selbst. win10 gehört verboten. :kotz:
 

Mydgard

Commander
Dabei seit
Sep. 2002
Beiträge
2.274
Das mag bei Notebooks interessant sein, bei PCs hingegen (mit SSD) startet der auch in Sekunden ... da braucht man keinen Sleepmodus imho.
 

ed_lumen

Commander
Dabei seit
März 2008
Beiträge
2.122
@Mydgard: man sollte nicht stets von sich auf andere schließen. mal abgesehen davon, daß es hier nicht um "meinungen" geht, sondern um technologischen rückschritt bzw. überwachungsmäßigen übergriff seitens MS, der nach monaten ohne auch nur den versuch, ihn zu ändern, wohl als gezielte aktion anzusehen ist. ohne obige aufwachfunktion ist zb. ein timergestütztes aufnehmen vom tv nicht möglich.
 
Top