Synology MailPlus SMTP/POP3/IMAP mit Thunderbird Client

Hot Dog

Lieutenant
Dabei seit
Mai 2007
Beiträge
878
EDIT: SOLVED
Wer auch immer das hier liest, es ist einiges an Arbeit erforderlich. Lösung siehe Post #14 unten.

Hey Leute,
ich weiß, das Thema wurde bereits in anderen Threads diskutiert, aber die konnten mir bisher nicht weiter helfen.

Der Ist-Stand:
  • Strato -> POP3 -> Synology NAS Mail Plus (funktioniert einwandfrei über SSL/TLS)
  • Synology NAS Mail Plus -> POP3/IMAP -> Client PC (Thunderbird) (klappt nicht)
  • -> Nachschlagen von [DOMAIN].local fehlgeschlagen. Anmeldung fehlgeschlagen.
  • Client PC (Thunderbird) -> SMTP -> Synology NAS Mail Plus (klappt nicht)
Der Plan:
Das NAS ruft die Mails vom Provider (Strato) mittels POP3 ab. Die Mails sind daraufhin auf dem NAS gespeichert. D.h. mit Synology Mail Plus kann ich diese bereits lesen/archivieren/löschen/etc..
Nun würde ich gerne diese Mails mittels IMAP (oder POP3) an Thunderbird weiterleiten (ohne sie auf dem NAS zu löschen). Aber genau das scheitert momentan. Hab es in Thunderbird sowohl mit POP3-Server als auch IMAP-Server versucht. Im letzten Schritt wird dann SMTP eingerichtet, so dass die Mails vom Client (Thunderbird) an das NAS und letztlich an Strato weiter geleitet werden.

Zur Verdeutlichung, siehe Bilder.
Was mache ich falsch und wie bekomme ich Thunderbird dazu, die Mails von Synology NAS Mail Plus abzurufen?

Danke schonmal.

EDIT: SOLVED
Wer auch immer das hier liest, es ist einiges an Arbeit erforderlich. Lösung siehe Post #14 unten.
 

Anhänge

  • Thunderbird_Einstellungen.jpg
    Thunderbird_Einstellungen.jpg
    122,8 KB · Aufrufe: 309
  • NAS_Domain.jpg
    NAS_Domain.jpg
    26,5 KB · Aufrufe: 286
  • NAS_Protokolle.jpg
    NAS_Protokolle.jpg
    78,3 KB · Aufrufe: 259
  • NAS_SMTP_Einstellungen_01.jpg
    NAS_SMTP_Einstellungen_01.jpg
    76,6 KB · Aufrufe: 261
  • NAS_SMTP_Einstellungen_02.jpg
    NAS_SMTP_Einstellungen_02.jpg
    63,8 KB · Aufrufe: 297
Zuletzt bearbeitet:
Dein Rechner kennt dein nas.local nicht. Entweder über IP gehen oder DHCP Server prüfen. Du kannst ja mal ein Eingabeaufforderung (cmd.exe) starten und ping hostname.local eingeben, dann wirst du sehen: Unbekannter Host
 
  • Gefällt mir
Reaktionen: Hot Dog
Zitat von Falc410:
Dein Rechner kennt dein nas.local nicht. Entweder über IP gehen oder DHCP Server prüfen.
Ja das habe ich mir auch schon gedacht, da tatsächlich kein Ping klappt (weder zu IMAP- noch SMTP-Host).
Ich verwende das NAS selbst als DNS-Server und habe bei meinem PC unter IPv4 die NAS-IP als DNS eingetragen. Eigentlich sollte der doch dann alles regeln oder nicht? Der DNS funktioniert ja soweit.
Wie mache ich dem die Auflösung der Namen klar? Im NAS DNS Server gibt es hierfür keine zusätzlichen Einstellungen.
 
Zuletzt bearbeitet:
Meistens macht das der Router der als DHCP und lokaler DNS fungiert, beim Synology bin ich leider raus. Hab meins immer noch nicht wirklich benutzt. Vielleicht kann da jemand anders helfen.
Zur Not wie gesagt anstatt über Hostname über die IP gehen oder in deine Windows hosts Datei den Eintrag manuell reinschreiben (kann man googlen wie das geht)
 
Zitat von Hot Dog:
Ich verwende das NAS selbst als DNS-Server und habe bei meinem PC unter IPv4 die NAS-IP als DNS eingetragen.
Äh bitte was?
Bitte nochmal nachschauen wie DNS funktioniert.
Du musst einen Eintrag anlegen der wie folgt aussieht:
nas.local IP-des-NAS

Beispiel:
1653747528862.png


DNS-Name wäre nas.meinedomain.de, IP des NAS ist die 192.168.2.15
 
Zitat von kamanu:
Du musst einen Eintrag anlegen der wie folgt aussieht:
nas.local IP-des-NAS
Wie soll ich hier bitte einen Text eingeben? (siehe Anhang)
Ergänzung ()

Zitat von Falc410:
Meistens macht das der Router der als DHCP und lokaler DNS fungiert.
Nutze meinen FritzBox DNS für das interne LAN nicht (ist deaktiviert). Von außen regelt der ISP die Vergabe der IPS und Namen und intern soll das der NAS DNS-Server regeln.
 

Anhänge

  • IPv4_Einstellungen.jpg
    IPv4_Einstellungen.jpg
    46,7 KB · Aufrufe: 152
@Hot Dog Siehe mein Beispiel. Den DNS-Eintrag legst du auf dem NAS im DNS-Server an.

Auf dem PC gibst du wiederum die IP des NAS als DNS-Server an.
 
Zitat von kamanu:
Siehe mein Beispiel. Den DNS-Eintrag legst du auf dem NAS im DNS-Server an.
Auf dem PC gibst du wiederum die IP des NAS als DNS-Server an.
Ja an sich schon. Aber der Synology DNS Server ist mit den Möglichkeiten ziemlich begrenzt (siehe Anhang).
Ich sehe hier keine Möglichkeit irgendwas einzutragen.
PS: Die Forwarder-IP ist die der FritzBox, von welcher aus ich mich in das Internet verbinde.
 

Anhänge

  • Synology_NAS_DNS_Server_01.jpg
    Synology_NAS_DNS_Server_01.jpg
    47,8 KB · Aufrufe: 215
  • Synology_NAS_DNS_Server_02.jpg
    Synology_NAS_DNS_Server_02.jpg
    64,1 KB · Aufrufe: 190
Du musst oben eine Zone für deine interne Domain anlegen. Alles auf Standardeinstellungen lassen.
z.B. hotdog.local
Beim Nameserver kannst du danach einfach 127.0.0.1 eintragen (falls er das zulässt). Der sollte für deine Zwecke nicht relevant sein.
Im Anschluss kannst du da dann auch Einträge anlegen wie du oben siehst.
 
  • Gefällt mir
Reaktionen: Hot Dog
Da musst du jetzt einfach "ausprobieren" :D
Aber im Zweifel Master-Zone.
Ich hab bisher noch kein Synology-Gerät als DNS-Server wirklich in Betrieb gehabt. Hab gerade eben nur auf eins zugegriffen um mit Standardeinstellungen kurz die Sachen so einzutragen, wie ich es auch bei Windows machen würde :D
 
Zitat von kamanu:
Da musst du jetzt einfach "ausprobieren" :D
Aber im Zweifel Master-Zone.
Ich hab bisher noch kein Synology-Gerät als DNS-Server wirklich in Betrieb gehabt. Hab gerade eben nur auf eins zugegriffen um mit Standardeinstellungen kurz die Sachen so einzutragen, wie ich es auch bei Windows machen würde :D
haha ok verstehe 😂
Gut, dann werde ich mal rumprobieren und melde mich erneut, falls etwas klappt oder eben nicht klappt. Danke euch beiden!

EDIT:
Muss für die korrekte Einrichtung des Synology NAS DNS nun auch einen DHCP einrichten.[Blödsinn]
Könnte also noch etwas dauern 😅
Ich melde mich dann morgen nochmal.
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: kamanu
@Hot Dog rein theoretisch kann dein bisheriger DHCP-Server AUCH den DNS der Synology verteilen.
Wichtig: Alle anderen DHCP-Server deaktivieren. Du willst maximal einen in deinem Netz.
 
Zitat von kamanu:
@Hot Dog rein theoretisch kann dein bisheriger DHCP-Server AUCH den DNS der Synology verteilen.
Wichtig: Alle anderen DHCP-Server deaktivieren. Du willst maximal einen in deinem Netz.
Ja da hast du Recht, hab das oben nochmal abgeändert. Hab jetzt allerdings trotzdem einen eigenen DHCP-Server aufgesetzt, kann nicht schaden 😂
Ergänzung ()

Also habs inzwischen hingekriegt, läuft alles so wie es soll. Danke euch nochmal!
Details (für alle die es interessiert):

1. Statische IP:
Habe einen eigenen DHCP-Server auf dem NAS aufgesetzt und damit den FritzBox-DHCP abgelöst (ist nicht notwendig, habs aber trotzdem gemacht). Allerdings benötigt das NAS eine statische (gleichbleibende) IP-Adresse, dies kann man auf dem NAS unter Systemsteuerung -> Netzwerk -> LAN [1,2,3 oder 4] -> IPv4 manuell festlegen.

2. DNS-Server:
Anschließend habe ich meinen NAS-DNS-Server so eingerichtet, dass alle Hosts erreicht/angepingt werden konnten (das war die meiste Arbeit und hat einiges an Einarbeitung vorausgesetzt).
Habe hierzu folgende (E-Mail-bezogene) Einträge in einer Master-Zone angelegt:
-> Hinweis: [DOMAIN]=die im Mail-Server eingerichtete Domain (bei mir: DOMAIN.local)
  • imap.[DOMAIN.local] -> Typ: A [IP des NAS]
  • smtp.[DOMAIN.local] -> Typ: A [IP des NAS]
  • mailserver.[DOMAIN.local] -> Typ: A [IP des NAS]
    [mailserver.[DOMAIN.local] muss mit dem auf dem NAS-Mail-Server unter Mailübermittlung -> Hostname (FQDN) eingetragenen Name übereinstimmen]
  • ns.[DOMAIN.local] -> Typ: A [IP des NAS]
  • [DOMAIN.local] -> Typ: MX (MX ist wichtig für den Mail-Server) & Priorität: 10
    [hier wird auf mailserver.[DOMAIN.local] verwiesen, statt auf nur eine bestimmte IP]
  • [DOMAIN.local] -> Typ: NS
    [hier wird auf ns.[DOMAIN.local] verwiesen statt auf nur eine bestimmte IP]
3. Delivery-Relay:
Wichtige Randnotiz: Wenn die Mails nicht vom eigenen NAS verschickt-, sondern zunächst an den Provider (hier Strato) gesendet werden sollen (wird empfohlen), muss man dies unter Mailübermittlung -> Delivery -> Mails über Relay-Host senden z.B. [smtp.strato.de] mit Port 587 eintragen und weiter unten die richtige Authentifizierung angeben.

4. Thunderbird:
Mit den oben genannten DNS-Einträgen konnten (nach einem Neustart des NAS) alle Mail-relevanten-Hosts angepingt werden (Grundvoraussetzung), Thunderbird wollte allerdings immer noch nicht verbinden.
Hab mit einigem Rumprobieren dann folgende, funktionierende Einstellungen in Thunderbird festgelegt:

-> Server (Eingang):
Server: imap.[DOMAIN.local]
Benutzername: NAME (für den Zugriff auf das NAS)
Verbindungssicherheit: STARTTLS
Port: 143
Authentifizierung: Passwort, normal

-> Server (Ausgang):
Server: smtp.[DOMAIN.local]
Port: 587
Verbindungssicherheit: STARTTLS
Authentifizierung: Passwort, normal
Benutzername: NAME (für den Zugriff auf das NAS)

Nachdem man dann mit Thunderbird versucht zu verbinden, beschwert er sich über ein unsicheres Zertifikat (was ja normal ist), dem wird also vertraut (Ausnahme dauerhaft hinzufügen).

5. Übersicht:
Mein System läuft nun wie folgt:
-> Mail-Eingang:
Welt -> Strato (Mail-Provider) -> POP3 durch Synology Mail Plus -> IMAP -> Thunderbird
  • POP3: verschiebt die Mails automatisch von Strato auf mein NAS und löscht sie [optional] bei Strato
  • IMAP: verwaltet die Mails auf dem NAS vom PC aus, ohne sie zu löschen, außer natürlich man löscht sie manuell
-> Mail-Ausgang:
Thunderbird -> SMTP -> NAS-Mail-Server -> Relay: Strato -> Welt
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: kamanu
Zurück
Top