Synology, OpenVPN und Android -> Konfigurationsproblem

omavoss

Lt. Commander
Dabei seit
März 2017
Beiträge
1.369
#1
Hallo alle,
was ich bereits gemacht habe:

- in der Fritzbox den OpenVPN-Port 1194 über UDP auf die Synology-NAS weitergeleitet

- auf der Synology-NAS den VPN-Server installiert

- OpenVPN aktiviert, die Standard-Konfiguration ohne Änderungen übernommen und die Konfigurationsdateien exportiert, das dabei exportierte File openvpn.zip ausgepackt

- in dem dadurch entstehenden Ordner openvpn sind vier Dateien enthalten: ca.crt, ca_bundle.crt, README.txt und VPNConfig.ovpn

- die VPNConfig.ovpn bearbeitet -> hier tauchen die ersten Fragen auf:

In der Original VPNConfig.ovpn lautet die erste Zeile : remote YOUR_SERVER_IP 1194, hier habe ich anstelle der YOUR_SERVER_IP meine DDNS-Adresse von Synology eingetragen, also (meine-quickconnect-id).synology.me; und die Zeile #redirect-gateway def1 habe ich einkommentiert, also das #-Zeichen entfernt.

Ist das erstmal soweit richtig oder habe ich hier bereits etwas falsch gemacht?

Nun habe ich den Ordner openvpn in das Android-Smartphone kopiert, auf dem bereits vorher der OpenVPN-Client installiert worden ist. Nach dem Öffnen des Clients bekommt man einen Screen, dessen unterste Option "OVPN Profile" lautet.
Hier mann man nun das Profil importieren, dazu wähle ich die vorher auf das Smartphone kopierte VPNConfig.ovpn aus. Es wird nun im Folgenden ein Benutzername und ein Passwort verlangt.

Dazu eine weitere Frage: welchen Benutzernamen und welches Passwort muss ich hierfür eingeben? Ich bekomme lediglich die Ausgabe: Disconnected, Authentication Failed, Username/password does not match.

Auf dem Smartphone habe ich natürlich W-LAN deaktiviert, denn ich will ja "von außen" mit dem Smartphone auf mein LAN zugreifen.

Ich bedanke mich bereits jetzt für eure Hinweise.
Viele Grüße.
 
Zuletzt bearbeitet:

GSXArne

Lieutenant
Dabei seit
Okt. 2009
Beiträge
772
#2
Da bisher keiner dir helfen konnte, versuche ich es mal mit meinen Halbwissen von meinen Qnap nas. Dort ist standardmäßig der gleiche Nutzername für die Openvpn Verbindung eingetragen wie für das Nas.

Das heißt, verbindest du dich mit admin/password mit dem nas , so gilt dieser Nutzer auch für die Openvpn Verbindung.

Da der Client meldet, dass Nutzername und Passwort nicht stimmen scheint die Verbindung über die ddns Adresse zu funktionieren.

Wie gesagt, nur Halbwissen von meinen Qnap.
Ich hoffe, ich konnte helfen.
Beste Grüße
 
Zuletzt bearbeitet:
Top