systemd UEFI-Boot Probleme mit Pop!_OS nach Kopieren der Partitionen

Tanzmusikus

Admiral
Registriert
Aug. 2010
Beiträge
9.089
Hallo,

ich hatte vorgestern mittels Gparted Lubuntu von der M.2-SSD entfernt und die Pop!_OS-Installation nach vorn kopiert.
Lubuntu war zuerst installiert inkl. ESP. Später wurde Pop!_OS mit zusätzlicher ESP manuell hinzugefügt.

In der Mitte befand sich eine NTFS-Partition mit Spielen und Daten für das Testen der beiden Distributionen.
Die swap-Partition habe ich am Ende belassen. Das Ganze wurde wegen Platzvergrößerung mit Gparted durchgeführt.

Ist-Zustand:
Code:
NAME       FSTYPE  UUID                                  PARTUUID                              LABEL      PARTLABEL
nvme0n1                                                                                                           
├─nvme0n1p1  vfat  F36B-213C                             260d9c55-d1ee-49ad-9d77-f767fe414c1f  EFI_POPOS 
├─nvme0n1p2  ext4  bf0da815-d72c-4b8b-baaf-11b3ac84a5f6  81d17331-6b01-4dab-9619-8f69bc90d45d  Pop!_OS    root
├─nvme0n1p3  ntfs  14752E9530BC6A3A                      0f8af442-2e2d-4c8b-b9cf-0fd6e0aa3a1a  Test-SSD   Basic data partition
└─nvme0n1p4  swap  1a008906-28cb-4beb-b21b-38d4164101ec  e3c82e08-8ead-4af0-8e28-8098d821f785  swap       swap

Uups, was ich vergessen habe:
Hatte zuvor ein Full-/Dist-Upgrade durchgeführt ... und eine User-Datei namens "keyring" o.s.ä. gelöscht wegen WineHQ-Warnung.
Vielleicht hatte ich mich auch vertan und die .Xauthority-Datei gelöscht. Würde das zum Fehlerbild passen?

Hab dann gleich nochmals die Partitionen neu angerdnet & vorsorglich eine Recovery-Partition hinzugefügt.
Diese ist aber (noch) nicht aktiv. Das werde ich nach der "Wiederbelebung" angehen.

Code:
nvme0n1      931.5G  FSTYPE  DISK
├─nvme0n1p1    500M  vfat    part /boot/efi  (boot,esp)
├─nvme0n1p2      4G  vfat    part            (recovery)
├─nvme0n1p3      8G          part            (swap)
├─nvme0n1p4    500G  ext4    part /          (root,home)
└─nvme0n1p5    360G  ntfs    part            (games)

Gestern hatte ich mittels Pop!_OS 21.10 ein Chroot-Vorgang erfolgreich umgesetzt, dabei erneut ein Dist-Upgrade inkl. Kernel- sowie Bootconfig-Aktualisierung vornehmen lassen. Leider kam ich nach einem Neustart nur bis zum Single-User-Terminal wie bereits zuvor.

Könnte also doch an der versehentlich gelöschten Datei ".Xauthority" liegen, oder?
Nächster Schritt wäre, diese per Single-User-Terminal oder Chroot wieder herzustellen.
Im Netz fand ich etwas zu xauth: https://akashmittal.com/xauthority-not-exist/

Würde mich über Ideen und Lösungsvorschläge von Euch freuen. 🧐
Grüße

P.S.
Hardware: Ryzen 2700X, ASRock X470 Taichi, RX 5700 XT, 32 GB DDR4, Firecuda 530 1TB M.2
Betriebssystem: Pop!_OS 21.10, manuell installiert im (U)EFI-Mode, systemd_boot, (noch) keine Recovery-Funktion aktiv
 
Tanzmusikus schrieb:
Vielleicht hatte ich mich auch vertan und die .Xauthority-Datei gelöscht. Würde das zum Fehlerbild passen?
Eher nicht. Das ist eine Datei die angelegt wird wenn Xorg gestartet wird. Problematisch wird es für die laufende Xorg-Session wenn Du die Datei im laufenden Betrieb entfernst (und selbst dann bleiben keine dauerhaften Schäden sondern beim nächsten Boot ist alles wieder ok).
Aber das ist bei Dir hier ja nicht der Fall.

Tanzmusikus schrieb:
Leider kam ich nach einem Neustart nur bis zum Single-User-Terminal wie bereits zuvor.
Ist das ein echtes Single-User-Terminal oder befindest Du Dich lediglich auf der Textkonsole?

Und was sagen die diversen Logs? Wenns ein Problem gibt, dann wirst Du dort oft Hinweise.
Keine Ahnung wie das bei Pop!OS ist aber ich glaub die nutzen systemd-journald und dort kannst Du Dir alle Systemlogeinträge seit dem Boot mit
journalctl -b
anzeigen lassen.
 
  • Gefällt mir
Reaktionen: Tanzmusikus
Könntest du mal genauer sagen, was du entfernt hast?
Ich nehme mal an Partitionen? Wie sieht die fstab aus, stehen dort vielleicht falsche UUIDs?
 
  • Gefällt mir
Reaktionen: KJQm8v und Tanzmusikus
andy_m4 schrieb:
Ist das ein echtes Single-User-Terminal oder befindest Du Dich lediglich auf der Textkonsole?
Das ist wohl der Emergency-Modus, also quasi Fallback-Booteintrag.

andy_m4 schrieb:
Und was sagen die diversen Logs? Wenns ein Problem gibt, dann wirst Du dort oft Hinweise.
Keine Ahnung wie das bei Pop!OS ist aber ich glaub die nutzen systemd-journald und dort kannst Du Dir alle Systemlogeinträge seit dem Boot mit
journalctl -b
anzeigen lassen.
Pop!_OS hatte dort u.a. den Befehl journalctl -xb empfohlen.
Werde auch journalctl --list-boots und journalctl --p err -b probieren.
Ich mache dann Fotos vom Journal mit obigen Parametern.


mytosh schrieb:
Könntest du mal genauer sagen, was du entfernt hast?
Ich nehme mal an Partitionen? Wie sieht die fstab aus, stehen dort vielleicht falsche UUIDs?
Wie die einzelne Datei heißt, habe ich nicht mehr ganz im Kopf.
Sollte der "Öffentliche Schlüssel" o.s. von WineHQ im "/home/user"-Verzeichnis gewesen sein.

Partitionen hatte ich "ESP" (nvme0n1p1) & komplette "/" (nvme0n1p2) von Lubuntu entfernt.
Danach "ESP" & "/" sowie später auch "swap" von Pop!_OS an deren Stelle kopiert.

Die fstab werde ich mal untersuchen und dann hier posten.

Danke Euch schon mal !!
🙂
 
Zuletzt bearbeitet:
Tanzmusikus schrieb:
Wie die einzelne Datei heißt, habe ich nicht mehr ganz im Kopf.
Sollte der "Öffentliche Schlüssel" o.s. von WineHQ im "/home/user"-Verzeichnis gewesen sein.

🙂
Vollkommen unwichtig. Du hast die Partitionen neu vermischt. UUID in der fstab bzw. Grub? prüfen. Neuinstallation geht schneller.

mkdir -p ~/grub-backup
cp /etc/default/grub ~/grub-backup/
sudo cp -R /etc/grub.d/ ~/grub-backup/
update-grub

Für die Zukunft.
 
Journal zeigt, dass eine Partition beim Booten anhand der PARTUUID nicht gefunden wurde.

boot-device-timed-out.jpg



Diese ist in der /etc/fstab eingetragen.

fstab.jpg


Jetzige ESP PARTUUID=260d9c55-d1ee-49ad-9d77-f767fe414c1f.
Na dann ändere ich das mal eben ... :mussweg:
 
  • Gefällt mir
Reaktionen: mytosh
KJQm8v schrieb:
Vollkommen unwichtig. Du hast die Partitionen neu vermischt. UUID in der fstab bzw. Grub? prüfen. Neuinstallation geht schneller.
Neuinstallation geht schneller als eine Zeile in der fstab anzupassen?
 
Vielen Dank allen!
Das System läuft wieder wie ein Reh im Walde. 🌿🐎🌳
 
Zurück
Oben