TL-WDR4300 mit OpenWRT VPN hinter Fritzbox 7390

Ava_lon

Cadet 1st Year
Dabei seit
Apr. 2014
Beiträge
8
Hallo Leute!

Ich weiß einfach nicht merh weiter.
Zugegebenermaßen bin ich extremer Laie auf dem Gebiet, aber was ich auch lese, es hilft mir nicht sonderlich weiter.
Ich hoffe mir kann jemand weiterhelfen.
Ich habe 2 Router: Fritzbox 7390 und TP-Link WDR4300 sowie massig Endgeräte.
Optimale Lösung:

------------------------------------------------------------Internet
Endgeräte (LAN)----|---------------------------------------|----------| Endgeräte (LAN)
-------------------------|--TP-Link(VPN-Client)--------Fritzbox------|
Endgeräte (WLAN)-|--------------------------------------------------| Endgeräte (WLAN)

Alle Geräte am TP-Link sollen über einen VPN-Provider ins Internet gehen, alle Geräte an der Fritzbox ganz normal.
Alle Geräte sollen untereinander sichtbar sein und kommunizieren können.
TP-Link und Fritzbox sind jeweils Subnetze.

Alternativ wäre auch nur ein großes Netzwerk in Ordnung, aber Subnetze wären schöner.

Ich hoffe ich konnte mein Anliegen etwas deutlich machen.

Aktuell ist auf dem TP-Link OpenWRT installiert und der TP-Link ist per WAN-Port (über einen Switch) mit einem LAN-Port der Fritzbox verbunden.
Den WAN Port habe ich im OpenWRT aber noch nocht zum laufen gebracht...
 

Raijin

Admiral
Dabei seit
Nov. 2007
Beiträge
9.584
Hm.. Du bist "extremer Laie" und versuchst dich an einem relativ komplexen Konstrukt. In deinem Setup musst du mehrere Routen konfigurieren, Regeln in der Firewall definieren und und und.. Ein ambitioniertes Vorhaben, wenn ich das mal so sagen darf.
 

Ava_lon

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
Apr. 2014
Beiträge
8
Ja, das ist leider meistens so bei meinen Projekten.
Was soll ich machen? Man überlegt sich etwas und versucht es umzusetzen :)
Naja "extremer Laie" ist vielleicht auch etwas übertrieben.
Netzwerk einrichten, routen und Firewall konfigurieren sind jetzt auf jeden Fall keine Fremdwörter.
Ich kann auch statische Routen einrichten, bin mir in erster Linie bloß überhaupt nicht sicher, ob sich dieses Konstrukt überhaupt mit nur 2 Routern durchführen lässt.
Ich denke, jeder Router fungiert als DHCP im jeweiligen Subnet und soll zusätzlich noch jeweils ins andere Subnet routen wobei die FB noch das Modem bereit stellt.
Ich meine mal gelesen zu haben, dass man hierfür einen dritten Router benötigt, der das Routing zwischen den beiden Subnetzen übernimmt.

Ich habe aktuell den TP-Link über LAN-LAN an der Fritz, DHCP aus und IP zugewiesen. Somit steht schonmal ein Netz.
Ich werde jetzt erstmal den VPN CLint auf dem TP zum laufen bringen und dann weiter sehen.

Zwei Subnetze wären trotzdem schön. Und lernen möchte ich dabei ja auch ganz gern was :)

EDIT: Habe statt OpenWRT nun DD-WRT genommen, da ich ständig Probleme mit den Paketen hatte.
Vielleicht kann ja jemand das Thema anpassen.
VPN-Client ist Konfiguriert.
Wie bekomme ich denn die Angeschlossenen Endgeräte über diese VPN Verbindung ins Net?
IPs ändern sich nicht o.O
Muss der Router evtl über WAN verbunden werden?

EDIT: Habe es geschafft an die log zu kommen. Ging über Command im dd-wrt irgendwie nicht.
Telnet hat aber geklappt.
Dort sagt er mir, dass er meine Anmeldedaten für den VPN Provider nicht finden kann:
"--auth-user-pass fails with '/tmp/auth.conf': No such file or directory"
Allerdings ist die Datei vorhanden und (über vi geprüft) auch mit meinen Daten gefüllt...
Kennt jemand das Problem?
 
Zuletzt bearbeitet:

Raijin

Admiral
Dabei seit
Nov. 2007
Beiträge
9.584
Aha.. "VPN" ist ein Überbegriff für einen Teilbereich der Netzwerktechnik. Solange du nicht sagst was für ein VPN du nutzt und wie du dich dort authentifizierst (Zertifikate, Passwort, etc.) ist es müssig, darüber zu diskutieren. Ich tippe zwar auf OpenVPN, der Fehler ist mir jedoch im Rahmen von Zertifikaten noch nicht untergekommen - evtl. Benutzername/Passwort-Authentifizierung? Es könnte sein, dass Zugriffsrechte für die Datei fehlen obwohl ich dann eine entsprechende Fehlermeldung erwarten würde.
 

Ava_lon

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
Apr. 2014
Beiträge
8
Ja, natürlich :)
Ich nutze OpenVPN auf dem DD-WRT über Nutzername und Passwort.
Diese sind in der auth.conf hinterlegt, welche auch existiert und befüllt ist.
Ich kann auch nicht sagen wo der Fehler war, aber ich habe den OpenVPN Dienst jetzt nochmal als Statup Command eingetragen und nun funktioniert es komischerweise...
 
Top