Win 10 1903 SMB Shares beim Start nicht verbunden

sasbro97

Lt. Junior Grade
Dabei seit
Nov. 2014
Beiträge
321
Heyho. Bei jedem Windows Start sind meine 5 SMB Freigaben vom Server nicht verbunden und rot. Sobald ich aber nur einen Doppelklick darauf mache bin ich aber problemlos drin. Aber woran liegt das? Kann man das nicht beheben?

Verzögerungen entstehen dadurch nur selten und wenn minimal. Aber irgendwie stört mich das alleine schon optisch als Perfektionisten...
 

evilbaschdi

Lt. Commander
Dabei seit
Aug. 2011
Beiträge
1.937
das neueste update ist schon drauf? den fehler an sich kenn ich durchaus, nicht nur von smb.
mit irgend nem update vom frühsommer war es aber dann behoben.

dachte bei der überschrift zuerst daran, dass microsoft smb ja ausgebaut / bzw. in die optionalen features verschoben hat. das sollte es aber ja nicht sein, da es ja grundsätzlich funktioniert.
 

sasbro97

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Nov. 2014
Beiträge
321
@evilbaschdi Ja, bin immer up-to-date. Hab auch unglaublicherweise im Gegensatz zu allen anderen noch nie durch Windows Updates Bluescreens oder sonstige Probleme gehabt und das schon seit gut 10 Jahren nicht. Nur mal ein Problem, dass ich nicht updaten konnte, aber das war es auch.

Ich hab deshalb auch keine Ahnung. Der verbindet sich halt nicht direkt automatisch. Aber du klickst drauf: zack grün und bist drin und das sofort. Unerklärlich. Sowas kann aber nicht am Server liegen oder?
 

evilbaschdi

Lt. Commander
Dabei seit
Aug. 2011
Beiträge
1.937
die session kann ja grundsätzlich aufgebaut werden. wenn dann scheitert es am zeitpunkt. gab damals ja den workaround, per mehr oder weniger "logon script" die laufwerke zu verbinden.
 

mr hyde

Lieutenant
Dabei seit
Okt. 2012
Beiträge
828
Ich hatte schon seit Win7 Zeiten das gleiche Problem. Hintergrund ist wohl, dass Windows versucht die Netzwerklaufwerke zu mappen zu einem Zeitpunkt, an dem entweder die Netzwerktreiber "noch nicht fertig" sind oder die Verbindung zum Server noch nicht steht. Ich habe es mit einem VBS Script im Autostart gelöst, anhand dieser Vorlage: http://www.gtkdb.de/index_29_1849.html .
Notfalls kann man in das Script noch eine 5 Sekunden Pause einfügen, ist hier bei mir allerdings nur am alten Win7 Rechner nötig. Mein Win10 Rechner kommt ohne aus.
 

mkdr

Banned
Dabei seit
Sep. 2010
Beiträge
1.240
Das ist normal und offensichtlich, es werden erst nach und nach die services geladen und einer davon ist halt noch nicht gestartet. Je nachdem wie zugemüllt dein PC ist, wie schnell er ist wie schnell die SSD ist kann sich das timing fenster da verschieben dass es mal auftritt mal nicht, bei einigen, bei anderen nicht.
 

sasbro97

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Nov. 2014
Beiträge
321
Kann man einfach ein Delay einbauen irgendwie, irgendwo? Jedes mal ganz neu connecten ist doch bescheuert... das brauchte ich aber auch als ich eine WebDAV Verbindung beim Neustart haben wollte. Alles irgendwie so gar nicht 2019...
 

mkdr

Banned
Dabei seit
Sep. 2010
Beiträge
1.240
Hat er doch oben geschrieben. Setz einfach ein net connect script mit delay in den Windows scheduler.
 

sasbro97

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Nov. 2014
Beiträge
321
@mkdr Problem ist, dass mir das nicht viel sagt. Hab mit dem Aufgabenplanungszeugs etc. nie gearbeitet. Hatte zuletzt nur eine .bat irgendwo liegen und die wurde unschön aufgerufen.
 

sasbro97

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Nov. 2014
Beiträge
321
@xexex Funktioniert nicht, schon ausprobiert.

Und ich weiß nicht, was direkt mit den Freigaben heißen soll.
 

mr hyde

Lieutenant
Dabei seit
Okt. 2012
Beiträge
828
@sasbro: copy paste das script in ne .vbs datei, und die in den autostart legen. ist doch nicht so schwer!
 

mkdr

Banned
Dabei seit
Sep. 2010
Beiträge
1.240
Ja kleister einfach n net use X: \\SERVER\Share in den scheduler login 30sec delay.
 

sasbro97

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Nov. 2014
Beiträge
321
@xexex Nehme das mit den direkten Freigaben zurück. Stimmt eigentlich. Mit WebDAV hatte ich damals Probleme, aber jetzt mit SMB sollte das gehen. Gute Idee!
 

sasbro97

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Nov. 2014
Beiträge
321
Ich hab das jetzt auch geändert. Sieht dann nicht mehr so doof aus :D
1573454833819.png
 

updater14

Lt. Commander
Dabei seit
Juni 2014
Beiträge
1.284
Statt bei jeder Anmeldung einem Laufwerk "X:" die Freigabe "\\server\daten\" zuzuweisen, wieso nicht einfach die benötigten Freigaben direkt in den Schnellzugriff packen...
Es gibt durchaus Programme, die auch in 2019 nicht mit UNC-Pfaden klarkommen und die guten alten Netzlaufwerke benötigen. ;)
Variante 1 über die GPO eine Laufwerkszuordnung, oder aber über eine kleine Batch als Logon Skript.

@topic
Wird die erwähnte GPO denn überhaupt gezogen?
 

xexex

Fleet Admiral
Dabei seit
Jan. 2010
Beiträge
11.000
Es gibt durchaus Programme, die auch in 2019 nicht mit UNC-Pfaden klarkommen und die guten alten Netzlaufwerke benötigen.
Mir klar! Die sind dann auch noch nicht in 2019 angekommen...… :evillol:

Laufwerksbuchstaben haben auch noch den Vorteil, dass die bleiben auch wenn sich der Servername ändert. Letztlich ist es auch nur eine Option, die nicht immer gut sein muss.

Seit Microsoft damit angefangen hat "Dieser PC" "vollzumüllen", habe ich es mir aber angewohnt gleich mit dem Schnellzugriff zu arbeiten und da bieten sich dann auch gleich die Pfade an.
 

jo89

Lt. Commander
Dabei seit
Apr. 2011
Beiträge
1.758
Ich hab das bei mir ganz ordinär über eine Batch gelöst. Die wird beim starten ausgeführt und löscht erst alle Netzlaufwerke bevor sie alle benötigten neu verbindet.
Für Dateien und einfache Freigaben funktioniert das zum Glück noch immer prima.
 
Zuletzt bearbeitet: (Rechtschreibung)
Top