Windows 8 in Multiboot System: CHKDSK Probleme

motzerator

Lt. Commander
Dabei seit
Juli 2011
Beiträge
1.139
Ich habe Windows 8 in einer Multiboot Umgebung installiert.

Jedesmal wenn ich von Windows 8 zurück auf Windows 7 gehe, wird für jede einzelne NTFS Partition der chkdsk durchlaufen, bevor nach ein paar Neustarts dann Windows 7 wieder bootet.

Bisher habe ich Windows 7 und Windows Vista auf zwei verschiedenen SSD installiert, wenn ich dazwischen hin und her wechseln tue, habe ich keinerlei Probleme.

Ich hatte Windows 8 zuerst auf einer 3,5" HDD in einem Externen Dock installiert, das über SATA angeschlossen ist. Da habe ich die Probleme noch auf das Dock geschoben.

Jetzt habe ich eine kleine 2,5" Notebook Festplatte fest eingebaut und dort Windows 8 noch einmal installiert. Die Installation ging einwandfrei und ich konnte damit auch arbeiten. Aber kaum habe ich wieder über das Bios/Bootreihenfolge zurück auf mein Hauptsystem Windows 7 geswitcht, meldete sich beim booten wieder der CHKDSK.

Zur Konfiguration:

Intel 510 128 GB SSD mit Windows 7
Samsung 470 64 GB SSD mit Windows Vista
Samsung 1 TB HDD mit Daten, FAT 32 (hier gabs NIE chkdsk nach der Rückkehr)
Toshiba 200 GB HDD 2,5" mit 1 FAT32 Partition und Windows 8

Das Windows 8 wurde neu in eine leere Partition installiert.

Ich hab ein ASUS Mainboard, einen Core I3 2100 und nutze die Interne Grafikkarte.

Die Auswahl des zu bootenden OS treffe ich über das Bios, und wenn ich nur mal kurz ein anderes Laufwerk mit einem anderen OS botten will, drücke ich beim Start die Taste F8, das führt im Bios zur Anzeige aller bootbaren Laufwerke.

Bisher hat das immer problemlos funktioniert, habe das damals auch bei der Beta von Windows 7 gemacht und nie Ärger gehabt.

Mit einer Aussnahme: Windows (egal welche Version) mochte es garnicht, wenn es auf einer Platte in Standby versetzt wurde, ich dazwischen ein anderes OS benutzt habe und dann das os aus dem deepsleep wieder erweckt habe.

Als nun zu meinen Fragen:

Windows 8 soll ja nicht mehr ordentlich runterfahren, könnte also eventuell daran liegen. Weis jemand wie man Windows 8 komplett herunterfährt anstatt es in den Tiefschlaf zu versetzen?

Warum machen immer nur die NTFS Partitionen zicken und was treibt Windows 8 da eigentlich, wenn es doch auf einer ganz anderen Platte installiert ist?

Habe nur ich das Problem in Multiboot Umgebungen mit mehreren Platten oder können andere das bestätigen. Ist es also eher ein lokales Problemchen oder eher ein Windows 8 Problem?

Ich benutze keinen Bootmanager, auf jeder Platte/SSD ist nur ein Betriebssystem installiert.

Ich weis, man soll Windows 8 nicht auf produktiven Systemen installieren, aber wie soll ich das sonst in meiner gewohnten Umgebung testen?
 

ottkog

Lt. Commander
Dabei seit
Juli 2010
Beiträge
1.286
Also ich habe 4FP 3SSD 1 HDD angeschlossen und nichts in den Bios verändert da ich beim installieren der BS die anderen FP abklemme sodas jede platte einen eigenen Bootmanager hatt.Beim hochfahren zeigt mir Win 1-4 Platten an und ich kann mit dem Mainboard Zeiger rauf und runter variieren.
 

motzerator

Lt. Commander
Ersteller dieses Themas
Dabei seit
Juli 2011
Beiträge
1.139
Ich stell immer die platte als Bootlaufwerk ein, auf der ich installieren will. Bisher war es nicht nötig, die anderen Platten abzuklemmen, damit das Installieren Funktioniert. Hast Du denn auch Windows 8 am Start bei dir und keine Probleme? Wenn ja, wie fährste runter?

Kann ich aber gern mal mit in die Liste der möglichen Optionen aufnehmen. Neu Instalieren und andere Platten abklemmen.

Aber: Warum meckert CHKDSK bei ALLEN NTFS und bei keiner FAT32 Partition?
 

Selissa

Lieutenant
Dabei seit
Feb. 2011
Beiträge
916
Komischerweise hatte ich ein ähnliches/gleiches? Problem.

W8 kannst du ganz herunterfahren, wenn Du Hibernate abstellst: powercfg.exe /hibernate off

Sag bitte bescheid, wenn es klappt.

Zusätzlich hätte ich auch eine Frage. Hatte zuerst eine normale Bios Installation, da er nicht automatisch Uefi machte (wie gewohnt, lag wohl am USB Stick). Einen Tag später habe ich nochmal mit Uefi installiert. Komischerweise brauchte er danach länger zum Booten (sind jetzt mit Treibern 25 s). Ist jetzt kein Beinbruch, aber trotzdem irgendwie komisch, und weit weg von den optimalen 8 s. Einer ne Ahnung woran es liegen könnte?
 

motzerator

Lt. Commander
Ersteller dieses Themas
Dabei seit
Juli 2011
Beiträge
1.139
Du sagst Du "hattest" die Probleme. Hast Du sie jetzt nicht mehr? Und wie hast Du sie abgestellt?

Mein BIOS hat auch UEFI, ob das damit was zu tun haben könnte? Und wie hast Du das mit UEFI installiert, ich hab da keinerlei Optionen gesehen, habe die ISO auf DVD gebruzzelt und davon installiert.
 

Selissa

Lieutenant
Dabei seit
Feb. 2011
Beiträge
916
Ähm, hab einfach eine wieder ins Laptop gebaut und mich nicht weiter darum gekümmert^^

Edit: Für UEFI musst das vorher im "Bios" auf UEFI umstellen und dann auch das Bootmedium als UEFI Medium booten.
 

motzerator

Lt. Commander
Ersteller dieses Themas
Dabei seit
Juli 2011
Beiträge
1.139
Also der Befehl zum Ausschalten des Standby hat leider das Problem nicht gelöst, es kommt nach wie vor CHKDSK aufrufen.

Ich habe dann mal versucht, eine neue ISO herunterzuladen, diesmal 64 Bit statt 32 Bit und diese hab ich diesmal auch betüglich dem HASH kontrolliert um einen Fehlerfreien Download sicher zu stellen.

Leider ohne Erfolg, es kommt immer noch dazu, das CHKDSK aufgerufen wird. Ich befürchte fast, das es etwas mit UEFI zu tun hat, weis hier einer ein Tutorial was man da im Bios einstellen kann? Bei Tante Wiki hab ich da nicht viel verständliches gefunden.
 

Selissa

Lieutenant
Dabei seit
Feb. 2011
Beiträge
916
Kann Dir da leider nicht weiterhelfen. Konnte aber meine Frage mittlerweile klären.
Wenn man auf Neu Starten geht, wird ein Komplettboot durchgeführt. Wenn man ausschaltet und wieder ein, und hat Super/Prefetch auf 2 oder 3 stehen, bootet W8 in 5 s.
 

motzerator

Lt. Commander
Ersteller dieses Themas
Dabei seit
Juli 2011
Beiträge
1.139
Du hast mir indirekt aber einen Tip gegeben. Es scheint daran zu liegen, das Windows 8 den PC normalerweise nciht mehr komplett herunter fährt, sondern einen Suspend to Disk macht.

Dabei wird scheinbar das sogenannte "dirty flag" der Partitionen nicht gelöscht, Windows 8 denkt ja es währe noch in Betrieb da es nicht komplett heruntergefahren wurde, auch wenn man als Anwender das eigentlich denkt.

Ich hatte auch schon früher CHKDSK Probleme, wenn ich ein OS nicht komplett herunter gefahren und zu einem anderen gewechselt habe. Daher habe ich mal ausprobiert, die Funktion "NEU STARTEN" statt "HERUNTERFAHREN" zu wählen, um dann im BIOS einfach eine andere Platte anzubooten.

Beende ich Windows 8 mit "Neu Starten", habe ich keine Probleme mehr mit CHKDSK. Bei "NEU STARTEN" wird Windows 8 komplett heruntergefahren, wechselt man dabei im BIOS auf eine andere Platte hat man kein Ärger mehr :)

Habe das Thema auch im Technet angesprochen, dort kam noch eine recht nett bebilderter Vorschlag von einem anderen User mit einer Einstellungsoption in der Systemsteuerung, die in meiner Version so leider nicht zu finden ist. Aber mit "NEU STARTEN" geht es ja auch.

http://social.technet.microsoft.com/Forums/en/w8itproinstall/thread/5f477c3d-d914-4c9f-a477-541e7e74945e
 

motzerator

Lt. Commander
Ersteller dieses Themas
Dabei seit
Juli 2011
Beiträge
1.139
fährste den rechner komplett runter?

Die probleme hatte ich auch, wenn ich zum beispiel aus versehen windows vista in standby geschickt habe statt es richtig runterzufahren und dann nach windows 7 gewechselt bin.

grundsätzlich solltest du festplatten nur wechseln:

1. wenn der PC runtergefahren ist und das nicht mit suspend to disk!
2. Wenn es exteren/wechselramen sind, dann guck mal ob du im bios setup einstellen kannst, das der port hotswap fähig ist. wenn ja wie bei mir kann man platten auch hinzufügen wenn der pc an ist, die werden dann behandelt als wenn man eine speicherkarte einsteckt. wie bei speicherkarten muss man die aber auch abmelden, bevor man sie bei laufendem rechner rausnimmt, sonst datenverlust.

sobald du mehrere betriebssysteme auf verschiedenen platten hast:

Erst KOMPLETT runterfahren, dann Betriebssystem wechseln :)

Und nimm lieber FAT32!
NTFS ist sehr zickig und nur etwas für WINDOWS BOOT PARTITIONEN :)

Wobei das meine Meinung ist, es gibt auch andere. Aber meiner Erfahrung nach ist FAT32 robuster :)

Auch hier haben mal wieder nur die NTFS gezickt ;)
 
Top