ARP: Statischer Eintrag wird nicht gesetzt (raspbian)

rebecca1983

Cadet 3rd Year
Dabei seit
Sep. 2007
Beiträge
32
Hallo,

eine Verständnissfrage:

Ich habe die Anleitung für statische ARP-Einträge von http://www.thomas-krenn.com/de/wiki/Statischen_ARP_Eintrag_einrichten
befolgt, aber mein Win7-System ist nicht als statisch definiert (Flags Mask: "M").

Was ich nicht verstehe: Warum wird RBECCA aufgelöst als IP in meiner ARP-Table aufgeführt?

Ziel ist es, als Übung auf meinem RASPBIAN nur statische ARPs einzutragen.

Danke für Antworten,

Rebecca
 

Anhänge

Thermi

Lt. Commander
Dabei seit
Apr. 2009
Beiträge
1.308
Hallo,

Die ARP-Tabelle beinhaltet die Werte in numerischer Form, ohne Namen. ALso die IP wird als IP gespeichert.
IPs werden bei der Ausgabe von "arp" standardmäßig in DNS-Namen umgewandelt, falls das möglich ist; also ein PTR-EIntrag für diese IP im DNS-System vorhanden ist. Nun, für deinen Speedport liefert ebendieser einen solchen EIntrag zurück (speedport.ip), für "REBECCA" gibt es jedoch keinen, also wird nur die IP angezeigt. Du kannst dir mit der Angabe des Parameters "-n" beim Aufruf von "arp" die numerischen Werte direkt einzeigen lassen, ohne diese in die entsprechende menschenlesbare Form umzuwandeln.
Ich vermute, dass dein Speedport den Namen "REBECCA" nicht über DNS auflösen kann oder keinen statischen Hostname-Eintrag dafür hat. Daher schlägt der Befehl beim Ausführen des Skripts beim Hochfahren der Schnittstelle vermutlich fehl und die IP wird automatisch über ARP hinzugefügt und gelernt.

Du bist übrigens gut damit beraten, iproute2 statt den alten net-tools zu nutzen. Hier sind die Gründe dafür.

Grüße,
Thermi
 

rebecca1983

Cadet 3rd Year
Ersteller dieses Themas
Dabei seit
Sep. 2007
Beiträge
32
Hi Thermi,

danke für die technisch fundierte Antwort.
Deinen Link werde ich mir anschauen, danke für den Hinweis!

Gruß

Rebecca
 
Top