Bash: Automatische Eingabe von yes

chinamaschiene

Lt. Commander
Dabei seit
Mai 2008
Beiträge
1.257
hallo,

ich habe ein programm was ein yes [ENTER| verlangt ca 1 sek nach dem das gestartet ist. wie kann ich sowas automatisch machen.

sachen wie echo "y\n" | programm oder auch röhren oder umleitungen zu stdin gehn leider nicht. muss ich da irgentwo nen sleep einbauen oder ist das ganz falsch.
 

LATEX

Lt. Junior Grade
Dabei seit
Feb. 2006
Beiträge
490
Wenn du eine Funktion benützt die beim Aufruf zulässt meist -y alle Fragen mit ja zu beantworten würde ich es so lösen.
 

chinamaschiene

Lt. Commander
Ersteller dieses Themas
Dabei seit
Mai 2008
Beiträge
1.257
danke fuer die antwortn. leider verstehe ich sie gar nicht.

was muss ich jetzt in der bash eingeben genau?

hier mal was ich genau will: ich will mit sntp die zeit einstellen und das bringt immer diese sicherheitsmeldung. das ist aber behindert bei nen startupskript.

sntp -r nist.time.gov
The time correction is 15970940.330 +/- 0.036+0.039 seconds
Do you want to correct the time anyway?
 

Sug82

Lt. Commander
Dabei seit
Juni 2005
Beiträge
1.754
nochmal bissl ausführlicher
command << EOF
y oder yes oder wasauchimmer
EOF

Falls nicht geht tut expect bestimmt.
 

chinamaschiene

Lt. Commander
Ersteller dieses Themas
Dabei seit
Mai 2008
Beiträge
1.257
habe genau das in nen batch datei geschrieben.Antwort ist die gleiche wie bei dem Befehl

# sntp -r time.nist.gov <> echo "y"
oder
# echo "y" | sntp -r time.nist.gov

Code:
sntp: time correction too large: 1597142.182 +/- 0.035+0.040 seconds
das liegt aber nicht an sntp, weil wenn ich von hand y enter eingebe klappt es

den befehl expect kenne ich bzw. bash nicht
 

Sug82

Lt. Commander
Dabei seit
Juni 2005
Beiträge
1.754
Wenn expect, dann musst du es zunächst installieren, und wie man das nutzt "man expect", denn ich habe keine Lust die Funktionsweise von expect zu erklären. Einfach mal suchen.

Übrigens, ist die Zeitkorrektur so groß? Stimmt der Rechner nicht?
 
Zuletzt bearbeitet:

chinamaschiene

Lt. Commander
Ersteller dieses Themas
Dabei seit
Mai 2008
Beiträge
1.257
die batterie ist leer. und fuer dieses billige problem installier ich sicher nicht noch ein programm. geht bestimmt auch mit den normalen standartools. da such ich mir besser nen anderen zeitsynchronisierer als sntp. troztzdem vielen dank fuer deine hilfe.

vielleicht hat ja jemand anderes noch nen idee, evtl. muss man nen sleep oder so einbauen?
 

magus16

Ensign
Dabei seit
Sep. 2005
Beiträge
194
Code:
sntp -P no -r nist.time.gov
 

chinamaschiene

Lt. Commander
Ersteller dieses Themas
Dabei seit
Mai 2008
Beiträge
1.257
hey Ensign magus16

das hat mein problem geloest. ich habe auch wirklich die manpage gelesen als erstes. blos habe ich das fuer irgentwas komisches anderes gehalten bzw. beim druberlesen nicht richtig verstanden auf englisch. hab irgendwie nach so was wie quiet gesucht. jetzt ist mir das klar

Code:
 -P prompt
              sets the maximum clock change that will be made automatically to
              maxerr.   Acceptable  values  are  from 1 to 3600 or no, and the
              default is 30.  If the program is  being  run  interactively  in
              ordinary  client  mode,  and  the system clock is to be changed,
              larger corrections will prompt the user for confirmation.  Spec-
              ifying  no  will  disable  this  and the correction will be made
              regardless.
dann weis ich mich mal selber auf das 1. gebot hin ;-)

Lieutenant chinamaschiene@:
RTFM!!

vielen dank das du so freundlich warst und mir trotz meinem behinderten verhalten geantwortet hast! :schluck:
 
Zuletzt bearbeitet:
Top