Bluescreen bei zwei Netzwerkkarten in einem Rechner

Lord_Nelson

Newbie
Dabei seit
Aug. 2020
Beiträge
1
Hallo erstmal!

Ich arbeite in einem mittelständischen Betrieb und bin hier für ca. 30 PC zuständig. Wartung und Instandhaltung etc.
Jetzt haben wir einige neue Maschine erhalten und der Techniker hat diese mit insgesamt 3 Patch Kabel (CAT 5e) zu einem Switch geführt und von diesem Switch mit einem PC (specs in Screenshot anbei Windows 10 Version 2004) verbunden. Die Maschinen haben nun ihren eigenen IP-Pool (z.B. 192.168.40.11) unser Firmennetz mit den 30 PC's hat jedoch einen anderen IP-Pool (z.b. 192.168.0.39) auf den ich auf jeden fall zugreifen möchte. Meine Idee war es, ich baue einfach eine weitere Netzwerkkarte (Bild der Verpackung auch dabei) ein und stelle die IP-Adresse der Karte 1 auf die Maschine ein und die zweite Netzwerkkarte auf das Firmen Netzwerk.

Gesagt getan, baue also die zweite Netzwerkkarte ein und Installiere über die beigelegte CD den Treiber. Bei der Treiber Installation war noch kein Netzwerkkabel angeschlossen. Alles Funktionierte wunderbar. Nach ca. 1-2 Minuten jedoch ein Bluescreen (Auch als Screenshot dabei). Danach habe ich unter dem Gerätemanager den Treiber auf Updates überprüft. Er hat sogar einen neuen Treiber gefunden und diesen installiert.
Jedoch keine Verbesserung. Wieder ein Bluescreen nach 1-2 Minuten.

Wenn ich das Kabel, das zur zweiten Netzwerkkarte geht, abziehe bekomme ich keinen Bluescreen mehr. Das die Karte einen Kurzschluss hat, glaube ich nicht da sonst sofort eine Fehlermeldung kommen würde und nicht erst nach 1-2 Minuten.

Die üblichen Verdächtigen sowie Kabel sind schlecht, Kabel getauscht, habe ich schon alles durch. KEIN Ergebnis.

Bitte um Hilfe ich sehe kein Licht am Ende des Tunnels.
Danke im Voraus.
 

Anhänge

  • specs.png
    specs.png
    10,8 KB · Aufrufe: 294
  • NEtzwerkkarte.jpg
    NEtzwerkkarte.jpg
    508,1 KB · Aufrufe: 300
  • Bluescreen.jpg
    Bluescreen.jpg
    1,3 MB · Aufrufe: 308
Konfiguriere zuerst die Netzwerkkarte, danach steckst du das Kabel ein. Wobei wenn du in einer kontrollierten Domäne bist, wird das wohl vom Admin gesperrt sein. (Zusätzliche Hardware), also frag ihn doch um Rat.
 
Zitat von Lord_Nelson:
Ich arbeite in einem mittelständischen Betrieb und bin hier für ca. 30 PC zuständig
Hm.. Und dann meldest du dich in einem Forum, in dessen Titel explizit von Heimnetzwerken die Rede ist?

Abgesehen davon lesen sich deine Ausführungen so als ob du - sorry - nicht wirklich Ahnung von Netzwerken hast. Es ist daher fraglich inwiefern du überhaupt für diese Aufgabe in Frage kommst. Ich will dir da nicht auf den Schlips treten, aber ich habe beruflich oft genug mit Pseudo-IT-Admins Kontakt, deren Kenntnisse sich effektiv auf das Anschließen eines Druckers beschränken und sonst keinerlei erweitertes Know im Bereich Netzwerke mitbringen - wenn überhaupt Basiskenntnisse vorhanden sind. Mein All-Time-Favourite: "You need an IP from my network? 255.255.255.0". Das ist leider eine weitverbreitete Praxis, gerade in kleinen und mittelständischen Unternehmen, ist aber grob fahrlässig und setzt zum Teil sogar die Existenz des Unternehmens auf's Spiel (zB wenn Datensicherung und IT-Sicherheit nicht fachgerecht gehandhabt werden), wenn ich das mal so sagen darf. Auch wenn ich mich ziemlich gut in Netzwerken auskenne, würde ich mir selbst nicht den Schuh des IT-Admins anziehen wollen, obwohl ich ein artverwandtes Studium hinter mir habe.


Wie dem auch sei, die (oder eine) übliche Vorgehensweise wäre, ein separates Netzwerk für besagte Maschinen, durch einen Router inkl. Firewall vom Büronetzwerk getrennt bzw. reglementiert einzurichten. Der Router (zB ein EdgeRouter-X @ 50€) würde dabei als Schnittstelle zwischen PCs und Maschinen fungieren und den Zugriff untereinander blockieren bzw. zulassen. Einfach so zwei Subnetze auf ein und derselben Infrastruktur laufen zu lassen (also parallel die "IP-Pools", wie du sie nennst, 192.168.40.0/24 bzw. 192.168.0/24 ausgehehend von einem mutmaßlichen 24-Bit-Netzwerk) ist ganz ganz bad practice und sollte wirklich nur in absoluten Ausnahmefällen gemacht werden, wenn man wirklich weiß was man da tut.


Zum eigentlichen Problem mit dem Bluescreen kann ich dir leider nur wenig Hilfestellung geben. Ich würde die Karte mal in einem anderen PC testen, um einen Defekt auszuschließen. Funktioniert sie dort, baust du sie wieder in den Fehler-PC und startest diesen mit einem Live-Linux via USB. Funktioniert sie auch unter Linux auf dem Fehler-PC ebenfalls, ist es nahezu sichergestellt, dass Windows bzw. der Treiber Probleme macht. Dann könnte eine frische Windows-Installation Abhilfe schaffen.
 
Hängen die in einem physisch getrennten Netzwerk oder ist "nur" das unterschiedliche IP-Netz das Problem? Bei letzterem könnte man z.B. mit Routing arbeiten oder dem Rechner mehrere IPs verpassen (sowas geht doch bei Windows oder?).

Zum geschilderten Problem: Hast du nur eine dieser Karten oder mehrere? Wenn mehrere, gibt es das Problem mit allen Karten?
 
@KillerCow : So wie ich das lese sind die Einstellungen der Karte unerheblich. Selbst wenn man eine falsche IP eingibt und ggfs einen IP-Konflikt produziert, gibt es keinen Bluescreen. Da liegt irgendwas im Argen, ein Hardwaredefekt oder ein kaputter Treiber / Netzwerkstack von Windows.

Ich weiß allerdings nicht was du großartig routen willst, wenn beide Subnetze auf derselben Infrastruktur laufen. Routing braucht man nur zwischen verschiedenen Subnetzen. Wenn einfach nur zwei Subnetze parallel im Netzwerk genutzt werden, braucht man keinerlei Routing, sondern kann wie du dann schon richtig schreibst eine zweite IP auf der Netzwerkkarte einrichten (und braucht dann auch keine zweite Karte)
 
... ich bin zwar auch kein Netzwerkexperte, aber beim lesen habe ich doch einen ziemlichen Schreck bekommen.
Hier sollen zwei (Sub-)Netze, für deren Trennung es ja einen Grund gibt, wieder (über einen Client) verbunden werden. Mehr als eine NW-Karte sollte in einem Client nicht genutzt werden. Ich denke @Raijin hat dazu schon vieles gesagt: tu das nicht. Der betroffene Windows-PC wird (netzwerkkonfigurationsbedingte) Fehler produzieren und keiner weiß genau woran es jetzt wieder liegt. Von der Sicherheitsproblematik (auch noch in einer Firma) ganz abgesehen. Ich hätte schon nur temporär ein sehr ungutes Gefühl.
Weshalb die Karte nicht funktioniert : da ihr mehrere PC's habt würde ich sie in einem anderen Gerät einmal testen.
Falls wieder Bluescreen -> defekt zurück, allenfalls vorher noch ein Treiber-Update versuchen.
 
Zuletzt bearbeitet:
Zurück
Top