Bootmanager von D: auf C: holen?

Flutlicht

Lt. Junior Grade
Dabei seit
Okt. 2009
Beiträge
362
Hallo an alle,

Erst hatte ich Windows 7 auf meiner Raptor installiert
Hab aber zu Weihnachten eine INTEL X25M bekommen und dort dann parallel Windows 7 draufgemacht (sicherheitshalber).

Blöd ist nun, dass laut bcdedit der bootmanager immer noch auf D: liegt... ich würde D: aber gerne Formatieren :/


Was tun?
Hab schon das Tool "VistaBootPRO" versucht, dürfte aber nichts bewirken bzw. nicht die Funktionalität bieten...

Wie krieg ich mein C: (Intel SSD) UNABHÄNGIG? :(
 

Fortatus

Lt. Commander
Dabei seit
Juni 2009
Beiträge
1.293
Starte mal von der Windows 7-DVD, wähle "Computerreparaturoptionen" nimm deine Windows 7-Installation und starte die Konsole. Dann "bootrec /?" eingeben und die entsprechenden Optionen wählen um den Bootmgr auf C: neuzuschreiben. (Versuch z.B. mal "bootsect /nt60 C: /force")
 
Zuletzt bearbeitet:

Flutlicht

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Okt. 2009
Beiträge
362
Hab gerade den MBR in der Reparaturconsole neu schreiben lassen... Neustart war wie immer erfolgreich, aber immernoch steht D:\ da :(
 

pcBauer

Lieutenant
Dabei seit
Feb. 2007
Beiträge
912
Dann formatiere D: doch einfach, klemm die Platte ab, dann "reparierst" du den MBR und da er keine Wahl hat muss er ihn ja dann auf C: schreiben, oder?^^ ;)

Gruß
 

Flutlicht

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Okt. 2009
Beiträge
362
Statusbericht:

Ich habe vergessen im BIOS die SSD unter "Laufwerke" an erste Stelle zu nehmen, und bei der Bootpriorität entsprechend die SSD reinzutun....

Soweit sogut - "NO SYSTEM FOUND."


Dacht ich mir: "Eh klar, auf C: ist ja auch kein MBR"

Also DVD rein und in die Eingabeaufforderung:
"bootrec /rebuildmbr"

Dort dann eine Fehlermeldung a la "Objekt nicht verfügbar" bekommen.
Nach bischen Recherche dann mitbekommen, dass meine SDD anscheinend nicht als "aktiv" gesetzt ist.

Also "diskpart" gestartet...
"select disk 0"
"select partition 1"
"active"

Partition 1 als aktiv gesetzt.



YAY!


Dann nochmal in BOOTREC alles probiert - diesmal ohne Fehlermeldungen...

Dachte mir "ENDLICH!" ... also gleich reboot.... und dennoch NO MBR FOUND.

Also wieder zurück zur Reparaturkonsole... wenn ich dort jetzt "bootec /scanos" mache, finde ich GARNICHTS mehr (vorher gings noch). Habe anschließend mehrere Male versucht den MBR auf die Platte zu schreiben - keine Fehlermeldung in der Konsole, aber beim booten immer noch keinen Erfolg... :(

Hab daher bischen in PARTDISK rungesucht und bin draufgekommen, dass wenn ich:

select disk 0
select partition 1
attributes disk

ausführe, dann "Startdatenträger: Nein" da steht....
WIE kann ich das ändern? Is das der Grund?

Ich hab jetzt vorerst im BIOS wieder mein D: als Startdatenträger genommen, damit ich wieder hierher komme.... :/
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
62.685
Lass mal nur die Platte drin die booten soll, dann starte von DVD eine Reparaturinstallation.
 

enteon

Commander
Dabei seit
Apr. 2009
Beiträge
2.092
oder es fehlt einfach das boot-flag der partition, daher "Startdatenträger: Nein". das sollte sich mit einem intelligenten partitionierer wie z.b. gparted schnell setzen lassen.
danach kann er dann eventuell reparieren was das zeug hält ^^
 

Flutlicht

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Okt. 2009
Beiträge
362
Werde ich morgen mal probieren, danke schonmal für die Tipps!
Mach ich lieber nicht jetzt, bevor der Zockabend draufgeht... :)
Ergänzung ()

So, habs jetzt endlich geschafft :)


Danke für eure Tipps.
Hab mit Hilfe von Gparted den Bootflag von der D:-Platte entfernt, dann via Win7 DVD automatisch die Reparatur durchführen lassen. Nun ist der Bootmgr auf C:... :lol:
 
Top