Bootmgr fehlt! Win7 bei angeschlossener Externen Festplatte installiert..

Thesickness

Cadet 4th Year
Dabei seit
Okt. 2010
Beiträge
113
Halööchen

ich hoffe mir kann jemand helfen, folgendes Problem:

Ich habe auf meinem System Win7 neu installiert... das problem dabei war wohl das ich meine Externe Esata Festplatte angeschlossen hatte...

ich habe die Win7 Installation jedoch auf das Interne Raid gespielt... soweit so gut, sobald ich nun die externe Esata Platte vom Strom nehme bzw abstecke bootet der Pc nicht meht und bringt die Meldung:

Bootmgr fehlt
alt + stg+ enft für reboot....


Wenn ich die externe Esata Platte anhänge läuft alles wieder...

Ich habe dann mal die Esata abgesteck und mit der Win7 Dvd neugestartet und in der Reperatur Konsole Bootrec / Fixmbr und /bootfix eingetippt... der meinte er hätte es repariert aber es geht immer noch nicht...

nun habe ich keine Lust das system nochmal aufzusetzten

hat mir vl jemand einen Tip wie ich das lösen könnte??

Grüße Thesickness :)
 

Schildkröte09

Admiral
Dabei seit
Nov. 2009
Beiträge
9.879
Das Problem ist einfach gestrickt.

Der Bootloader von Windows 7 sitzt auf der eSATA Platte. Diese Startpartition ist auch ACTIVE markiert.
Deine Windows 7 Installation ist aber auf deiner internen HDD. Vgl. dazu deine Datenträgerverwaltung ...
Übrigens : In der Datenträgerverwaltung ist die Partition die Startpartition für Windows, welche als SYSTEM gekennzeichnet ist, aber nicht immer auch als Startpartition gekennzeichnet ist :freak:!

Nur einen Unterschied gibt es. Deine interne HDD und Windows 7 Partition ist NICHT ACTIVE markiert !
Der Reparaturversuch scheitert, obwohl Windows nichts davon meldet. Das liegt aber NUR daran ! Windows 7 Setup kann eine andere Partition (worauf NICHT die BOOTMGR liegt !) nicht automatisch ACTIVE markieren.
Eine Partition, die nach wie vor die Bootmgr im Root Verzeichnis liegen hat, wird automatisch ACTIVE markiert beim Reparaturversuch. (Kannst du gerne mit deine eSATA ausprobieren, dazu einfach die Startpartition auf der eSATA inactive markieren und die automatische Bootreparatur durchführen - wird erfolgreich sein, sie wird dadurch wieder ACTIVE markiert).

Was heißt das ?

Die Windows 7 Partition auf der internen HDD ACTIVE markieren. Sollte Windows 7 laufen, kannst du die Windows 7 Partition über die Datenträgerverwaltung ACTIVE setzen. Rechtsklick auf die Windows 7 Partition und ACTIVE setzen auswählen. Ansonsten mit Partitionierungsprogramme wie GPARTED.
Dann die automatische Bootreparatur mit der Setup DVD durchführen, die mindestens 3 mal durchlaufen gelassen werden muss. Auch die manuelle Methode kann nun eingesetzt werden mit allen drei Befehlen.
"bootrec /fixmbr",
"bootrec /fixboot" und
"bootrec /RebuildBcd"
Selbstverständlich bleibt während der Reparatur die eSATA Platte abgeklemmt.
http://www.unawave.de/installation/boot-reparatur.html

Die automatische Bootreparatur sorgt dafür, das der BOOTMGR ins Rootverzeichnis kommt und installiert somit den Bootloader und den Ordner BOOT auf die ACTIVE Systempartition.

Sollte das für das RAID System nicht funktionieren, (habe ich nicht, kann ich nicht mit Gewissheit sagen), wirste Windows 7 neu installieren müssen, allerdings ohne angeklemmte eSATA ...

UND : Klemme deine Systemplatte direkt korrekt am ersten SATA PORT und die 2. am zweiten SATA PORT an ! Dann bekommste später, wenn neue Platten hinzu kommen, keine Probleme mehr.

Viele Grüße
 
Zuletzt bearbeitet:

Thesickness

Cadet 4th Year
Ersteller dieses Themas
Dabei seit
Okt. 2010
Beiträge
113
So ich danke euch mal für die Ausführliche hilfe!

Ich hatte schon hoffnung nach dem ich die Sache mit der Aktiven Partition gelesen hatte...

als ich unter der Datenträgerverwaltung mir die Partitionen angeschaut hatte war die Esata Platte wie du schon gesagt hattest als AKTIV markiert...

Die C: Partition leider auch....

ich habe mir dann das Gparted runtergeladen und auf Cd Gebrannt... dort konnte ich aber nichts finden was mein Problem hat lösen können sprich ich konnte keinen Menupunkt für *als Aktiv markieren* finden...

Nach einem Neustart meldete dann mein RaidController das eine der Festplatten nicht mehr im Raidverbund eingegliedert ist....

Ich hatte dann die Schnauze voll und hab neuinstalliert....dieses mal ohne Esataplatte

Schade meine schönen Daten :(

Grüße Thesickness
 

frogger9

Commodore
Dabei seit
Feb. 2008
Beiträge
4.267
bei Gparted wäre das der Punkt "Manage Bootflag" gewesen.

Was das mit dem RAID-Controller zu tun hat, hängt idR. vom RAID-Modus und der Hardware ab.
 
Top