Browser hängen sich kurz auf seit 1709 Update

Kigalla

Lieutenant
Registriert
Feb. 2010
Beiträge
516
Vor kurzem habe ich das 1709 Update installiert, seitdem habe ich mit Browsern das Problem, wenn ich Bilder speichern will, der Browser sich für kurze Zeit (5 Sekunden) aufhängt. Das passiert nachdem auf "Speichern" gedrückt wurde und das Speichern Fenster wieder geschlossen wurde.

  • Das Verhalten wurde mit Firefox, Chrome und IE festgestellt.
  • Die Browser sind alle auf der System SSD installiert und der Speicherort der Bilder wurde auch auf HDDs und auf SSDs getestet.
  • Virenschutz wurde für die Tests deaktiviert.
  • Taskmanager zeigt nur kurz an, dass der Hauptprozess von Firefox hängt.
  • Ressourcenmonitor zeigt nichts interessantes an.
  • Process Explorer zeigt nichts besonderes an.
  • Beim Zocken sehe ich keinerlei Probleme.

Jemand eine Idee?
(Habe einen i5-2500k falls das von Belang ist)
 
Das "Speichern-Fenster" ist genau welches? es gibt verschiedene
 
Mal mit einer Portable- oder ZIP-Version prüfen, ob es am Zusammenspiel zwischen Windows und dem Browser liegt.

Parallel-Betrieb:

  • Profil kopieren
    • %APPDATA%\Mozilla\Firefox\Profiles\firefox.default - der Ordner mit den Profil-Daten
    • %APPDATA%\Mozilla\Firefox\Profiles\firefox.kopie - der Ordner mit den kopierten Profil-Daten
  • %APPDATA%\Mozilla\Firefox\profiles.ini erweitern
    • [General]
      StartWithLastProfile=1

      [Profile0]
      Name=firefox.default
      IsRelative=1
      Path=Profiles/firefox.default
      Default=1

      [Profile1]
      Name=firefox.kopie
      IsRelative=1
      Path=Profiles/firefox.kopie
  • Firefox mit Parametern aufrufen
    "...\Mozilla Firefox\firefox.exe" -no-remote -P "firefox.kopie"

Vermutlich über 'Grafik speichern unter ...' im Popup-Menü.
 
Zuletzt bearbeitet: (Ergänzung)
blah-jpg.663235
 

Anhänge

  • blah.jpg
    blah.jpg
    74,5 KB · Aufrufe: 529
Das ist zumindest der Windows-eigene Dialog. Wenns da Probleme gibt, dann liegts am Explorer, nicht am Browser.
Kann alles sein, was sich im Explorer einnistet, inkl. Cloud-Anwendungen, ZIP/RAR-Tools, usw.
 
Wie bereits oben geschrieben habe ich das Problem mit Firefox, Chrome und IE.
Ich habe jetzt mal Firefox Portable installiert aber kann das Problem nun weder mit Portable noch mit den anderen Browsern produzieren.

Weitere Tests erfolgen später oder morgen.
 
Wenn der Fehler erst einige Zeit und nicht direkt nach Windows Start auftreten sollte:
Steck mal deine My Book Festplatte testweise vom Rechner ab und teste, ob es damit auch auftritt.
 
Die Idee mit dem Ruhezustand von Festplatten ist mir auch schon eingefallen.
Energiesparoptionen sind (wie vorher) auf 60 Min für Festplatten gestellt.
My Book wurde nun mal entfernt.

Ich werde berichten.
Ergänzung ()

Also seit gestern nach meinem letzten Eintrag ist das Problem nicht mehr aufgetreten.
Änderungen:
Firefox Portable installiert aber wurde heute nicht verwendet
My Book entfernt

Wenn das Problem nicht wieder auftritt, muss ich wohl davon ausgehen, dass es am My Book bzw. Windows im Zusammenspiel mit der USB HDD liegt.
Interessanter Verlauf... vom "Speichern unter" Fenster zur externen HDD.

PS: Danke an alle.
 
Zuletzt bearbeitet:
Es ist eigentlich immer so: Wenn das Problem dort auftritt wo die Windows-eigenen Fenster genommen werden, in diesem Fall ein Speichern-Dialog, dann ist ab dem Zeitpunkt normalerweise nicht mehr die aufrufende Software schuld, sondern der Windows-Explorer. Woran es dann genau liegt, das kann man oft nur durch Ausschlussverfahren herausfinden.

Für die Zukunft: Wenn es in mehr als einem Browser auftritt, dann scheiden die Browser selbst schon mal aus, weil diese null gemeinsame Code-Basis haben. Das einzige was sie sich teilen sind die Schnittstellen von Windows.
 
rg88 schrieb:
Es ist eigentlich immer so: Wenn das Problem dort auftritt wo die Windows-eigenen Fenster genommen werden, in diesem Fall ein Speichern-Dialog, dann ist ab dem Zeitpunkt normalerweise nicht mehr die aufrufende Software schuld, sondern der Windows-Explorer.

Nicht ganz, sonst würde der Windows Explorer an sich schon solche Verzögerungen hervorrufen.
Ich vermute den Hund bei der API, dem Framework oder den Sicherheitsvorkehrungen (durch Drittanbieter).
Als Beispiel fürs Framework, https://www.computerbase.de/forum/t...reren-einzelnen-zellen.1693664/#post-20248809 (letzer Edit: "Bin jetzt statt 2 Minuten auf 6 Sekunden"), wie DLLs und sonstige Windows Komponenten die Geschwindigkeit für diverse Dinge beeinflussen können.
 
Zuletzt bearbeitet:
Naja, ich meinte damit das initialisieren/schließen des Dialogs. Auf irgendwas wartet die API ja da noch, also pfuscht irgendwas rein. Der Explorer selbst ist natürlich unschuldig, es liegt immer an einem externen Einfluss.
 
Zurück
Oben