Compton in Xubuntu 14.04 aktivieren

BCHMEMBER

Lt. Junior Grade
Registriert
Mai 2007
Beiträge
293
Hallo liebe CB-Community,

ich habe mir ein neues Notebook für die Uni Arbeiten zugelegt, da mein MacBook nicht mehr zuverlässig läuft.
Es ist am Ende das Acer Aspire E3-112 geworden.

Ich habe die HDD gegen eine SSD getauscht und auch schon Xubuntu 14.04.1 installiert. Soweit alles gut ich kann super mit dem Gerät arbeiten.

Aber ich würde gerne das Tearing besonders im Browser und beim Scrollen in PDF Dokumenten los werden. Da ich schon mal davon gelesen hatte wollte ich das relativ leichte Compton als Compositing Software nehmen.
Installation hat auch ohne Probleme geklappt. Aber ich kriege es nicht zum laufen.
Wenn ich im Terminal "compton" eingebe kommt die Meldung, dass bereits ein anderer Compositing Manager läuft.
Auf dieser Seite wird beschrieben dass man Compton einfach in den Autostart Bereich einträgt und es dann laufen sollte. Doch das klappt nicht, dabei habe ich schon die Angabe mit und ohne Pfad, sowie nur compton und compton -b .
Ich hoffe die erfahrene Community kann mir hier helfen :)

Grüße
BCHMEMBER
 
Hallöchen,

also zunächst: ich bin kein Linux-Experte und hab' den Thread gerade aus Zufall entdeckt, aber ich hatte exakt das gleiche Problem unter Xubuntu 14.04. Alles lief top, nur ich hatte echt überall Tearing drin; im Browser, beim Scrollen, beim Fenster verschieben, und erst recht hat's mich angekotzt beim Filme gucken im VLC Player. Die Lösung bei mir war: ich musste im Grafikkartentreiber (bei mir: AMD) systemweit V-Sync im Treiber aktivieren - da gab's ironischerweise eine Funktion, die extra "Rissfreie Darstellung" heisst.

Laut Google scheint in Deinem Gerät ein Intel Graphics HD Chip verbaut zu sein. Google mal danach, wie man unter Xubuntu mit Intel Graphics V-Sync anschalten an. Das sollte Dein Problem beheben.

--

Zu den Compositors würde ich Dir grundsätzlich raten diese abzuschalten. Ich finde die fressen nur unmengen an Leistung und der Standard-Compositor von Xubuntu, welcher von Haus aus aktiviert ist, scheint laut Google relativ verbuggt zu sein.

--

Standard-Compositor deaktivieren.

--

Sorry, eine Sache habe ich vergessen: hast Du den freien Grafiktreiber installiert oder speziell einen proprietären von Intel? Falls Du den freien benutzt, würde ich vielleicht mal testen den Intel-Treiber zu installieren. Der bietet vermutlich differenziertere Einstellmöglichkeiten, erst recht durch seine GUI.

Downloadseite.
 
Zuletzt bearbeitet:
Vielen Dank für deinen Tipp!
Es war am Ende natürlich wieder einfacher als gedacht :D
Ich hatte den Intel Treiber bereits installiert, dieser hat aber nur eine GUI für den Installationsprozess aber nicht für die einstellungen selbst...
Aber nachdem ich gerade mal nach Xubuntu HD Graphics Vsync gegoogelt habe hat sich schnell eine Lösung gefunden.
Es musste einfach in einer entsprechenden Config Datei die Option, Achtung jetzt kommts!, TearFree aktiviert werden ;)
so ist Xubuntu doch mehr als schön zu erleben, auch die Videowiedergabe ist nun viel schöner.
Ich werde mir die Optionen des IntelTreiber noch mal genauer angucken vielleicht lässt sich ja noch das ein oder andere Feature finden.

Noch mals vielen Dank!
 
Zurück
Oben