Erste Partition gerettet, zweite bleibt verschwunden

AoE-Maniac

Lt. Commander
Dabei seit
Apr. 2004
Beiträge
1.407
Moin erstmal!


Ich habe mir mit Partition Manager meine zweite Festplatte (80 GB) so zerschossen, dass keine der beiden Partitionen mehr sichtbar war. Dank der Testdisk-Anleitunge (:daumen: für Fiona) konnte ich die erste (12 GB) Partition wieder herstellen. Die zweite findet er nicht mehr.

Um die erste wiederherzustellen musste ich die Cylinderzahl anpassen, die war auch beim Ausführen unter DOS falsch (Wert aus dem Bios). Jetzt bringt er folgende Fehler beim erneuten ausführen (Anhang). Die Werte ändern sich ständig, sprich es treten mehr Fehler auf als auf einen Screen passen.

Auch bei einer tieferen Suche passiert das gleiche und keine weiter Partition wird gefunden.

Mit dem falschen Cylinderwert (1028) hatte ich den hier bereits öfter beschriebenen Fehler, dass die Platte zu klein ist (Bios detection, Jumper settings etc.).

Ich habe zum Glück halbwegs aktuelle Backups der wichtigsten Dateien, aber trotzdem würde ich einige Daten verlieren, wenn ich die Partition nicht wieder finde.

Habt ihr noch irgendwelche Ideen, wie ich weiterkomme?


MfG
AoE-Maniac
 

Anhänge

F

Fiona

Gast
Das Problem bei dir ist im Moment das deine Festplatte gerade mal mit 8 GB erkannt wird.
Steht auf deinem Bild bei Disk.
Sind nur 8455 MB.
Kann auch mit der Speicheradressierung Int 13h zusammenhängen.
Prüfe daher nochmal mal dein Bios, Kabel, Jumper etc..
Auch mit dem Diagnosetool des Herstllers.
https://www.computerbase.de/forum/threads/hdd-diagnose-recoverytool-sammlung.58108/

Stresse die Festplatte nicht unnötig und mache nur mal eine Diagnose.

Viele Grüße

Fiona
 

AoE-Maniac

Lt. Commander
Ersteller dieses Themas
Dabei seit
Apr. 2004
Beiträge
1.407
Sowohl im Bios als auch im Samsung-Tool hat die Platte 80 GB. Windows 98 zeigt an, dass die bereits wiederhergestellte Partition 12 GB hat.

Laut Herstellertool hat die Platte keine Fehler.

Jumper und Kabel kann ich eigentlich ausschließen, da ich an den Platten schon länger nichts mehr verändert habe. Schaue aber gleich mal nach und editiere das Ergebnis dann in hier rein.

EDIT:
Kabel und Jumper sind überprüft, war alles noch fest. Habe trotzdem nochmal alles festgedrückt, Testdisk zeigt trotzdem immer noch dasselbe an.

Was mir noch aufgefallen ist: Meine erste (baugleiche) Platte wird von Testdisk mit der selben Größe (8 GB) angezeigt. Scheint also irgendwie an dem Programm selbst zu liegen, im Bios etc. haben ja beide Platten 80 GB und mit Windows komme ich auf die erste ohne Probleme drauf.

Habe mir das ganze nochmal mit einem Partitionierungsprogramm unter Windows angesehen, natürlich nichts verändert, nur um zu sehen ob es an Testdisk liegt: Dort haben beide Platten auch nur 8 GB (gleichzeitig im Windowsexplorer 80 GB bzw. 12 GB, wo die Partition fehlt). Zusätzlich ist alles bis auf die C:-Partition als "ungültig" markiert, obwohl Windows mit der ersten Platte, auch mit den "ungültigen" Partitionen, keine Probleme hat.
 
Zuletzt bearbeitet:
F

Fiona

Gast
Lade dir mal die Dos-Version von Testdisk.
Überprüfe mal ob du dort auch das Problem mit der Größenerkennung bei Disk von 8 GB hast.
Teile es mit.

Wenn die richtig erkannt wird kannst du mal eine Diagnose machen.
Infos;
Ich hoffe das du ein Diskettenlaufwerk hast.
Ansonsten ist Testdisk normal auch auf der Knoppix-CD oder auf der Ultimate Boot CD.
Gibt auch von mir hier demnächst ein aktuelles CD-Image als iso zum brennen.
Da kannst du mir aber keine Log erstellen da CD's nicht beschrieben werden können.
Schreibe mit dann die Infos auf was bei Disk angezeigt wird, die Partitionsdaten nach Analyse, Proceed und der tieferen Suche Search.
Wenn die Partition markiert ist teile mir auch mit was am Screen ganz unten in der letzten Zeile steht.
Sind Bootsektorinfos.
Teile auch mit wenn die Partition markiert ist und du p drückst ob deine Daten angezeigt werden.

Erstelle dir eine Bootdiskette.
Ansonsten kann auch www.bootdisk.com helfen (amerikanische Tastatur).
Lade dir sonst mal die Testdisk-Version 6.3 beta für Dos/Win9x.
https://www.computerbase.de/forum/threads/faq-datenrettung-testdisk-anleitung.110869/#post-1109338
Kopiere den Ordner dos auf eine Diskette (kann man auch nach dem booten wechseln).
Die Datei Photorec im dos-Ordner wird nicht benötigt und kann im Fall auch gelöscht werden
Wechsle an der Eingabeaufforderung in das dos-Verzeichnis.
Führe dort aus;
testdisk /log /debug
Damit wird jeder Schritt protokolliert.
Hinterher findest du im Ordner "dos" eine Datei die testdisk.log heißt.
Benenne die in testdisk.txt um.
Die kannst du dann hier unter Anhänge Verwalten hochladen.

Boote mit der Bootdiskette.
Wechsel bei Bedarf zur Testdiskdiskette
Führe;
testdisk /log debug
Wähle deine Festplatte und bestätige bei Proceed.
Bestätige bei Partition Table Typ Intel.
Bestätige bei Analyse.
Bestätige bei Proceed.
Wenn im Fall keine Partition erkannt wird kann eine Suche kommen. Lasse die im Fall laufen.
Bestätige dann weiter mit Enter bis du zum Menü kommst wo unten steht [Quit] [Search] [Write] und gehe mit dem Pfeil auf [Search] (tiefere Suche) und lasse es laufen.
Wenn die Partitionen gefunden wurden, kannst du die auch mal markieren und p (List Files) auf der Tastatur drücken.
Schaue dann mal ob die Daten angezeigt werden.
Zurück kommst du einfach mit p drücken.
Bestätige hinterher mit Enter.
Jetzt bist du wieder am Screen wo unten sich [Quit] [Search] [Write] befindet.
Bestätige bitte jeweils bei Quit bis Testdisk beendet ist.

Benenne die Datei testdisk.log in testdisk.txt um und lade die für Analyse hier hoch.
Geht unterhalb wenn du einen Post erstellst unter Anhänge verwalten.
Viele Grüße

Fiona
 

AoE-Maniac

Lt. Commander
Ersteller dieses Themas
Dabei seit
Apr. 2004
Beiträge
1.407
- Die DOS-Version zeigt auch nur 8 GB an.
- Die Cylinderanzahl ist falsch -> Fehlermeldung Platte zu klein.
- Korrekter Wert über Geometry eingegeben -> Die erste Partition der Platte ist sichtbar, die zweite nicht (auch nach intensiver Suche). Fehlermeldungen (siehe Screenshot am ersten Post).
- Bootsektorinfos: "FAT32, 12GB, 11GB".
- p zeigt die Daten der ersten Partition an.
- Die testdisk.txt befindet sich im Anhang.
 

Anhänge

F

Fiona

Gast
Da bei dir beide Festplatten mit 8 GB angezeigt werden nehme ich mal an das es an dein Bios oder Kontroller vom Motherboards liegt.
Ich weiß nicht inwieweit Windowstreiber das Ergebnis verfälschen können.
Zumindest gab Testdisk keine Fehler der Festplatte aus wie in diesem Fall bei nur einer;
https://www.computerbase.de/forum/threads/ide-festplatte-wird-nicht-angezeigt.178613/#post-1747843
Problem ist vielleicht die Speicheradressierung LBA (Logical Block Addressing).
Dafür benötigst du für größere Festplatten die erweiterte Int 13h Schnittstelle.
Ansonsten ist bei Enhanced Bios bei 8 GB Schluß.
Nennt sich Int 13h-Extension.

Ist aber nur mal Vermutung.

Prüfe daher mal dein Bios auch auf Updates.
Mache mal einen Cmos Clear.
Überlege dir mal dazu die Battery vom Motherboard zu entfernen und einige Minuten wegzulassen.
Dabei sollte auch das Stromkabel abgezogen sein.
Gib die Werte richtig und neu ein.
Vielleicht auch mal lba manuell im Bios setzen.
Kabel mal austauschen und überprüfen wurde bereits erwähnt.

Viele Grüße

Fiona
 
Zuletzt bearbeitet:

AoE-Maniac

Lt. Commander
Ersteller dieses Themas
Dabei seit
Apr. 2004
Beiträge
1.407
Bios-Reset etc. haben nichts gebracht. Kabeltausch ebenfalls nicht.

Ich habe die Platte in einen anderen Rechner eingebaut. Dort hat sie in Testdisk auch nur 8 GB, in Windows und Bios 80 GB. Testdisk verhält sich wie auf dem anderen Rechner. Ein 13h-Problem kann denke ich ausgeschlossen werden, da auf dem anderen Rechner gleichzeitig eine 40 GB-Platte von Testdisk völlig korrekt erkannt wird.
 
Zuletzt bearbeitet:
F

Fiona

Gast
Habe mir das ganze nochmal mit einem Partitionierungsprogramm unter Windows angesehen, natürlich nichts verändert, nur um zu sehen ob es an Testdisk liegt: Dort haben beide Platten auch nur 8 GB (gleichzeitig im Windowsexplorer 80 GB bzw. 12 GB, wo die Partition fehlt). Zusätzlich ist alles bis auf die C:-Partition als "ungültig" markiert, obwohl Windows mit der ersten Platte, auch mit den "ungültigen" Partitionen, keine Probleme hat.
Überprüfe mal auf der Herstellerseite der Festplatten ob dort Treiber angeboten werden für eine volle Erkennung.
Überprüfe die Festplatzte auch mal mit dem Diagnosetool.
https://www.computerbase.de/forum/threads/hdd-diagnose-recoverytool-sammlung.58108/

Teile es mal mit.

Ansonsten eine andere Möglichkeit;

Du kannst mal wenn du mit Partitiontools Probleme hast mit Datenrettungssoftware eine Diagnose machen ob die mit den Low Level Treiber das ganze Laufwerk erkennen und dir deine Daten anzeigen.

Link zu Datenrettungssoftware hier;
Freeware hat nicht immer gute Ergebnisse und ist deshalb kein Maßstab für eine Diagnose.
https://www.computerbase.de/forum/threads/faq-datenrettung-testdisk-anleitung.110869/#post-1109338

Gute Ergebnisse sind Restorer2000, Scavenger und Recover My Files.
Freeware hat nicht immer gute Ergebnisse.

Du kannst dir ja mal den kostengünstigen Restorer2000 Pro (Shareware 49.99 $ ca. 38 €) in der Testversion anschauen was der an Daten nach Diagnose anzeigt.
Hatte hier bereits gute Ergebnisse und macht auch wenig Probleme mit verschiedene Dateiformate.
In der Bedienung für einige ein wenig gewöhnungsbedürftig.
Daher noch ergänzende Hinweise wegen Bedienung.
Mache damit mal einen genauen Sektorscan.
Markiere einfach mal die Festplatte und nicht irgendeine Partition..
Scanne die gesamte Festplatte indem du auf das dritte Icon im Menü mit dem Laufwerkssymbol und dem Fernrohr gehst.
Hierbei wird nach Partitionen gesucht die du anhand von Laufwerkssymbole oben im rechten Fenster findest.
Untersuche die mal auf deine Daten.
Wähle bitte zuerst die Laufwerkssymbole aus die deiner Partitionsgröße und Dateisystem entsprechen.
Untersuche die mal und teile es mit.
Da kannst du auch wenn im rechten Fenster mehrere angezeigt werden wechseln indem du in Restorer2000 im Menü oben ganz links auf das Laufwerkssysmbol klickst.
Dann kommst du wieder zurück und kannst im rechten Fenster das nächste Laufwerkssymbol zum untersuchen auf Daten auswählen.
 

AoE-Maniac

Lt. Commander
Ersteller dieses Themas
Dabei seit
Apr. 2004
Beiträge
1.407
Da zwei baugleiche Platten von Testdisk nicht richtig erkannt wurden, habe ich mir mal parallel noch eine neue besorgt, nur um zu testen, ob bei der fabrikneuen das Problem auch auftritt. Das war nicht der Fall.

Also habe ich die Platte wieder abgebaut und die, die falsch erkannt wurde, wieder an den Rechner gehängt. Dann wollte ich deine Vorschläge ausprobieren, aber siehe da, die Platte hatte auf einmal 80 GB. Mit Testdisk konnte ich die Partition ganz einfach wiederherstellen, alle Daten sind noch vorhanden.

Kann es sein, dass der Einbau der neuen Platte wirklich dafür gesorgt hat, dass die alte wieder richtig erkannt wurde? Ich habe weder ein anderes Kabel verwendet, noch war selbiges lose. Da bin ich mir 100%ig sicher, das hatte ich vorher mehrfach überprüft.

Wie dem auch sei, vielen Dank für deine Hilfe! Und nocheinmal ein dickes Lob für dein Testdisktutorial, ohne das ich nicht gewusst hätte, was überhaupt zu tun ist. :daumen:

PS der Vollständigkeit wegen: Die Platte wurde, als sie noch von Testdisk mit 8 GB erkannt wurde, vom dem Herstellertool richtig angezeigt (80 GB).
 
Top