Falscher Kernel für Treiber + OS Wechsel nicht möglich?

F

Fat32Tony

Gast
Hey.

Ich habe hier eine TV Karte von dvbsky rumliegen. Mein Problem ist dass die Treiber nur für einiger Kernelversionen verfügbar sind . Ich hatte angedacht die Karte mit dem VDR zu betreiben, am liebsten mit einer dafür ausgelegten Partition. Nur sind leider sämtliche Kernel dieser Partitionen wie yavdr, etobi etc. inkompatibel. Kernel upgrade bin ich nun schon mehrfach dran gescheitert und ich habe ehrlich gesagt auch Bedenken dass danach Software nicht mehr funktionieren könnte (?)
Was bleibt mir?
 

HominiLupus

Banned
Dabei seit
Okt. 2013
Beiträge
33.550
Welche Kernelversion(en) hast du zur Verfügung, welche Kernelversion benötigt das Module und welche PCI ID hat die Hardware die du zum laufen bringen willst?
 
F

Fat32Tony

Gast
Welche Kernelversion(en) hast du zur Verfügung, welche Kernelversion benötigt das Module und welche PCI ID hat die Hardware die du zum laufen bringen willst?
Unterstützt werden:
2.6.x
3.5.3/3.4.4/
3.3.2/3.2.29
3.5.x ~ 3.13.0
3.14.x ~ 3.16.0
3.6.6/3.6.7
3.7.2~3.7.5
3.8.4~3.8.5
3.9
3.12
(http://www.dvbsky.net/Support.html)

Und Verwendung findet im Moment der 3.2.0er

pci ID kann ich mit lspci ohne Treiber grade schwerlich herausfinden oder gibt es dort Alternativen?
Ergänzung ()

Eine Karte für die es Treiber passend zu Deinem Kernel gibt?
Einen Treiber im Quellcode, den Du passend zu Deinem Kernel kompilieren kannst?
^kompilieren


//Edit Quatsch es ist der 3.2.0er Kernel... Brain AFK
 
Zuletzt bearbeitet:

mensch183

Captain
Dabei seit
Jan. 2008
Beiträge
3.610
Genaue Modellbezeichnung deiner Karte? Bisher wissen wir nur den Hersteller.

pci ID kann ich mit lspci ohne Treiber grade schwerlich herausfinden oder gibt es dort Alternativen?
Ein PCI-Gerät ist ohne Treiber für dieses PCI-Gerät auf dem PCI-Bus zu sehen. Genau über diesen Mechanismus bekommt ja das Betriebssystem beim Booten mit, was für PCI-Hardware im Rechner steckt und kann die dafür nötigen Treiber laden. Du wirst das Ding also mit lspci sehen können.

Bevor ich an einem uralten Kernel-3.2 rumfrickeln würde, würde ich erstmal nachschauen/ausprobieren, ob nicht ein aktueller Kernel(=3.16.2) die Karte bereits von Haus aus unterstützt.
Kernel upgrade bin ich nun schon mehrfach dran gescheitert und ich habe ehrlich gesagt auch Bedenken dass danach Software nicht mehr funktionieren könnte (?)
Einen aktuellen Kernel zu installieren ist einfacher als einen alten Kernel zu patchen und zu installieren. Deine Bedenken wegen Inkompatibilität sind unbegründet. Linux ist sehr strikt darin, einmal darauf laufende Programme nicht plötzlich nicht mehr ablaufen lassen zu können.

Dich mit jemandem an den Rechner setzen, der sich mit sowas auskennt.
 
Zuletzt bearbeitet:
Top