HAL.dll fehlt, Partition verloren

telemixa

Newbie
Dabei seit
Nov. 2006
Beiträge
4
Hallo ich habe folgendes Problem bei meinem IBM Laptop R30 mit Hitachi 80 GB Hd + 3 Partitionen, Win Xp Pro mit Sp 2 und allen Updates bis zum Crash. Beim Booten kam folgende Fehlermeldung:Win konnte nicht gestartet werden da folgende Datei fehlt: Windows root\system32\hal.dll. Bisher lief der Lap immer ohne Probleme. Nach diversem Googeln und Sufu hier habe ichs dann erstmal mit der Win Reperaturfunktion versucht, aber da kam der Buchstabe R überhaupt nicht sondern Win wollte sich gleich neu installieren. Dann habe ich die Festplatte ausgebaut und über Usb an meinen HomePc angeschlossen und festgestellt das das Lw mit den Windows daten garnicht erkannt wird.
Bin dann auf Testdisk gestossen und habe mir die 6.6 auf Cd gebrannt und habe mich dann mehrere Stunden durch alle Threads zum Thema gequält. Also Testdisk hat tatsächlich die verlorene Partition und die Daten wiedergefunden. ABER ich kann die Daten nicht sichern ?? Hier komme ich nicht weiter... Habe mal einen Screenshot angefügt. Vielleicht hat ja jemand einen Tip für mich.
Danke im Vorraus, Micha
 

Anhänge

gm-style

Lieutenant
Dabei seit
Okt. 2005
Beiträge
820
Guten Abend,

hatte genau das selbe Problemund habe es geschafft, leider falsch aber es geht, du brauchst eine leere Partition um sowas wiederherzustellen, ich habe es damals auf meine win gemacht und alles war weg nur die daten nicht.
 
F

Fiona

Gast
Teile mir mal mit was du genau mit Daten sichern meinst.
Testdisk kann auch Daten, Ordner oder alle Daten von einem Laufwerk komplett kopieren.

Ich habe jetzt keine Übersicht über eine vollständige Diagnose in Testdisk.
Mache mir mal eine Diagnose nach folgender Anleitung;
Lade dir mal Testdisk Version 6.6 beta für Windows.
Link dazu gibt es hier;
http://www.cgsecurity.org/wiki/TestDisk_Herunterladen
Starte Testdisk bestätige bei dem Log-Datei-Screen mit Enter, wähle deine betroffene Festplatte aus und bestätige mit Enter, bestätige bei Partition Table Typ Intel, bestätige bei Analyse mit Enter und setze mir einen Screenshot.
Bestätige bei Proceed und setze mir auch einen Screenshot.
Bestätige weiter bis du zum Menü kommst wo unten steht [Quit] [Search] [Write] und gehe mit dem Pfeil auf [Search] (tiefere Suche) und lasse es laufen.
Setze mir auch einen Screenshot.
Die betroffene Partition sollte wenn du den Screen machst markiert sein.

Markiere mal die betroffenen Partitionen und drücke p auf der Tastatur ob deine Daten angezeigt werden oder eine Fehlermeldung.
Zurück kommst du mit q drücken.

Infos über das kopieren von Daten in Testdisk hier;
https://www.computerbase.de/forum/threads/232924/

Teile es mit.

Viele Grüße

Fiona
 
Zuletzt bearbeitet:
F

Fiona

Gast
Bei dir besteht die Möglichkeit das deine Festplattegeometrie nicht passt.
Ändere das mal auf 240 Heads und mache mal eine Diagnose.

Lade dir dazu die neueste Version von Testdisk 6.6 beta.
http://www.cgsecurity.org/wiki/TestDisk_Herunterladen

Starte Testdisk, bestätige bei Log-Datei erstellen mit Enter, wähle deine Festplatte und bestätige mit Enter.
Bestätige auch bei Partition Table Typ Intel mit Enter.
Gehe jetzt auf das Menü Geometry.
Gehe dort auf Heads.
Gib dort 240 ein und bestätige mit Enter.
Lasse SectorSize und den Rest in Ruhe.
Bestätige dann mit OK zum verlassen von Geometry.
Du darfst dann Testdisk nicht beenden da du dann die Einstellungen verlierst.
Gehe dann mit dem Pfeil auf Analyse bestätige mit Enter und setze mir einen Screenshot.
Bestätige bei Proceed und setze mir auch einen Screenshot.
Bestätige weiter bis du zum Menü kommst wo unten steht [Quit] [Search] [Write] und gehe mit dem Pfeil auf [Search] (tiefere Suche) und lasse es laufen.
Setze mir einen Screenshot
Du kannst da auch mal die Partitionen wenn die gefunden werden markieren, die Taste p drücken und schauen ob du deine Daten siehst.
Zurück kommst du mit q drücken.

Teile es mit.

Viele Grüße

Fiona
 

telemixa

Newbie
Ersteller dieses Themas
Dabei seit
Nov. 2006
Beiträge
4
Hier mal die neuen Shots vielleicht hilfts mir ja weiter. Habe die Heads auf 240 geändert und kann alle Daten mit P auch sehen
nochmal Danke für die schnelle Hilfe
 

Anhänge

F

Fiona

Gast
Das passt jetzt.
Bestätige einfach bei Write mit Enter, y und Ok.

Beende Testdisk und starte den Computer neu.

Wenn chkdsk bei Systemstart kommen will, beende chkdsk erstmal.
Geht innerhalb von 10 Sekunden durch beliebigen Tastendruck.

Überprüfe das Ergebnis und teile es mit.

Viele Grüße

Fiona
 

telemixa

Newbie
Ersteller dieses Themas
Dabei seit
Nov. 2006
Beiträge
4
Hallo danke für die Tipps alles so gemacht wie es hier steht und das Ergebnis ist niederschmetternd: Win konnte nicht gestartet werden da folgende Datei fehlt: Windows root\system32\hal.dll Die HAl.dll fehlt natürlich nicht, Was kann ich denn noch versuchen. Scheinbar wird die 1 Partition immer noch nicht erkannt.
 
F

Fiona

Gast
Ich denke mal nicht das das Ergebnis niederschmetternd ist.
Die Daten solltest du jetzt eigentlich an dem anderen PC und USB gesehen haben!
Teile es mal mit!
Wenn die Meldung hal.dll kommt kann es auch ein Problem mit der boot.ini sein.
Öffne die mal in einen Editor und poste mal den Inhalt.
Zumindest sollten die anderen Boot-Dateien wie ntldr und ntdetect.com gefunden werden.
Infos wegen der boot.ini und hal.dll;
https://www.computerbase.de/forum/threads/win-xp-prof-startet-nicht-mehr.238241/#post-2341403
Lade auchmal die Datei testdisk.log im Testdisk-Verzeichnis hier hoch ob das Dateisystem beschädigt ist.
Benenne die dazu in testdisk.txt um.
Ansonsten wenn du die Daten in Testdisk gesehen hast, könntest du die auch in Testdisk auf ein anderes Laufwerk kopieren.
Infos dazu hier;
https://www.computerbase.de/forum/threads/232924/
Würde ich an deiner Stelle wieder an USB machen.

Teile es mal mit.

Viele Grüße

Fiona
 
Zuletzt bearbeitet:
Top