Interne SATA-Laufwerke werden als externe Wechseldatenträger angezeigt

Snoopy69

Captain
Registriert
März 2004
Beiträge
3.549
Bei einem Kollegen mit Core i7-920 - ASUS P6T - X58 werden interne SATA-Laufwerke werden als externe Wechseldatenträger angezeigt. Was irgendwie blöd ist. Es sollen ja nur echte, externe Laufwerke angezeigt werden. Als Lösung habe ich das hier gefunden...

https://www.deskmodder.de/blog/2015...seldatentraeger-angezeigt-windows-10-8-und-7/

Gibt es nichts Einfacheres? Ich habe noch ein altes System aus dem ähnlichen Jahr (nur anderes MB), aber da war das nie so :confused_alt:
 
  • Gefällt mir
Reaktionen: Amasov
Im BIOS gibt's evtl. 'ne Option um SATA Hotplug zu (de)aktivieren. Dann kann man die Platten nicht mehr im laufenden Betrieb ab- und an-stecken, aber dafür sollte Windows dann hoffentlich alle Platten als intern ansehen.
 
  • Gefällt mir
Reaktionen: ekin06, mercury, up.whatever und 2 andere
Der Datenträger wurde nunmal so eingerichtet (ist mir auch schon passiert) und so kompliziert ist die verlinkte Anleitung nun wirklich nicht.

Man kann das auch einfach ignorieren.

benneq schrieb:
Im BIOS gibt's evtl. 'ne Option um SATA Hotplug zu (de)aktivieren.

Hat damit nichts zu tun.
 
Hat durchaus was damit zu tun, ist nämlich z.B. auch bei mir der Fall, wenn Hotplug im Bios aktiviert ist.
 
  • Gefällt mir
Reaktionen: ekin06, Knito und Sebbi
hat absolut mit der hotplug funktion zutun, bios standard ist in meinem fall enabled und zeigt jedes laufwerk in der folge als wechseldatenträger an.

guck nach sata settings oder ähnlichem im bios, dort solltest du fündig werden.
 
Sollten alle MBs diese Option im BIOS haben? Ich suche, wie verrückt, aber ich finde nichts :(
 
wenn die die Funktion unterstützen ja

lt. Handbuch bei dir sollte das bei der OnBoard Gerätekonfiguration drin sein, ggf musst du das auch für jeden Port einstellen
 
Nein, nicht immer gibt es einen BIOS-Eintrag, und nein, der Trick in der Registry funktionierte früher einmal. Was immer hilft: Den Intel Rapid Storage Manager installieren (früher Intel Matrix). Viel Glück beim finden....
 
yxcvb schrieb:
Den Intel Rapid Storage Manager installieren ..
Und dann hat man den unnötigen Treiber samt Software auf dem System, besser nicht.
In der Regel hat jedes Bios diese Option: "Hotplug"
 
Habe verschiedene Versionen von Intel Rapid Storage Manager ausprobiert, aber es kommt immer die Meldung, dass dein Plattform nicht unterstützt wird

Was nun?
 
Da brauchst du genau die Version, welche zu deinem Chisatz passt und das wäre dann ein wohl sehr alter.
Und diese alten Treiber machen dann je nachdem Probleme mit Windows 10.
 
möglicherweise heisst die option anders, verschiedene hersteller benutzen verschiedene bezeichnungen, häufig ist nicht unbedingt offensichtlich welche funktion sich tatsächlich dahinter verbirgt...

wobei ich mir recht sicher bin, jetzt wo du nachfragst, dass mein zweitsystem mit z87 chipsatz (~2013) keine hotplug option im bios hat... allerdings wurden interne datenträger auch nicht als wechseldatenträger deklariert.
 
Das interne Laufwerke in der Liste von "Hardware sicher entfernen" angezeigt werden, ist normal wenn der Port im BIOS als Extern und/oder Hot Swap konfiguriert ist. Das kann man zumindest für die Ports des Chipsatzes meistens im BIOS einzeln einstellen, für die Zusatzcontroller nicht immer. Das Board hat ja sogar zwei davon und einer wird sogar noch für den eSATA Port genutzt, da ist der andere Port mit hoher Wahrscheinlichkeit ebenso konfiguriert.
Wenn es nicht durch Konfiguration im BIOS und/oder Umstecken auf andere Ports gelöst werden kann, so hast Du die Lösung mit dem Parameter TreatAsInternalPort in der Registry ja schon selbst gefunden.
Snoopy69 schrieb:
Habe verschiedene Versionen von Intel Rapid Storage Manager ausprobiert, aber es kommt immer die Meldung, dass dein Plattform nicht unterstützt wird
Schau welche die letzte Version des RST ist die noch die alte ICH10R unterstützen, beachte aber das erst ab oder nach 10.2 Platten mit mehr als 2TB unterstützt werden, nimm also besser wenigstens eine 11er oder gleich den AHCI Treiber von Microsoft der bei Windows dabei ist, sofern Du kein RAID am Chipsatz laufen hast, wobei dann auch darauf zu achten wäre das der RST und das RAID ROM im BIOS RAIDs mit Platten mit mehr als 2TB unterstützen.
 
Holt schrieb:
Das kann man zumindest für die Ports des Chipsatzes meistens im BIOS einzeln einstellen, für die Zusatzcontroller nicht immer. Das Board hat ja sogar zwei davon und einer wird sogar noch für den eSATA Port genutzt, da ist der andere Port mit hoher Wahrscheinlichkeit ebenso konfiguriert.
Dann sollte es doch auch möglich sein, die Festplatte an den internen Controller anzuschließen und das Problem so zu beseitigen. Zumindest wenn noch nicht alle Ports belegt sind.
 
Ja, wenn das BIOS die Möglichkeit bietet die Ports der ICH10R entsprechend zu konfigurieren.
 
Würde eine Umstellung von AHCI auf IDE helfen?
Probieren kann ich es nicht, weil das OS mit IDE nicht mehr startet. Aber ich installiere mal testweise WIN10 ganz neu unter IDE
 
Snoopy69 schrieb:
Würde eine Umstellung von AHCI auf IDE helfen?
Kann sein, muss aber nicht. Gibt es keine Einstellung zu Extern oder Hot-Swap/Hot-Plug? Wenn Du es ausprobieren willst, musst Du vorher ggf. dafür sorgen das auch ein IDE zum Bootzeitpunkt gestartet wird, wenn auch das Systemlaufwerk betroffen ist. Neuinstallieren brauchst Du nicht, öffne eine Eingabeaufforderung "Als Administrator" und gib ein:
sc Config pciide Start=Boot
 
So wie es aussieht, geht es mit IDE...
Das Symbol „Hardware sicher entfernen...“ kommt jetzt nur, wenn ein USB-Stick oder eine ext. HDD dran hängt. Zuvor wurde ja ALLES angezeigt (auch c: :rolleyes: )

Aber was für Nachteile hätte ich (bzw. Der Kollege) noch mit IDE?
 
SSDs können im IDE Modus nicht ihre volle Leistung erreichen, da die Zugriffe nur maximal über 2^8 LBAs pro Befehl gehen können, also bei den üblichen 512 Byte pro LBA nur über 128MB und NCQ wird im IDE Modus normalerweise auch nicht unterstützt. Bei HDDs macht dies kaum einen Unterschied, aber SSDs brauchen schon längere Zugriffe um die vollen Transferraten und natürlich viele parallele Zugriffe um ihre maximalen IOPS zu erzielen. TRIM sollte aber auch im IDE Modus funktionieren, was aber wie bei AHCI vom Treiber abhängt.
 
Zurück
Oben