Langsame interne 1TB Festplatte

nicegu

Newbie
Dabei seit
Juni 2009
Beiträge
5
Hallo,

vorgestern habe ich mir die Festplatte HD103UJ von Samsung als Backup-Platte
gekauft und in meinen Rechner (Athlon 64 Dual Core 5000+, 1 GB Speicher, Asrock
ALiveNF6G) zunächst über einen Wechselrahmen und mittlerweile fest eingebaut.

Im Betrieb zeigte sich die Festplatte als sehr langsam, der Rechner "frohr" beim
Kopieren von Daten immer wieder ein. Eine Aufteilung in 2 Partitionen (NTFS) brachte
keine Änderung.

Über das Tool HD Tune (2.55) ergaben sich soweit ich gesehen habe keine
Auffälligkeiten (SMART/fehlerhafte Sektoren). Im Benchmark dann allerdings eine
Transfer-Rate von ca. 8-9 MB/S, die konstant blieb. Eine Kontrollmessung mit
der eingebauten Platte (HD161HJ) lieferte die üblichen, nach außen abfallenden
Werte von 60 MB/s oder mehr.

Auffallend war, das beim ersten Test die CPU Usage bei fast 50 % lag, also ein
Kern voll mit dem Test ausgelastet war, was möglicherweise der Grund für die
geringen Werte und das Einfrieren des Rechners ist. Beim zweiten Test war das
nicht so.

Was bremst meine Festplatte aus?
 

AndrewPoison

Admiral
Dabei seit
Jan. 2005
Beiträge
8.228
Bei diesem Phänomen (hohe CPU-Last, geringer und vor allem konstanter Datendurchsatz) liegt die Schlussfolgerung sehr nahe, dass die Festplatte im sogenannten PIO-Modus läuft. Wenn sie auf DMA umgeschalten würde, ginge dann die Post ab ;)

Wie schalte ich in den DMA-Modus?
Erstmal klicken wir rechts auf den Arbeitsplatz und wählen "Eigenschaften", gefolgt von "Hardware" und dann "Gerätemanager" (das ist zumindest der Weg unter XP, unter Vista kann das etwas anders sein). Dort suchen wir den Punkt "IDE ATA/ATAPI-Controller" und sehen dann eine Liste von mehreren IDE-Kanälen und Controllern. Wir doppelklicken dann auf den ersten Eintrag und wechseln in das Menü "Erweiterte Einstellungen", wo wir sowohl bei Gerät 0 und 1 unter "Übertragungsmodus" den Wert "DMA, wenn verfügbar" auswählen. Das ganze wiederholen wir mit allen anderen Unterpunkten der IDE ATA/ATAPI-Controller-Liste (manche der Punkte werden die Einstellungen nicht haben, ist nicht schlimm). Danach neustarten und erneut benchen und vermutlich schon Glücklich sein.

Was, wenn es danach immernoch das gleiche Problem gibt?
Dann schaust du bitte im Gerätemanger erneut nach, ob sich die Einstellung "DMA, wenn verfügbar" wieder auf "Nur PIO" zurückgesetzt hat. In dem Fall ist Windows der Meinung, dass der Controller bzw. die Festplatte DMA nicht unterstützt (dann müsste man evtl. im BIOS mal schauen). Steht jedoch nachwievor "DMA, wenn verfügbar" drinn (bei allen), die Symptome bleiben aber bestehen, dann lade ich dir nacher mal eine kleine Software von mir hoch, die mir schon ähnliche Probleme aufgelöst hat.
 

nicegu

Newbie
Ersteller dieses Themas
Dabei seit
Juni 2009
Beiträge
5
Im Gerätemanager finde ich unter je 3 primären und sekundären
IDE-Kanälen die folgenden Werte:

1. Primärer Kanal, Device 0 -> aktueller Modus: UDMA 5 (CD-LW?)
3. Primärer Kanal, Device 0 -> aktueller Modus: UDMA 6 (System-Platte?)
3. Sekundärer Kanal, Device 0 -> aktueller Modus: PIO Modus
Der Wert "DMA, wenn verfügbar" war, ist und bleibt auch nach Neustart gesetzt.

Im BIOS wird für beide Platten UDMA6 angegeben, für das CD-LW UDMA5.

Merkwürdig finde ich die Größenangabe der Platte im BIOS.
Dort steht "1000.2GBSAMSUNG HD103UJ" (statt "1000.2 GB").

Wie kann ich die Ursache für den PIO Modus herausfinden?

P.S.: Betriebssystem: Win XP SP3
 

AndrewPoison

Admiral
Dabei seit
Jan. 2005
Beiträge
8.228
Was hast du für ein Board? Vielleicht benötigt es ein BIOS-Update für das unterstützen größerer Laufwerke?

Aber ich hab erstmal in den Anhang das Prorgamm von mir hochgeladen, dass du mit dem Parameter /F startest. Wenn du keinen Parameter angibst (also z.B. einfach nur doppelt auf die Datei klickst), zeigt dir das Programm nur an, ob es etwas problematisches finden konnte. Mit dem Parameter /F wird es angewiesen, diese Probleme zu beseitigen.

Dann wieder neustarten und hoffen. Wenn es dann immer noch nicht klappen will, wäre wie gesagt die Bezeichnung des Boards hilfreich.

/edit: jetzt ist die Datei auch wirklich im Anhang ;)
 

Anhänge

_TK_

Lieutenant
Dabei seit
Jan. 2009
Beiträge
707
Der Transfermodus wird zwischen der Hauptplatine und der Festplatte ausgehandelt, von UDMA aus anfangend. Ursache für PIO ist sehr wahrscheinlich eine schlechte Verbindung des SATA-Kabels.

Kabel neu stecken / tauschen, und schon sollte die Post abgehen.

Falls nicht, kann es evtl. auch an der Festplatte liegen. Manchmal sind dort die Koppelkondensatoren defekt, oder der Controllerchip kurz vorm Aufgeben. Aber das sind eher seltene Phänomene - meistens sind wie gesagt Kontaktprobleme die Ursache.
 

nicegu

Newbie
Ersteller dieses Themas
Dabei seit
Juni 2009
Beiträge
5
Der UDMA IdDataChecksum Cleaner brachte die Lösung:

Checking 0000 (Standard-Zweikanal-PCI-IDE-Controller)...
Checking 0001 (Standard-Zweikanal-PCI-IDE-Controller)...
Checking 0002 (Standard-Zweikanal-PCI-IDE-Controller)...
Checking 0003 (Primärer IDE-Kanal)...
> MasterIdDataChecksum exists [deleted]
Checking 0004 (Primärer IDE-Kanal)...
> MasterIdDataChecksum exists [deleted]
Checking 0005 (Sekundärer IDE-Kanal)...
Checking 0006 (Primärer IDE-Kanal)...
Checking 0007 (Sekundärer IDE-Kanal)...
Checking 0008 (Sekundärer IDE-Kanal)...
> MasterIdDataChecksum exists [deleted]

Checksums found and deleted - press key to continue...

Nun rennt die Platte wieder, bis zu 99.7 MB/s :D

@AndrewPoison, _TK_, Mäuserrich: vielen vielen Dank für eure schnelle Hilfe!
 

AndrewPoison

Admiral
Dabei seit
Jan. 2005
Beiträge
8.228
Mal als kleiner Hintergrund-Kurs, was das Programm gemacht hat bzw. was von der Lösung zu halten ist:

Windows zählt bei UDMA-Datenübertragungen die Fehler mit, die während der Übertragung so passieren (das müssen keine wirklichen Fehler sein, oft reicht es schon aus das die Festplatte mit mehreren Zugriffen stark ausgelastet ist und (für Windows) nicht schnell genug die Daten übermittelt). Wird irgendwann ein bestimmter Wert überschritten, stellt Windows automatisch auf PIO um, ohne das der User darüber informiert wird noch über den Gerätemanager die Möglichkeit hat, das wieder zu ändern.

Das Programm macht nun folgendes: es durchsucht einen Teil der Registry nach den Fehlerzählern, und löscht sie. Dadurch lässt Windows wieder die UDMA-Übertragung zu.

Ich habe dieses Programm geschrieben, nachdem meine neue Festplatte (WD20EADS) für Windows scheinbar häufig zu langsam ist und es deshalb gerne mal auf PIO drosselt. Bei mir habe ich die Anwendung sogar im Autostart, um sicher zu gehen das ich nicht in ein paar Wochen wieder auf PIO bin.

/edit: im Programm ist übrigens www.vrisom.de als Bezugsadresse genannt, aber noch gibt es das dort nicht zum Download, da das Tool eigentlich noch in meiner Test-Phase ist. Doch es scheint ja nicht nur bei mir zu klappen... von daher kann ich es wohl die nächsten Tage auch auf vrisom.de bringen.
 
Zuletzt bearbeitet:
Top