Live-Linuxe - Schwarzer Rahmen ums Bild

Ed40

Commander
Dabei seit
Apr. 2010
Beiträge
2.996
Hallo,

Ich hab vor kurzem von einer ATI 6950 auf eine GTX 660ti gewechselt. Seit dem habe ich überall ausserhalb von WIndows (auch im Bios oder DosModus) einen schwarzen Rahmen ums Bild.

Ich verwende gerade zb einige Live Linuxe. Momentan bin ich bei Puppy Linux (Precise) gelandet. Auch hier der schwarze Rahmen ums Bild, egal welche EInstellung oder welche Treiber ich verwende.

Im Bios oder DosModus ist es mir egal, aber im Puppy hätte ich schon gerne das volle Bild

Monitor : LG E2442

Meine xorg.conf sieht so aus:

Code:
#Special base config file used in Puppy Linux.

# **********************************************************************
# Module section -- this  section  is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
#
Section "Module"

# This loads the DBE extension module.

    Load        "dbe"  	# Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection

# This loads the font modules
#    Load        "type1"
#    Load        "freetype"

# This loads xtrap extension, used by xrandr
#    Load       "xtrap"

# This loads the GLX module (if present). xorg 7.4/5 need explicit disable to disable...
#    Disable    "glx" #LOADGLX

# This loads dri module (if present). 7.4 loads it by default, have to disable...
#    Load       "dri" #LOADDRI
#    Disable "dri"

EndSection

# **********************************************************************
# Files section.  This allows default font paths to be set
# **********************************************************************

Section "Files"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)

    FontPath   "/usr/share/X11/fonts/misc/"
    FontPath   "/usr/share/X11/fonts/Type1/"
    FontPath   "/usr/share/X11/fonts/TTF/"

EndSection

# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

# Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
# (where n is 1 through 12).  This allows clients to receive these key
# events.

#    Option "DontVTSwitch"

# Enables mode switching with xrandr
# There is a report that this can cause Xorg not to work on some
# video hardware, so default is commented-out...
# but i want to use it in xorgwizard so leave on...

    Option "RandR" "on"

# With this, Xorg won't talk to HAL to add evdev devices and you'll be back
# with the old Xorg behavior (pre-7.4)...

    Option "AutoAddDevices" "false"

# For no-Hal, kirk also suggests this...

#    Option "AllowMouseOpenFail" "true"

# Xorg 7.4, Ubuntu Jaunty, CTRL-ALT-BACKSPACE is disabled by default...

    Option "DontZap" "false"

EndSection

#everything past here is auto-generated by Puppy's Xorg Wizard...

Section "ServerLayout"
	Identifier "Default Layout"
	Screen "Screen0" 0 0
	InputDevice "Keyboard0" "CoreKeyboard"
	InputDevice "Mouse0" "CorePointer"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option      "XkbRules" "xorg"
	Option      "XkbModel" "pc102"
	Option      "XkbLayout" "de" #xkeymap0
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "IMPS/2" #mouse0protocol
	#Option      "Emulate3Buttons"
	#Option      "Emulate3Timeout" "50"
	Option      "ZAxisMapping" "4 5" #scrollwheel
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
	#HorizSync    30-83
	VertRefresh  59-75
	#UseModes     "Modes0" #monitor0usemodes
	Option      "PreferredMode" "1920x1080"
EndSection

Section "Modes"
	Identifier "Modes0"
	#modes0modeline0
EndSection

Section "Device"
	Identifier  "card0"
	Driver      "nvidia" #card0driver
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultDepth 24
	#Option         "metamodes" "1920x1080_60 +0+0" #METAMODES_0
	Subsection "Display"
		Depth       24
		Modes       "1920x1080"
	EndSubsection
EndSection

#PuppyHardwareProfile=NVIDIAE2442

Weiß jemand ob und wie ich das beheben kann?
 

Keksdt

Lt. Junior Grade
Dabei seit
März 2009
Beiträge
502
Du hast den Monitor per HDMI angeschlossen oder?

Bei AMD Karten musst du dann mal nach OVERSCAN schauen, damit kann man das Bild im Treiber wieder richtig richten, wie das bei Nvidia Karten geht weiß ich aufgrund des mangels an Grafikkarten nicht
 

BlubbsDE

Fleet Admiral
Dabei seit
Juni 2011
Beiträge
41.485
Per DVI anschließen. Bei nVidia ist jeder Monitor, angeschlossen per HDMI, ein TV Gerät. Und dann gibts solche Probleme. Keine Ahnung, ob der Linux nV Treiber da Optionen hat, für den Overscan. Wenn ja, kannst Du es dort korrigieren. Oder eben, die beste Lösung. In der PC Welt einfach kein HDMI nutzen. Das hat dort im Grunde nichts verloren.
 

Ed40

Commander
Ersteller dieses Themas
Dabei seit
Apr. 2010
Beiträge
2.996
So..Danke erstmal für die Mithilfe :)

Also, der Monitor ist über DVI-D angeschlossen. Allerdings steckt im HDMI-Output der Karte ein LG-TV. Ich hab HDMi erstmal abgezogen und Puppy komplett neu eingerichtet.

Das Problem ist, beim ersten Start hab ich volles Bild, allerdings nur 640xblabla. Wenn ich per Setup den Xorgwizard starte und den Nouveau bzw NV-Treiber anwähle, schlägt der XServer-Test fehl...

Wennich VESA benutze kann ich alle Auflösungen nutzen, allerdings wieder nur mit dem schwarzen Rahmen...

EDIT:

Werd jetzt mal den Link durchgehen.
 
Top