OpenWRT Router als WireGuard Server

GlockMane88

Lt. Commander
Registriert
Aug. 2008
Beiträge
1.244
Hey Leute,

habe an die FritzBox! 7590 einen TP-Link Archer C7 (läuft mit OpenWRT 19.07) angeschlossen und darauf WireGuard installiert, funktioniert auch einwandfrei.. Nun wollte ich mit dem Notebook (mit FritzBox verbunden) auf das Webinterface vom OpenWRT zugreifen und stellte fest, dass ich dieses nicht erreiche, liegt wohl daran, dass er in einem anderen Subnetz liegt..

FritzBox -> 192.168.1.1
OpenWRT -> 192.168.1.2 / 192.168.2.1
WireGuard -> 192.168.3.1

Für mich würde es mehr Sinn machen, wenn das Ganze wie folgt aussehen würde:

FritzBox -> 192.168.1.1
OpenWRT -> 192.168.1.2
WireGuard -> 192.168.2.1

Also die OpenWRT Box soll kein eigenes Netz bereitstellen.. Wäre das sinnvoll und was müsste ich da einstellen?

Danke für eure Tipps!

Edit:

So schaut es aktuell aus.. Idee: den WAN Port nicht verwenden und beim LAN eine IP aus dem FritzBox Netz einstellen (192.168.1.2)..

1598115875430.png
 
Zuletzt bearbeitet:
Du kannst in OpenWrt den DHCP Server deaktivieren und den WAN mit den LAN-Ports Bridgen - dann ist die OpenWrt Box wie ein Switch im Netzwerk.

Die Fritzbox braucht eine statische Route für Netzwerke die am OpenWrt Router anliegen - die Fritzbox als Hauptrouter weiß nicht, dass es andere Netzwerke an LAN-Anschlüssen gibt -die Pakete werden normal an Fritzbox-WAN (default-Gateway) weitergeleitet.
 
  • Gefällt mir
Reaktionen: GlockMane88
@lokon

Okay, aber wo konfiguriere ich die Bridge? Am LAN oder WAN Interface und welches Protokoll stelle ich dann an den beiden Inferfaces ein? An einem (an dem, wo ich die Bridge konfiguriere?) würde ich dann eine statische IP einstellen, wenn ich das richtig verstehe, aber was stelle ich an dem anderen ein, Unmanaged?

1598117505423.png
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: GlockMane88
@lokon

Habe schon versucht ihn als Dumb-AP einzurichten, allerdings scheint mir der OpenWRT Router plötzlich jede Änderung (via Apply Unchecked) wie folgt zu quittieren:

1598118654757.png


Schon verschiedene Browser versucht, leider ohne Erfolg :(
 
  • Ist genug Platz vorhanden (System - Software - Freier Speicher/Free Space)
  • per ssh Zugriff versuchen
  • Konfiguration resetten (in Firmware-Flash-Seite) (löscht alle Einstellungen und installierten Pakete)
 
  • Gefällt mir
Reaktionen: GlockMane88
@lokon

Ich denke, ersterer Punkt trifft zu, in der SSH-Shell zeigt er folgendes an:

"your jffs2 partition seems full"

Ich resette mal die Konfig, ich hoffe mal, es lag nur daran, dass ich probiert hatte AdGuardHome zu installieren (welches ich mittlerweile auf einen RaspberryPi 3B installiert habe)..
 
Ja - OpenWrt hat keine Größenprüfung bei der Installation und soetwas wie AdGuard mit größeren Blocklisten ist für kleine Router nicht sogut geeignet - ein Raspi mit SD-Karte oder ein Router mit mehr Flash (NAND, eMMC oder SATA) wie zB pcengines APU2 sind für solche Einsatzzwecke dann besser geeignet.
 
  • Gefällt mir
Reaktionen: GlockMane88
@lokon

Hey, habe den Router jetzt als Dumb AP eingerichtet, funktioniert einwandfrei, WireGuard Setup müsste ich nun wieder selbst hinbekommen!

Danke dir vielmals!

Schönen Abend
 
q0p schrieb:
@GlockMane88 wie schnell ist der C7 unter Wireguard? OpenVPN sollten rund 10 Mbit/s sein?
Leider funzt mein Setup gerade nicht, da ich kein DSL mehr habe, stattdessen hängt jetzt eine Telekom Speedbox (LTE) vor der Fritzbox und ich bekomme von außen keine Wireguard Verbindung zu Stande obwohl ich in der Speedbox und Fritzbox Portweiterleitung en konfiguriert habe..
 
  • Gefällt mir
Reaktionen: q0p
Mit einer Wireguard Verbindung von meinen Oneplus 8t zu meinem Archer c7 v2 habe ich gerade ziemlich genau 30Mbit/s im Speedtest geschafft. Allerdings kann da auch das Handy als auch meine DSL Verbindung (40Mbit/s Upload) noch eine Bremse sein.
Der Peak load beim Test auf Router waren aber schon 0.95
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: q0p
Zurück
Oben