Pausenformel automatisch berechnen lassen

gidato

Lieutenant
Dabei seit
Juni 2009
Beiträge
631
Hallo,

ich möchte meine Formeln in Excel erfassen und möchte dabei dass du Pausen und die Nettoarbeitszeit automatisch erstellt wird.

In meinem Beispiel (frei erfunden) habe ich von 10:00 bis 19:00 Uhr gearbeitet. Ich will dass im Reiter "Pause" die Zeit der Pause automatisch erstellt und im Reiter "Stunden" die Gesamtstunden abzüglich der Pause stehen.

Dabei sollen die gesetzlichen Pausen 6-9 Stunden = 30 Minuten Pause und mehr als 9 Stunden = 45 Minuten Pause eingehalten werden.

Könnt ihr mir die Formel für beide Spalten bitte nennen ?

 

Anhänge

Zuletzt bearbeitet:

rg88

Fleet Admiral
Dabei seit
Feb. 2015
Beiträge
24.444
Einfach mit einer WENN DANN Funktion arbeiten. Zusammenbauen wirst die ja wohl selbst können
 

gidato

Lieutenant
Ersteller dieses Themas
Dabei seit
Juni 2009
Beiträge
631
@rg88
Leider nicht, wäre cool und nett wenn du es mal vorzeigen könntest. Danke
 

Axxid

Admiral
Dabei seit
Feb. 2012
Beiträge
7.489
=WENN(D-C>9:00;45;30) ?
Sonst müsste ich erst Excel aufmachen..

edit: Eine Zeile mit 9:00 irgendwo verstecken. Dann "=WENN(B1-A1>=$C$1;45;30)" wobei C1 die Zelle mit 9:00 ist.
Schöner wird es noch mit einer Abfrage vorher abzufragen ob beide Zeiten befüllt sind.

edit2: "=WENN(D7-C7>0;WENN(D7-C7>=$C$1;45;30);"")" wieder C1 = 9:00. Zum Zeiten formatieren bin ich gerade zu blöd.
 
Zuletzt bearbeitet:

florian.

Fleet Admiral
Dabei seit
Okt. 2006
Beiträge
20.148
versuchs mit D7 und C7....
und formatier die uhrzeit richtig
 

SKu

Admiral
Dabei seit
Aug. 2012
Beiträge
7.725
=wenn(d7-c7>=0.375,"0:45",wenn(d7-c7>=0.25,"0:30","0:00"))
=summe(d7-c7)-e7

Untitled.jpg
 
Zuletzt bearbeitet:

powerfx

Admiral
Dabei seit
Apr. 2009
Beiträge
9.352
Pause müsste mit
Code:
=F7-WENN(F7>9;F7-0,75;WENN(F7>6;F7-0,5;F7))
gehen, aber du brauchst wahrscheinlich eher die Stunden ohne Pause, weil die werden ja abgerechnet:
Code:
=WENN(F7>9;F7-0,75;WENN(F7>6;F7-0,5;F7))
Stunden mit Pause sind
Code:
=D7*24-C7*24
Du musst sie nur entsprechend formatieren.
 
Zuletzt bearbeitet:

SKu

Admiral
Dabei seit
Aug. 2012
Beiträge
7.725
An deiner Stelle würde ich aber lieber dezimal rechnen, was Stundenzeiten betrifft. Da wird eigentlich immer dezimal gerechnet.

Würde dann so aussehen:
Code:
=WENN(D7-C7>=0.375,"0.75",WENN(D7-C7>=0.25,"0.5","0"))
-> Kommt in die Zelle für Pausenzeit

Code:
=SUMME(((1/12)*D7*12)-(1/12)*C7*12)*24-E7
Code:
=SUMME(D7-C7)*24-E7
-> Kommt in die Zelle für Stunden (hier mit englischen Zeitformat auf das 24 Stunden Zeitformat umgerechnet). Mein Windows ist auf Englisch, daher nutzt Excel bei mir auch das 12 Stunden Format. Damit kannst du dann alle Zellen mit Dezimalzahlen einfach als Zahl formatieren und kannst dir obendrein auch noch direkt die Wochenstundensumme bilden.

Sieht dann so aus als Beispiel: Untitled.jpg
 
Zuletzt bearbeitet:

gidato

Lieutenant
Ersteller dieses Themas
Dabei seit
Juni 2009
Beiträge
631
wenn ich eure Formeln in meine TEST Datei eingebe, kommen Fehler auf. Kann einer meine TEST Datei mit Formeln einfügen und es hier wieder uploaden? (Damit ich die Formeln in der Exceltabelle habe).
 

SKu

Admiral
Dabei seit
Aug. 2012
Beiträge
7.725
Zuletzt bearbeitet:
Top