SABnzbd+ sorgt für Namensänderung der Partition, wenn nicht vorher eingebunden

storkstork

Lt. Junior Grade
Dabei seit
März 2010
Beiträge
465
Ich habe mal wieder ein Llinux-Problem zu dem ich keine Lösung finden konnte.
Kubuntu 19.10 wird als Betriebssystem genutzt.

Zum Herunterladen von Dateien benutze ich SABnzbd+. Die beiden Ordner "temp" und "complete" liegen auf einer HDD. Diese HDD ist standardmässig nicht eingebunden. Standardmässig heisst diese Partition (welche ich damals unter Windows 10 angelegt habe) "Downloadz". Wenn ich jetzt SABnzbd+ starte, ohne vorher die Partition eingehängt zu haben, benennt Kubuntu die Partition automatisch in "Downloadz1" um. So findet SABnzbd+ die Ordner nicht mehr und legt irgendwo neue an und speichert natürlich alles in den neuen Ordnern.

Zur Zeit ist die einfachste Lösung, das Verzeichnis bei SABnzbd+ einfach in "Downloadz1" umzubennen. Mittlerweile bin ich schon bei "Downloadz4".

Habt ihr mir eine Idee, wie ich das automatische Umbenennen verhindern kann? Ich möchte die Partitionen eigentlich nicht automatisch beim Start einbinden, da ich SABnzbd+ nicht oft benutze und die Festplatte so nicht unnötig eingeschaltet werden soll.
 

Alexander2

Ensign
Dabei seit
Aug. 2014
Beiträge
131
Es müsste eigentlich gehen indem du dir die Block ID von der Partition holst, diese dann als zu mountende Partition in die fstab eingibst mit nach deinem wunsch festgelegtem Pfad und bei den Mountoptionen zu denen die evtl. sonst schon da sind noch "noauto" hinzufügst.
Zum ermitteln der Blockid kannst du "blkid" verwenden, damit das Programm zum ermitteln der ID's zugriff bekommt musst du es mit root rechten ausführen. Typischerweise dann also "sudo blkid"
Hier ist auch eine Info zu noauto im Zusammenhang mit Systemd zu finden: https://wiki.ubuntuusers.de/fstab/
 

storkstork

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
März 2010
Beiträge
465
Alexander2, Danke für die Ausführlichen Hinweise.
Ich habe es tatsächlich schon geschafft mein NAS mit fstab einzubinden.
Dann werde ich es für die anderen Festplatten/Partitionen wohl auch versuchen müssen. Ich berichte, falls ich es geschafft habe oder gescheitert bin :D
 

storkstork

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
März 2010
Beiträge
465
Alexander2, Habe es gerade mal ausprobiert mit folgenden Werten in der fstab:
UUID="BCF823F6F823AE18" /media/andreas/Downloadz ntfs noauto

Leider funktioniert es nicht.
Wenn ich erst die Partition mounte und dann SABnzbd+ starte funktioniert es ganz normal.
Wenn ich die Partition nicht einhänge bevor ich SABnzbd+ starte, legt mir SABnzbd+ wieder einen Ordner an:
/media/andreas/Downloadz/
Dieser Ordner befindet sich dann aber irgendwo auf der Systemfestplatte, nicht auf der gewünschten Partition.
Wenn ich danach die Partitition einhänge, wird sie wieder als Downloadz 1 eingehängt.

Was ich auch probiert habe ist folgendes in der fstab:
UUID="BCF823F6F823AE18" /media/andreas/Downloadz ntfs noauto,x-systemd.automount,x-systemd.idle-timeout=600,defaults 0 2
Auch das hat nicht funktioniert, da die Partition nicht automatisch eingehängt wurde beim Start von SABnzbd+, sondern wieder ein neuer Mount auf meiner Systemplatte erstellt wurde anstatt auf der gewünschten partition.

Was funktioniert hat, wenn ich "noauto" weglasse. Dann ist die Partition immer gemountet und SABnzbd+ kann direkt beim Start darauf zugreifen.

Es scheint ein Problem von SABnzbd+ unter Linux zu sein, dass dies beim Start einfach einen neuen Ordner anlegt, wenn es den angegebenen Pfad nicht findet.
Unter Windows hat das immer wunderbar funktioniert. Wenn ich SABnzbd+ gestartet habe, hat sich die Festplatte mit der Downloadz-Partition hochgefahren und alles wurde dort gespeichert.

Was ich komisch finde ist, dass Die Festplatten (HDDs) nicht hochfahren müssen, wenn ich sie einhänge. Sie sind sofort da und alle Ordner werden angezeigt. Unter Windows hat es ein paar Sekunden gedauert bis alles angezeigt wurde und man hat gehört, wie die Festplatten anlaufen. Wenn ich unter Linux die HDDs im PC-Gehäuse anfasse, spürt man die Vibrationen, sie drehen sich also sowieso, auch wenn sie nicht gemountet sind. Kann man das irgendwie abschalten unter Linux? Sonst könnte ich die HDDs auch direkt beim Start mounten lassen, wenn sie sowieso ständig laufen.
 
Zuletzt bearbeitet:

Alexander2

Ensign
Dabei seit
Aug. 2014
Beiträge
131
Wenn die Platten sowieso immer im PC eingebaut sind würde ich die auch immer mounten lassen :-)
Falls du das möchtest, per hdparm kann man Festplatten idle-Einstellungen anpassen

https://linuxundich.de/hardware/festplatten-automatisch-im-betrieb-in-den-standby-schalten/


Soweit ich weiß ist das Strapazierendste für hdd wohl immer das anfahren und stoppen, also je nach Szenario wäre der dauerlauf sogar besser.

Mir war auch irgendwie nicht bewusst, dass es Interne Platten sind. Ich hatte tatsächlich daran gedacht, dass es eine USB-Festplatte ist die eben beim anhängen dann an immer der selben Stelle gemountet werden soll.

Wenn die Festplatte ja nun Intern ist und immer eingebaut ist könnte man sehr einfach ein Startscript schreiben. im Grunde 3 Zeilen
Dann wird wenn man das Programm starten will vor dem Start der Mountbefehl aufgerufen und falls nötig noch eine wartezeit dazwischengesetzt (Anlaufzeit der Festplatte)

Bash:
#!/bin/bash
sudo mount UUID="BCF823F6F823AE18"
sleep 5
sabnzbd
Diese Scriptdatei dann als ausführbar setzen chmod +x [Scriptdateiname] oder per gui (Dateimanager). Soweit ich weiß ist in dem fall das benutzen des sudo befehls nötig, wenn die Festplatte in der fstab eingetragen ist sollte nur die UUID reichen als Angabe für den mountbefehl. Man könnte es auch so machen, dass man das Passwort für diesen fall nicht eingeben muss indem man in der sudoers datei eine passende Regel erstellt. Dann wäre es aber wichtig wegen der Sicherheit, dass nur root User die Scriptdatei schreiben dürfen sonst könnte sie leicht von angreifern ausgenutzt werden um "alles" durch eintragen in die datei per Root auszuführen.
Also es geht auf jeden fall einiges, aber die Partition einfach generell mounten zu lassen und wenn man möchte Idle-Einstellungen zu setzen, dass sie nur bei Benutzung dann mal anläuft ist doch das einfachste :-)
 

storkstork

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
März 2010
Beiträge
465
Alexander2, Vielen Dank für die vielen Infos und Erklärungen.

Ich habe die Partitionen jetzt einfach dauerhaft automatisch eingebunden und es funktioniert soweit.

Code:
UUID="BCF823F6F823AE18" /media/andreas/Downloadz ntfs noauto,x-systemd.automount,x-systemd.idle-timeout=600,defaults 0 2
Das hat wohl nicht funktioniert, weil ich die UID samt den " kopiert habe :D

Etwas interessantes habe ich festgestellt. Ich muss ja zuerst einen Ordner erstellen,damit die Partition dort eingebunden wird. Eine meiner Partitionen heisst "Eigene Dateien". So einen Ordner kann ich in der fstab nicht anstprechen. Sobald ich ein Leerzeichen eingebe wird der nachfolgende Text zur nächsten Option. Da gibt es bestimmt auch eine Lösung für, aber dazu fehlt mir zurzeit die Lust, mich tiefer einzuarbeiten. Da weiss man auch, warum es selbst heute noch Dateien und Ordner ohne Leerzeichen benannt werden.

So funktioniert es jetzt erstmal. Ich möchte in den nächsten Monaten auch noch Manjaro und vielleicht andere Distros ausprobieren und mich irgendwann festlegen. Bis dahin werde ich mich bestimmt noch ein paar Mal mit solchen Dingen auseinandersetzen müssen :heul:
 

Alexander2

Ensign
Dabei seit
Aug. 2014
Beiträge
131
In der Shell ist es ja so, dass gewisse zeichen einem Befehl oder Trennungszeichen gleichzusetzen sind. Wie eben auch ein Leerzeichen. In der Shell kann man die eigendliche Funktion dieser Operatoren/Zeichen sozusagen auskommentieren.

Eine möglichkeit ist alles in Anführungszeichen zu setzen oder für Einzelne Zeichen dann das "\"
Also wenn man ein "\" und ein Leerzeichen danach schreibt, dann wird die sonst Trennende Funktion von einem Leerzeichen ignoriert.
(cat ist ein kleines Programm zur Ausgabe des Inhaltes von Dateien in die Konsole)

Wenn man zum Beispiel "cat /home/Benutzername mit Leerzeichen/textdatei.txt" eingibt findet cat nicht die Datei "textdatei.txt" weil der Benutzername eben Leerzeichen enthält und das nicht berücksichtigt wurde.
Wenn man nun aber "cat /home/Benutzername\ mit\ Leerzeichen/textdatei.txt" eingibt - man achte auf die "\" dann wird der Pfad als ganzes und richtig interpretiert und cat findet die eigendliche Zieldatei.
Es sollte auch gehen in der fstab den Pfad mit dem Leerzeichen entsprechend angepasst zu benutzen also "Eigene\ Dateien"
 
Top