[Samba] Kann Samba-Shares einbinden, aber nicht auf sie zugreifen

Photon

Commodore
Dabei seit
Apr. 2006
Beiträge
4.989
Hallo Community,

ich verzweifle nun schon seit einigen Tagen daran eine externe USB-Platte über meinen neuen Router (Easybox 803 LTE) im Netzwerk freizugeben. Die Clients sind alles Linux-Maschinen aber die Easybox unterstützt leider kein NFS sondern nur Samba und ich hatte damit noch nie zu tun gehabt, deshalb könnte es sich um ein Anfängerproblem handeln. :)

Ich habe eine große Fat32-Partition angelegt und auf dieser einen einzigen Ordner "Share" (nur zu Testzwecken erst mal). Diesen Ordner habe ich im "User Mode" für einen Benutzer "photon" für Lesen und Schreiben freigegeben. Benutzer und Passwort stimmen mit Benutzername und Passwort des Benutzers auf einem der Linux-Clients überein.

Nun lasse ich mir also die Shares anzeigen:

Code:
[photon@photon-desktop ~]$ smbclient -L EASYBOX
params.c:OpenConfFile() - Unable to open configuration file "/etc/samba/smb.conf":
	File or folder not found
smbclient: Can't load /etc/samba/smb.conf - run testparm to debug it
Enter photon's password: 

	Sharename       Type      Comment
	---------       ----      -------
	Share           Disk      Share
	IPC$            IPC       

	Server               Comment
	---------            -------
	EASYBOX              EasyBox File Server

	Workgroup            Master
	---------            -------
	EASYBOX              EasyBox File Server

Anmerkung: Die Fehlermeldung vor der Passwortabfrage ist bekannt und sollte nicht die Quelle des Fehlers sein, so zumindest hier beschrieben: https://bugs.archlinux.org/task/3743

Dann binde ich die Freigabe ein:

Code:
sudo mount -t cifs //EASYBOX/Share /mnt/mount/ -o user=photon,password=PASSWORD,workgroup=WORKGROUP,ip=192.168.2.1

Der Befehl wird ohne Ausgabe angenommen, so weit also alles ok. Dann aber versuche ich mit ls auf den Inhalt des Ordners zuzugreifen und leider erhalte ich keine Ausgabe. Ich kann nur noch die Ausführung abbrechen:

Code:
[photon@photon-desktop ~]$ ls /mnt/mount/
^Cls: reading directory /mnt/mount/: Host is down

Greife ich als Root zu, dann gibt es interessanterweise keine Ausgabe nach dem Abbruch:

Code:
[root@photon-desktop photon]# ls /mnt/mount/
^C

Der Zugriff über eine Vista-Installation, die genau für solche Fälle nicht entfernt wurde, klappt übrigens wunderbar.

Vielen Dank für Tipps,
Photon
 
Irgendwie fehlt mir hier das wichtigste... die smb.conf von dem Rechner auf dem die Freigabe liegt. Schließlich werden in dieser Datei diese ganzen Sachen konfiguriert -Freigabe, Zugriffsrechte, etc....

Gruß Zoldyck
 
Es handelt sich beim Freigabe"rechner" um einen Router. Ein normaler Nutzer kommt da eher schlecht an eine smb.conf heran (ohne die Easybox genauer zu kennen)...
 
Ja, mit dem Sharemode habe ich es auch schon probiert, mounte dann entsprechend ohne user und password Optionen mit dem gleichen Ergebnis: Mounten klappt, Zugreifen nicht. SSH-Zugriff wäre super, aber ich wüsste nicht, wie es gehen soll, entsprechende Einstellungen im Web-Interface gibt es zumindest nicht...

edit: SSH scheint keins drauf zu laufen:

Code:
[photon@photon-desktop ~]$ ssh root@192.168.2.1

gibt keine Ausgabe (root ist der Benutzername für den Login zum Web-Interface).
 
Zurück
Top