Ständiges Chkdsk einer großen Partition unter WinXP beim Booten beheben?

HDDesaster

Newbie
Dabei seit
Dez. 2006
Beiträge
2
Servus!

Rechner AMD-64 "irgendwas" mit lausigem K8VE-SE-Board (integrierter RAID-Controller, wenn man das überhaupt so nennen darf) und zwei SATA-HDDs 80GB und 200GB auf einem XP SP2-System.

Beide sind in mehrere Partitionen aufgeteilt (alle NTFS), wobei mir die größte Partition (ca. 80GB) der 200GB-Platte bei jedem Neustart ein Chkdsk einbringt (jeweils fehlerfreier Durchlauf). Ein Zugriff auf diese Platte findet manuell nicht statt und sollte auch automatisch nicht erfolgen (zZt nur zu 10% mit Scans belegt). Trotzdem das nervige Chkdsk.

Diskeeper (Lite-Version) lässt daher auch keine Optimierung der Partition zu und Checkdisk mal zwischendrin zu starten, bringt auch nichts. Es wird stets nur angesagt, dass Diskeeper nicht "optimieren" kann, weil ein Start von Chkdsk für diesen Datenträger vorbereitet wurde. Und das bereits wenige Sekunden nach dem Start!

Hat jemand etwas Ahnung, mit welchen Log/HDD-Tools man die Sache etwas einschränken kann? An XP an sich sollte es ja eigentlich nicht liegen, oder?

Gruß
der Mann mit der Platte
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
62.797
HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Session Manager
da kann man es abstellen unter "BootExecute "
Beispiel:
"autocheck autochk /k:C *" deaktiviert z.B. das Scannen von C:

wenn mehrere Platten ausgeschlossen werden sollen:
"autocheck autochk /k:CDEFG *" deaktiviert z.B. das Scannen von C: D: F: G: usw
Alternativ in unter "CMD" eintippen:
chkntfs /x c: d: e: f: hierdurch wird das checken von den angegebenen Laufwerk unterbunden, wenn Du ein NTFS System hast.
Solltest Du es für immer abstellen wollen, lösche in der Registry den Eintrag "BootExecute" komplett.
 

HDDesaster

Newbie
Ersteller dieses Themas
Dabei seit
Dez. 2006
Beiträge
2
Dass man das Abstellen kann, wusste ich bereits; wie es geht, noch nicht. Danke!

Aber möglicherweise hat jemand Hintergrundwissen, warum XP die Partition ständig in den Wartungszustand setzt?
 

werkam

Alter Meckermann
Dabei seit
Okt. 2001
Beiträge
62.797
Weil ein Programm nicht ordentlich oder ein Dienst nicht richtig beendet wird, da noch Daten auf die Platte geschrieben werden beim runterfahren.
Starte den Rechner im abgesicherten Modus und fahre ihn dann korrekt herunter.
Schalte den Rechner wieder ein und boote ihn ganz normal.
Sollte bei diesem ersten Startvorgang keine Datenträgerüberprüfung erfolgen, gehe wie folgt vor:
Start-->Ausführen-->msconfig-->Systemstart-->Alles deaktivieren
Start-->Ausführen-->msconfig-->Dienste-->alle Microsoft Dienste ausblenden-->die
verbleibenden deaktivieren, dann wieder neu starten, sollte das Problem nicht mehr auftreten, die Punkte einzeln wieder aktivieren, um somit das verursachende Programm lokalisieren zu können.

Du solltest dazu aber die oben genannten Einstellungen zwecks Abstellen der Funktion rückgängig machen.
 
Top