System-Partition gelöscht - TestDisk findet nichts!

KlarMax

Newbie
Dabei seit
Mai 2010
Beiträge
3
Hallo,

irgendwann erwischt's einen halt. Vor drei Tagen hat sich mein Computer beim Versuch ein XP-Image mit Acronis auf c: wiederherzustellen im ungünstigsten Moment aufgehängt.

Nach einem Neustart hat sich die Festpatte mit vorher 5 Partitionen nur noch als eine einzige aktive Partition zu erkennen gegeben (Bild-1), die von mir gern formatiert werden möchte. No baby!

Dummerweise hab ich dann - keine Ahnung was mich da geritten hat - mit einer XP-Installations-CD und dem Befehl <fixmbr> den bis dahin möglicherweise noch korrekten MBR überschrieben. :volllol:

Seitdem viel gegurgelt und natürlich auch über TestDisk gestolpert. TestDisk erkennt die Platte, findet keine Partitionen, wermutet FAT16 Dateisystem und 240 Heads. Auf der Platte befinden sich aber defenitiv nur NTFS-Partitionen. Bilder 2 bis 6.

Ein Versuch mit geänderter Geometrie, also 255 anstatt 240 Heads, bringt ebenfalls keine einzige Partition ans Licht.

Meine Idee: mit der XP-Installations-CD die angezeigte 150 GB-Partion zu löschen und die ersten 20 Gigas (gleiche Größe wie vorher) wieder mit NTFS zu formatieren, in der Hoffnung, dass danach wenigstens die Geometrie wieder stimmt ([Rebuild BS] ist mir zu riskant). Den Rest der Platte aber unangetastet lassen. Vielleicht klappt's dann mit der Analyse von TestDisk.

In einem älteren Artikel "Tipps zur Datenrettung" schreibt Fiona:

Zitat: Wichtiger Hinweis bei versehentlichem Formatieren:
Wenn eine verlorene Partition exakt auf der selben Größe und mit dem gleichen Dateisystem formatiert wurde, findet Testdisk nur diese Partition. Die vorige Partitionsstruktur wird nicht mehr gefunden.
Der Grund ist, bei einer gleichen Formatierung wird das Dateisystem, der Bootsektor und der Backup Bootsektor neu erstellt. Dadurch werden die alten Informationen, die für eine Wiederherstellung benötigt werden überschrieben.

Nach meiner vorschnellen Erstreaktion will alles gut überlegt sein. Daher meine Frage:

Werden nach einer solchen Formatierung nur die Struktur-Infos der Partition an gleicher Stelle nicht mehr gefunden (wäre mir egal, da nur OS-Daten) oder findet man nacher auch keine Struktur-Infos zu anderen Partitionen an anderen Stellen der Festplatte mehr?

Grüße Max
 

Anhänge

Ernst@at

Admiral
Dabei seit
Apr. 2008
Beiträge
7.918
Ich sehe auf keinem der Bilder, dass Du in testdisk die Geometry von 240 auf 255 umgestellt hättest...
 

KlarMax

Newbie
Ersteller dieses Themas
Dabei seit
Mai 2010
Beiträge
3
Erklären kann ich es nicht, aber als ich vergangene Nacht die Analyse mit 255 Heads gemacht habe, kamen keine Partitionen zum Vorschein. Als ich jetzt das Beweis-Foto schiessen wollte - ich brech' zusammenen - , der ganze Partitions-Club wieder vollständig (Bild-1).

Danke Ernst, oft muss man nur die richtigen Fragen stellen.

Wenn ich das richtig sehe (hab' keine Erfahrung mit dem Tool), kann ich dieses Ergebnis bereits mit [write] sichern (Bild-2) und anschliessend den Bootsektor mit [Backup BS] korrigieren. Die angezeigten Dateien <p> scheinen ok.

Oder sollte/muss man auch noch die nach wie vor fehlende System-Partition unterhalb von Sektor 2550 versuchen mit [Add] zu ergänzen, um nach einem Neustart das gewünschte Ergebnis zu sehen?

Grüße Max
 

Anhänge

Ernst@at

Admiral
Dabei seit
Apr. 2008
Beiträge
7.918
wenn bei allen Partitions Boot Sector=OK /Backup BS=OK angezeigt wird, brauchst Du nur ein "WRITE" zu Deinem Glück, um die Partitioninformationen in den MBR zurückzuschreiben

Vielleicht findet er die Systempartition ja noch mit "Deeper Search"... Schon probiert?
Jetzt ist aber die letzte primäre(hinter der Erweiterten) als Active (*) Bootpartition eingetragen
 
Zuletzt bearbeitet:

KlarMax

Newbie
Ersteller dieses Themas
Dabei seit
Mai 2010
Beiträge
3
Ok, das war's.

Klasse Tool, bin echt beindruckt ...

Auf dich und die Macher von TestDisk :schluck:
Ergänzung ()

P.S.

Natürlich hab ich auch noch einen "Deeper Search" gemacht. Die Partitionen am Ende der Festplatte sind die Überreste von mehreren ehemaligen Betriebssystemen. Sowas brauch ich manchmal zum testen.

Interessant ist, dass das vierte Laufwerk hier als "deleted" erscheint, während es bei "Quick Search" noch "logical" war.

Die eigenliche System-Partition vor der erweiterten ist anscheinend im Nirwana verschwunden. Schon irgendwie komisch...
 

Anhänge

Ernst@at

Admiral
Dabei seit
Apr. 2008
Beiträge
7.918
Wenn da was wichtiges draufstand, schau mal mit GetDataBack, ob da überhaupt noch Dateien drauf zu finden sind von der ersten Primären Partition. Wenn das allerdings die war, welche Du mit Acronis ohnehin restoren wolltest, dann kannst Du die einfach in der Datenträgerverwaltung anlegen und aktiv setzten und dann nochmal restoren
 
Zuletzt bearbeitet:
Top