TV Streaming im (W)LAN und Aufnahmen lokal mit tw. heftigen Artefakten und Stocken

conf_t

Rear Admiral
Dabei seit
Juni 2008
Beiträge
5.881
Hallo,

ich habe Probleme mit meinem TV-Server. In meinen Augen ein reines Softwareproblem.

Cut the long story short: Nach Windows Neuinstallation besser, aber noch lange nicht gut.

System:
Prozessor: Intel Core i7 6700
MainBoard: Fujitsu D3400-B1, BIOS 1.29 (inkl. aller bis Ende 2019 verfügbaren Intel Patches / Microcode-Updates für Skylake),
RAM: 16384 MB Crucial DDR4 2133
Grafikkarte: Intel(R) HD Graphics 530
Sound: Realtek ALC671
Netzwerk Realtek RTL8111G
Laufwerk: OCZ AMD Radeon R7 SSD 480GB
Tuner: PCTV 461e DVB-S
Software: bis vor 2 Wochen DVBLink, nun TVMosaic (mehr oder weniger das gleiche) und zum Test PCTV TVCenter, Windows 10 1909 / 2004



Das System läuft so seit 2016 mehr oder weniger non Stop und hat in dem Zeitraum nach dem Lösen von Kinderkrankheiten einwandfrei funktioniert. Windows 10 hat sich wie gewohnt halbjährlich von selbst auf eine neue Version gehoben und alles war in Butter. Ganz am Anfang hatte ich Probleme mit Stocken und Artefaktbildung beim Schauen, was ich durch den Hinweis in irgendeinem Forum, den VLC im Hintergrund auf dem TV-Server geöffnet zu lassen, behoben habe, war 2016/2017 immer wieder reproduzierbar, seit dem habe ich das einfach so gelassen. Seit dem startete der TV-Server Windows immer mit VLC im Autostart und es gab keine Probleme. Außer für TV Streaming/Recording und Film Bearbeitung wird mit dem Gerät nichts gemacht. Zugriff erfolgt per RDP. Zusammenstellung basiert auf einem Bauvorschlag der c't für besonders sparsame Systeme.

Im Juni habe ich lange nicht ferngesehen / aufgenommen, aber von einem Mal auf das andere Mal war eine massive Artefaktbildung und Stocken vorhanden.

Am Streaming im Netzwerk auf ein Endgerät lag es nicht, weil Aufnahmen genauso betroffen waren (Gerät wird primär als PVR genutzt).
Am DVB-S Singal liegt es nicht, da das Logging dazu keinen Hinweis gibt und anderer Gerät im Haushalt auch keine Probleme haben. An DVB-Link kag es nicht, da ich mit 2 anderen TV Software (PCTV TV Center und irgendwas kostenloses von Heise.de) die gleichen Probleme hatte bei Aufnahmen und Live-TV.

Mir war als letzte Änderung das Update 2004 in Erinnerung gewesen. Also da habe ich auf Verdacht Windows 10 1909 neu installiert und siehe da, es wurde viel besser. Leider habe ich noch immer sporadisch die Hänger und Artefaktbildung bei Aufnahmen oder Streaming. Auch hier sowohl bei PCTV als auch TVMosaic Das Log von TVMosaic hat keine Log-Meldungen zu den Zeiten, wo ich die Probleme feststelle. Das Ausführen von VLC im Hintergrund spielt keine Rolle mehr.

Die Hardware ist bei weitem für Aufnahmen flott genug und für Streaming (auch mit Transcoding) auch. Ich habe von allem die imho aktuellsten Treiber installiert.
Ich hatte die Idee, dass DPC Latency Checker vielleicht Aufschluss geben könnte und in der Tat habe ich i.d.R. eine Latenz von rund 1100µs mit selten aber wiederkehrend Spikes auf 4000-5000 µs. Zum Eingrenzen habe ich nacheinander die Netzwerkkarte, die Audio-Controller (Intel+Realtek), den TV-Tuner, den USB3-Controller deaktiviert, ohne Veränderung.

F
1596358115588.png


Meine Frage nun
a) bin mit einem vermuteten Zusammenhang zu den vom DPC-Latency Checker ausgelesenen Latenzen und den dauerhaft erhöhten Latenten von über 1000 µs auf dem Holzweg oder nicht?

b) wie kann man noch herausfinden, woran das Problem liegt?

Treiberversionen, die neuesten, die ich gefunden habe:
Intel Display Audio 10.26.0.9
Realtek Audio 6.0.8924.1
HD530 27.20.100.8336
H110 S-ATA: 17.7.0.1006
Chipset: 10.1.18383.8213
Realtek NIC: 10.42.526.2020
USB3: 10.0.18362.900
PCTV 461e: 5.2013.1206.0
 
Zuletzt bearbeitet:

hantelfix

Commander
Dabei seit
Feb. 2008
Beiträge
2.511
es reicht wenn ein nachbarn einen wlan router hinstellt
und hast wlan kanal problemm und kein Software problem


wenn der nachbar wlan benutzt auf selben kanal wie du



mal lan kabel testen ob der fehler besteht
 

conf_t

Rear Admiral
Ersteller dieses Themas
Dabei seit
Juni 2008
Beiträge
5.881
😟Bitte nicht nur antworten, sondern auch lesen, wenigstens die Überschrift. Die Antwort ist ja legendär... ich dachte ich wäre deutlich genug geworden.
TV Streaming im (W)LAN und Aufnahmen lokal mit tw. heftigen Artefakten und Stocken
Am Streaming im Netzwerk auf ein Endgerät lag es nicht, weil Aufnahmen genauso betroffen waren (Gerät wird primär als PVR genutzt).
d.h. die Aufnahme wird lokal abgelegt - nix WLAN und nicht umsonst habe ich das W in Klammern gesetzt, weil es auch bei LAN zutrifft. Alle unten in der Signatur gelisteten Geräte Arbeiten per LAN und von dort aus kann ich das wunderbar auch über das LAN testen, auch wenn der Usecase normalerweise für das Streaming eher Smartphones und Tablets vorsieht.

Und ich kann mir die erstellten .TS Files auch auf einen anderen PC ziehen, lokal abspielen und immer an der gleichen Stelle die gleichen Probleme. Gerade bei Aufnahmen habe ich vielleicht mal 1-3 Fehler in 1h Film und dann mal wieder viele Minuten am Stück nur Probleme, also so, dass die Aufnahme unbrauchbar ist.
 
Zuletzt bearbeitet:
Top