Visual C++, alle Versionen nötig?

hijacked

Lieutenant
Dabei seit
Feb. 2012
Beiträge
545
Hallo,

habe einige Versionen von C++ auf dem PC. Welche davon brauche ich, bzw. brauche ich die 2008er noch wenn ich bereits die nachfolgenden habe? Davor hatte ich noch 2005 drauf, das habe ich aber deinstalliert.



MfG -fReEsTyLe-
 

BlubbsDE

Fleet Admiral
Dabei seit
Juni 2011
Beiträge
41.662
Kurze Antwort. Ja.

Und das ist nicht Visual C++, das sind lediglich die Visual C++ Runtimes.
 

MagicAndre1981

Admiral
Dabei seit
Feb. 2004
Beiträge
7.456
ja die brauchst du. Sie werden nebeneinander im WinSxS Ordner installiert und die Programme suchen sich die Version heraus die sie benötigen.
 

Gleipnir

Captain
Dabei seit
Apr. 2012
Beiträge
3.840
Er sollte es in Ruhe lassen, da diese Pakete vom Treibern/Software mitinstalliert werden und die auch nur mit der mitgebrachten Version funktionieren. Ob aber wirklich alle noch aktiv genutzt werden kannst du aber nicht sagen.
 

Randy89

Captain
Dabei seit
Mai 2013
Beiträge
3.287
Wenn du Fehlermeldungen bezüglich "x.dll fehlt" beim Starten eines Programms bekommst, würde ich es entweder mit der Neuinstallation oder mit der Installation der noch nicht vorhandenen Visual C++ Versionen ab 2005 SP1 versuchen.
http://search.microsoft.com/de-de/DownloadResults.aspx?q=visual%20c%2b%2b%20redistributable%20package&first=1&FORM=PEME
Abgesehen davon sind von 2005 SP1 bis 2012 in x86 und in x64 Ausstattung grad mal etwas über 100MB belegt. Ein kleiner Preis, um seine Ruhe vor "x.dll-fehlt" Fehlermeldungen zu haben. ;)
 

Gleipnir

Captain
Dabei seit
Apr. 2012
Beiträge
3.840
auf den Link würde ich mich aber dann doch nicht 100%ig verlassen, hatte damals fast 20 Runtimes, 2x die 2010er (x64/x86) der Rest waren Unterschiedliche (x64/x86) 2005/2008er Versionen
 

Randy89

Captain
Dabei seit
Mai 2013
Beiträge
3.287
Wahrscheinlich noch einmal mit SP1 und einmal ohne? Wenn ja, kann es doch sein, dass einige Anwendungen ihr eigenes "Süppchen" kochen und ihre eigene "Version" installieren. :p
 

Gleipnir

Captain
Dabei seit
Apr. 2012
Beiträge
3.840
die Anwendungen aus der Zeit laufen wohl so wie die Javabasierende Lernplattform damals bei meinem Praktikumsbetrieb, das Mistding funktionierte nur richtig wenn eine ganz bestimmte 1.4er Version installiert war, bei anderen/neueren 1.4er gab es Abstürze und Fehler (dabei war zu dem Zeitpunkt schon v6 aktuell).
 
Top