Win 7 und AHCI + Win 7 mit SSD (instal)

cr4zyiv4n

Captain
Registriert
Nov. 2007
Beiträge
3.747
Servus.

Ich wollte gerad meine SSD Vertex 2 mit dem 1.23 FW update bespielen. Dazu habe ich meine aktuele Win 7 64 bit Version verwendet (ist auf meiner samsung sata hdd instaliert)

Habe das FW Update geladen und es als Admin aufgeführt. Nach einem automatischem Neustart war die SSD aber immer noch auf 1.22. Dann habe ich im Guide gelesen das es daran liegt das mein Sysem evtl. nicht auf AHCI läuft. Und dem ist in der Tat so.

ALso ab ins Bios und AHCI eingestellt. Wenn ich jetzt allerdings mein Rechner hochfahren will klappt das nicht... warum? LIegt es daran das ich mein OS OHNE AHCI instaliert habe und das jetzt nicht quasie on the fly wechseln kann?

Wie kann ich dann am besten meine SSD Flashen? Direkt nach dem Win 7 frisch drauf ist ?


Und eine Frage habe ich noch... SSD = Tempo... aber meine WIn 7 Instalation läuft schon über 20 Minuten und ich bin erst kurz nach der Stelle, wo man sich aussuchen kann auf welche Partition / Platte das OS aufgespielt wird. Warum ist das mit einer SSD so langsam (damals mit der hdd war es auch schon soo lahm)

Zusätzlich dreht irgend ein (oder mehrer) Lüfter auf 100% seit dem ich die Instalation gestartet habe bzw seit dem ich den AHCP Modus angemacht habe, is das normal?
 
Zuletzt bearbeitet:
Zu deiner Frage mit der Schnelligkeit.
Die Daten werden von einer DVD gelesen, das heißt das einzige was hier limitert ist dein DVD-Laufwerk. (Vorerst wird nur von DVD in RAM geladen, hat nichts mit der verwendeten Platte zu tun.)

Edit: Lüfterfrage:
Ich denke nicht, dass bei der Installation auch eine Lüftersteurung geladen wird. Da werden einfach alle Lüfter aufgedreht, damit ja nichts schief geht ;) Wäre zumindest logisch..
 
Zuletzt bearbeitet: (Zweite Frage beantwortet)
Aber AHCI stell ich doch lediglich im Bios ein. Was muss da denn noch instaliert werden ? Wenn ich den Rechner an machen steht da auch immer "AHCI Drive Init ..." sollte eigentlich Hardwarseitig alles gegeben sein für den AHCI Betrieb.

Und fürs flashen der SSD gibts auf der Homepage doch extra ein Tool mit dem man das macht. Da steht nix von DOS
 
ich würde es anders machen: mit der samsung sata hdd windows booten (ahci modus) und dann mit dem tool von ocz die ssd flashen.
 
Zuletzt bearbeitet:
cr4zyiv4n schrieb:
Und fürs flashen der SSD gibts auf der Homepage doch extra ein Tool mit dem man das macht. Da steht nix von DOS

glaub doch einfach das du eine SSD nicht im laufenden Betrieb unter Windows flashen kannst. ;)

Das Lüfterverhalten ist normal beim OS Installationsvorgang.
 
Befolge das hier:

To resolve this issue, enable the AHCI driver in the registry before you change the SATA mode of the boot drive. To do this, follow these steps:

1. Exit all Windows-based programs.
2. Click Start, type regedit in the Start Search box, and then press ENTER.
3. If you receive the User Account Control dialog box, click Continue.
4. Locate and then click the following registry subkey:

HKEY_LOCAL_MACHINESystemCurrentControlSetServicesMsahci
5. In the right pane, right-click Start in the Name column, and then click Modify.
6. In the Value data box, type 0, and then click OK.
7. On the File menu, click Exit to close Registry Editor.

After this you’ll have to restart your computer, go to BIOS and enable AHCI. When you log in to Windows again, you’ll notice the installation of drivers for AHCI. Another restart will be required to finish the driver installation.
 
AHCI erklärt

Der Wechsel von IDE/RAID auf AHCI ist nicht ganz einfach, oftmals ist eine neuinstallation vom OS einfacher/schneller. AHCI und "non-AHCI" ist wie Spanisch und Rumänisch, beides romanische Sprachen, aber der eine versteht vom anderen nix.

Und das die Win7 64bit installation teilweise ewigkeiten braucht, ist nix neues, das ist schon seit der RC1 so ^^

Ich hab auch mal auf meinem System Win7 64bit und meiner Freundin Win7 32bit nahezu zeitgleich installiert ... die 32bit Version war wesentlich früher fertig, obwohl die 64bit Maschine quasi die 4-8 fache leistung (i7 940+12GB Ram+SLC-SSD+MLC-SSD) wie die 32bit Maschine hatte (Athlon64+2GB Ram+HDD), also keine Panik ;)

greez
 
cr4zyiv4n schrieb:
Servus.

Und eine Frage habe ich noch... SSD = Tempo... aber meine WIn 7 Instalation läuft schon über 20 Minuten und ich bin erst kurz nach der Stelle, wo man sich aussuchen kann auf welche Partition / Platte das OS aufgespielt wird. Warum ist das mit einer SSD so langsam (damals mit der hdd war es auch schon soo lahm)

Bei mir war das Damals auch der Fall. Ich hatte im BIOS das Diskettenlaufwerk enabled aber keines verbaut.
Macht nix sollte man meinen... Aber nach dem deaktivieren war das Problem bei mir gelöst.
 
glaub doch einfach das du eine SSD nicht im laufenden Betrieb unter Windows flashen kannst.

hmmm .. aber irgendwie gings doch :D habe nur die SSD eingebaut, win 7 64 bit drauf. Flash tool gestartet im Win betrieb ... nu ist es von 1.22 -> 1.23 ...

oder meint ihr da ist jetzt was fehlerhaft? (habe es nicht mutwillig gemcht ... nur parallel als ich hier geschrieben habe)
 
Zuletzt bearbeitet:
Hi,

du hast ein Gigabyte Board in deinem Rechner wie ich aus der Signatur sehe.

Also auf ahci umstellen ist ganz einfach.

Du hast ja 6 sata Plätze auf dem Board. Die 5 und die 6 kannst du seperat schalten sprichen hier lässt du es auf ide mode. Steckst deine Windows Festplatte an einen von den beiden. stellst 1-4 auf ahci. Startest dann den Rechner Windows erkennt das Installiert dann den ahci Treiber. Danach Rechner runterfahren. Wieder umstecken, an machen und glücklich sein. So brauchst du kein Eingriff in die Reg machen.

Hab ich mit dem Board schon gemacht funktioniert tadellos ;) :)
 
TheGreatMM schrieb:
glaub doch einfach das du eine SSD nicht im laufenden Betrieb unter Windows flashen kannst. ;)

Das Lüfterverhalten ist normal beim OS Installationsvorgang.


Glaub Du doch einfach, dass Du eine SSD sogar unter Windows flashen kannst, wenn es die Boot-Platte ist.

Zitat aus der "Bedienungsanleitung" für das Sandforce Update Tool meiner XLR8 Plus:

"Overview
The SandForce Update Tool allows users to update flashware on drives operating in a Windows environment. The Update Tool is capable of updating flashware on both boot and secondary drives, and can be skinned for branding purposes."
 
Zurück
Oben