Win 7 und VLC Player Dienst

S

Slave Zero

Gast
Hatte meine VLC Player in Win7 64 als Dienst eingerichtet. Hat auch die ganze Zeit funktioniert. Hab eine DVD zu meiner Dreambox gestreamt mit VLC Plugin. Mitten im Film ist die Verbindung abgerissen und der Dienst in Win7 war abgeschaltet. Normalerweise wird nach einem Neustart Dieser VLC Dienst wieder gestartet. Aber er läßt sich aus heiterem Himmel noch nicht einmal mehr manuell starten. Neuinatallation des Players hat auch nicht geholfen. Weis da jemand was zufällig?
Ergänzung ()

Niemand eine Idee?
 

Inzersdorfer

Vice Admiral
Dabei seit
Juli 2010
Beiträge
6.963
Das Thema ist komplex, ob es eine Lösung deines Problems gibt, ist fraglich.
Sollte nicht doch noch eine elegantere Lösung auftauchen:
empfehle ich dir, einen Wiederherstellungspunkt auszuwählen, der vor diesem Fehler lag.
Es ist möglich, das durch ein Update od. installieren einer Software dieser Fehler "erzeugt" wird.

Hilft das nicht, oder ist kein Wiederherstellungspunkt verfügbar: mit der WindowsDVD eine Reparatur durchführen, bringt das nichts, Win7 neu installieren.

Zur Erläuterung ein Beispiel, warum so ein Fehler auftreten kann:
Die Klasse ServiceBase ruft die Methode OnStop direkt aus dem Befehlshandler Service auf, der im Thread "ScDispatcherLoop" der Datei "Advapi32.dll" definiert ist. Wenn der Thread "ScDispatcherLoop" nach 30 Sekunden nicht bereit ist, einen neuen Dienstbefehl vom Dienststeuerungs-Manager entgegenzunehmen, stellt der Windows-Dienstcontroller eine Zeitüberschreitung für den Dienst fest. Aus diesem Grund wird die genannte Fehlermeldung angezeigt.
 
Zuletzt bearbeitet:

walleflocke

Newbie
Dabei seit
Apr. 2011
Beiträge
1
Hi,
ich habe exakt das gleiche Problem, habe den Dienst als Streaming Client auf meine VU+.
Ich hatte seinerzeit am Mediaplayer von Windows7 rumgefummelt, weil ich noch einen DLNA TV einbinden wollte, danach war Schluss mit lustig.
Sollte also doch jemand eine andere Idee haben als Inzersdorfer ( Danke für Deine Anführungen ! ) dann bitte her damit.

MfG
walleflocke
 
S

Slave Zero

Gast
Hab jetzt ein zwei Tage altes Backup vor dem Ausfall eingespielt und auch wieder alle 23 Windowsupdates gemacht. Das letzte Mal ist es ja während des Streamens auf die DM800 einfach so ausgefallen und hat sich nicht mehr starten lassen.. Hatte nix installiert oder irgendwas anderes gemacht. Im Moment startet der Dienst bei jedem Neustart. Hoffe das es so bleibt. Ich tippe mal auf eine Sicherheitslücke in Windows oder im VLC 110. Irgendwas setzt den Dienst warscheinlich übers Internet außer Kraft.
Ergänzung ()

OK ist mal wieder so weit. Direkt während des Streamen ausgestiegen und läßt sich auch nach Neustart nicht wieder aktivieren. Wenn ich nur wüßte was da los ist. Hab den VLC komplett gelöscht und auch die REG durchsucht. Hab den Dienst gelöscht. Nach Neustart den VLC neu installiert und den Dienst neu erstellt. Nix geht mehr. :heul:
 
Zuletzt bearbeitet:

Ähnliche Themen

Top