Zeitüberschreitung beim Warten auf den Start von smb.service.

jodd2021

Lt. Commander
Registriert
Feb. 2021
Beiträge
1.871
Hallo

Kann mir jemand auf die Sprünge helfen woran es hier scheitert?

Bildschirmfoto_20260929_223148.jpg


systemctl status smb.service gibt das aus:



Code:
[joerg@joerg-nuc-titan ~]$ systemctl status smb.service
× smb.service - Samba SMB Daemon
     Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; preset: disabled)
     Active: failed (Result: exit-code) since Tue 2026-09-29 22:26:14 CEST; 3min 32s ago
 Invocation: 16d62f61a7e24eb8a0d475a70e5457de
       Docs: man:smbd(8)
             man:samba(7)
             man:smb.conf(5)
    Process: 4270 ExecStart=/usr/bin/smbd --foreground --no-process-group $SMBDOPTIONS (code=exited, status=1/FAILURE)
   Main PID: 4270 (code=exited, status=1/FAILURE)
   Mem peak: 3.9M
        CPU: 32ms

Sep 29 22:26:14 joerg-nuc-titan systemd[1]: Starting Samba SMB Daemon...
Sep 29 22:26:14 joerg-nuc-titan systemd[1]: smb.service: Main process exited, code=exited, status=1/FAILURE
Sep 29 22:26:14 joerg-nuc-titan systemd[1]: smb.service: Failed with result 'exit-code'.
Sep 29 22:26:14 joerg-nuc-titan systemd[1]: Failed to start Samba SMB Daemon.
[joerg@joerg-nuc-titan ~]$


und journalctl das:

Code:
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ An ExecStart= process belonging to unit smb.service has exited.
░░
░░ The process' exit code is 'exited' and its exit status is 1.
Sep 29 22:25:14 joerg-nuc-titan systemd[1]: smb.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ The unit smb.service has entered the 'failed' state with result 'exit-code'.
Sep 29 22:25:14 joerg-nuc-titan systemd[1]: Failed to start Samba SMB Daemon.
░░ Subject: A start job for unit smb.service has failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ A start job for unit smb.service has finished with a failure.
░░
░░ The job identifier is 350 and the job result is failed.
Sep 29 22:26:14 joerg-nuc-titan systemd[1]: Starting Samba SMB Daemon...
░░ Subject: A start job for unit smb.service has begun execution
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ A start job for unit smb.service has begun execution.
░░
░░ The job identifier is 4312.
Sep 29 22:26:14 joerg-nuc-titan systemd[1]: smb.service: Main process exited, code=exited, status=1/FAILURE
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ An ExecStart= process belonging to unit smb.service has exited.
░░
░░ The process' exit code is 'exited' and its exit status is 1.
Sep 29 22:26:14 joerg-nuc-titan systemd[1]: smb.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ The unit smb.service has entered the 'failed' state with result 'exit-code'.
Sep 29 22:26:14 joerg-nuc-titan systemd[1]: Failed to start Samba SMB Daemon.
░░ Subject: A start job for unit smb.service has failed
░░ Defined-By: systemd
░░ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
░░
░░ A start job for unit smb.service has finished with a failure.
░░
░░ The job identifier is 4312 and the job result is failed.

Das ist übrigens nicht nur auf den NUC so, das MSI NB mit fast identischen SW Stand macht das selbe.
 
Code:
[joerg@joerg-nuc-titan ~]$ testparm -s
Load smb config files from /etc/samba/smb.conf
Error loading services.
[joerg@joerg-nuc-titan ~]$

und bei
Code:
systemctl start smb -f -i

kommt das gleiche wie oben raus.

/etc/samba/smb.conf gibt es nicht , da ist nur ein leerer Ordner.
 
jodd2021 schrieb:
systemctl start smb -f -i

Das macht keinen Sinn. Was hat systemctl in dem Befehl zu suchen und woher kommt das -f?

Ausführen: smbd -F -i.

jodd2021 schrieb:
/etc/samba/smb.conf gibt es nicht , da ist nur ein leerer Ordner.

Wo liegt die denn dann bei dir? Irgendwo muss die Config ja sein?
Ergänzung ()

Und natürlich solltest du hier mit sudo arbeiten.
 
Zuletzt bearbeitet:
Code:
[joerg@joerg-nuc-titan ~]$ smbd -F -i
Can't load /etc/samba/smb.conf - run testparm to debug it
smbd - Failed to load config file!
[joerg@joerg-nuc-titan ~]$

Irgendwo muss die Config ja sein?

Bildschirmfoto_20260930_000347.jpg
 
Log sagt 100 mal:

smbd - Failed to load config file!
Can't load /etc/samba/smb.conf - run testparm to debug it
 
CoMo schrieb:
Du musst eine smb.conf erstellen.

Gemacht. Soll da etwas drin stehen?
Ergänzung ()

Das ist doch fast schon bösartig:

Bildschirmfoto_20260930_001214.jpg


angelegt.

2.jpg
 
Zuletzt bearbeitet:
Ja klar muss da was drin stehen.
Zumindest die Minimalkonfiguration. @jodd2021
z.B. welcher Nutzer welches Verzeichnis usw.
Oder welches Verzeichnis ueberhaupt geteilt werden soll.
Ergänzung ()

Und das was frei gegeben wwerden soll muss auch vorhanden sein. Das sagt die eine Meldung.
Und man fuegt keine SMB-Nutzer in Gruppen ein in denen root/admin bzw lokale Verzeichnisrechte des Root drin sind. Immer auch dran denken das unter einem Linux die Datei/Verzeichnisrechte granularer sind als bei Windows.

https://www.howtogeek.com/use-samba-on-linux-for-home-network-file-sharing/

Was willst Du ueberhaupt erreichen?
 
Zuletzt bearbeitet:
Ich habe das Thema Samba für mich erst mal begraben, das ist mir viel zu aufregend. Ich hab das ganze jetzt per ftp gemacht.

Danke für eure Hilfe.
 
jodd2021 schrieb:
Ich habe das Thema Samba für mich erst mal begraben, das ist mir viel zu aufregend. Ich hab das ganze jetzt per ftp gemacht.

Danke für eure Hilfe.
Würde mich aber nicht in Ruhe lassen wenn es nicht funktioniert. Erstelle doch einfach mal eine Conf Datei. Im Netz gibt es genug Beispiele...
 
Am besten probierst du es erstmal nur über das Terminal und mountest dann das Sambashare über /etc/fstab Dolphin und co. haben da manchmal ihre Eigenheiten.


Code:
# /etc/samba/smb.conf

[global]
#to allow symlinks from everywhere
allow insecure wide links = yes
workgroup = WORKGROUP
dos charset = cp866
unix charset = utf-8
force user = jodd2021

[storage]
# to follow symlinks
follow symlinks = yes
# to allow symlinks from outside
wide links = yes    
browseable = yes
writeable = yes
path = /media/storage

Dann noch einen smbuser erstellen.

Code:
# adduser jodd2021
# smbpasswd -a jodd2021


Code:
# /etc/fstab

//192.168.178.2 /media/storage cifs username=Jodd2021,password=yourpassword 0 0

Im terminal dann mount -a als root.

https://wiki.archlinux.org/title/Samba
 
Zuletzt bearbeitet:
Gibt doch bestimmt auch vorkonfigurierte Vorlagen/Plugins etc. (Dolphin/Thunar/Nautilus/Nemo/PCManFM Addons?), die einem die Arbeit abnehmen, so dass man nicht selbst in der .conf Datei fummeln muss. OpenWrt z.B. macht das so. Das müssen doch die großen Distributionen erst recht mitbringen.
 
Die beiden EndeavourOS Systeme sind die ersten wo solche Probleme mit Samba aufgetreten sind. Wenn mal Ruhe und Zeit ist, fange ich damit noch mal ganz von vorne an.
 
  • Gefällt mir
Reaktionen: jodd2021
Zurück
Oben