Bild ist unruhig bei Xubuntu 16.04

Hunky

Lt. Commander
Registriert
März 2005
Beiträge
1.334
Moin, ich habe das Problem, das mein Monitorbild teils so unruhig ist/wird - gerade was das scrollen im Browser angeht.

https://www.youtube.com/watch?v=zFbJdt9neq8&feature=youtu.be

Man kann es ganz gut bei 0,02 (Bitte in Vollbild und Full HD) sehen, wenn die Sprünge/Hzbrüche? kommen. Hat jemand eine Idee was man da machen kann/soll? Bei Windows7 ist mir sowas noch nicht aufgefallen.

System: Intel Xeon e3 1231, Geforce 660 (Treiber 361,42 ist installiert), 8gb Ram und Monitor ist der Iiyama Pl2481H per Dvi.

Danke!
 

Anhänge

  • Bildschirmfoto_2016-07-13_14-20-39.png
    Bildschirmfoto_2016-07-13_14-20-39.png
    121 KB · Aufrufe: 344
  • Bildschirmfoto_2016-07-13_14-20-00.png
    Bildschirmfoto_2016-07-13_14-20-00.png
    113,8 KB · Aufrufe: 349
Nennt sich Tearing. Macht er gerne mit dem NVidiatreiber. Mit dem Nouveautreiber läuft das Bild geschmeidig. Kann auch an XFCE liegen, unter Unity keine Probleme.
 
StefanA schrieb:
Nennt sich Tearing. Macht er gerne mit dem NVidiatreiber. Mit dem Nouveautreiber läuft das Bild geschmeidig. Kann auch an XFCE liegen, unter Unity keine Probleme.

Hatte auch schon an Tearing gedacht, wollte aber eine Expertenmeinung hören :). Beim Nouveatreiber starten meine Spiele nicht :(.
 
Es geht auch extrem auf die Augen, weil es ja ständig aktiv ist (auch wenn das Bild nicht bewegt wird). Ubuntu wollte ich eigentlich nicht installieren, weil ich Unity nicht mag und es auch mehr Speicher frisst ;/

edit: schnell mal einen Ubuntu Mate Bootstick erstellt und getestet: Das selbe Problem :/. Auch war der Standard-Treiber aktiv.
 

Anhänge

  • Screenshot at 2016-07-13 14:06:44.png
    Screenshot at 2016-07-13 14:06:44.png
    253,1 KB · Aufrufe: 335
Zuletzt bearbeitet:
Bin ich der einzige, der auf dem Video kein Problem erkennen kann? YouTube lässt mich aber auch nur 720p auswählen.
Außerdem frage ich mich, inwieweit Tearing, falls es denn das Problem sein sollte, bei Standbildern auf die Augen gehen kann. Würde dazu gerne noch mal ein paar Meinungen hören. Eigentlich baut sich da doch nichts mehr neu auf. Oder doch?
 
Ist leider ein Problem des proprietären Nvidia-Linux-Treiber. Passiert unabhängig von der DE oder Distribution. Vielleicht hilft dir das.
 
computerfrust schrieb:
Bin ich der einzige, der auf dem Video kein Problem erkennen kann? YouTube lässt mich aber auch nur 720p auswählen.
Außerdem frage ich mich, inwieweit Tearing, falls es denn das Problem sein sollte, bei Standbildern auf die Augen gehen kann. Würde dazu gerne noch mal ein paar Meinungen hören. Eigentlich baut sich da doch nichts mehr neu auf. Oder doch?

Musst du ganz genau hinschauen. Ansonsten im Anhang ein Bild wo es auftritt. Es stört halt sehr, und die Augen müssen sich mehr anstrengen - jedenfalls geht es mir so.

@schlunzi: Aber Nvidia könnte das doch fixen? Oder liegt der Hund woanders begraben? Danke, ich schau mal
 

Anhänge

  • teaing.png
    teaing.png
    316,1 KB · Aufrufe: 345
Zuletzt bearbeitet:
OK, auf dem Screenshot kann man das Tearing gut erkennen. Dennoch darf es bei Standbildern eigentlich nicht auftreten. Das wäre meiner Meinung nach ein anderes Phänomen. Wenn die Augen bei Standbildern wehtun, dann würde ich als erstes im Treiber Temporal Dithering abstellen. Manchmal ist das (sinnloserweise) per Default aktiviert.
Ergänzung ()

Ich würde auch das hier mal ausprobieren (Mauszeiger):
image.jpg
 
so, jetzt startet die Oberfläche nicht mehr, nachdem ich die Config, wie im Artikel, bearbeitet habe :/

ESC habe ich beim Starten auch schon gedrückt, und geschaut ob man es reparieren kann. Aber da kommt nichts :/
 

Anhänge

  • 20160713_194349.jpg
    20160713_194349.jpg
    1,6 MB · Aufrufe: 358
  • 20160713_194354.jpg
    20160713_194354.jpg
    1,4 MB · Aufrufe: 328
Doch, das kann man in Textmodus reparieren. Ich denke mal, der Editor nano ist vorinstalliert. Einloggen, dann einfach "sudo nano /etc/X11/xorg.conf" eingeben and die Änderungen rückgängig machen. Speichern mit Strg-x.
 
MERCI! Konnte erfolgreich booten, auch wenn der Fehler immer noch da ist.
 

Anhänge

  • maus.png
    maus.png
    59,6 KB · Aufrufe: 329
Zuletzt bearbeitet:
Das liegt an der Desktopoberfläche!! Ich habe etliche Distros ausprobiert und nur unter Unity lief das vernünftig. Musst dann halt immer den Treiber umschalten, je nachdem was du machen möchtest (Spielen oder alles andere), geht über die Nvidiasettings. Evtl. noch bumblebee ausprobieren.
ps. Unter debian-Testing mit Mate ging es auch, allerdings wieder nur mit dem Nouveautreiber
 
Denke auch, ich würde einfach mal den Nouveau-Treiber testen. Hat auch den netten Nebeneffekt einer High-Res-Konsole.

Radikalkur, wenn gar nichts mehr übrigbleibt, wäre Grafikkarte rausnehmen und nur noch auf Intel-Treiber zu setzen. Hab ich aus anderen Gründen auch so gemacht - auf einmal kein Tearing mehr unter Xfce. Inteltreiber haben dafür eine spezielle Option.
Wobei das jetzt wohl nicht wirklich weiterhilft, und ich weiß auch nicht, ob der Xeon überhaupt eine Grafikeinheit hat.
 
Danke für den "panning and tearing test",

hab ich so nicht (mehr ?)


Installier einmal nvidia-settings

geh auf OpenGL Settings -> Sync to VBlank

ich hab bei mir momentan auch xfwm4 laufen (ohne compositing),


alternativ kannst du ja einmal compiz installieren und schauen, ob es mit einem voll beschleunigten Desktop besser wird + VSync aktiviert
 
Habe hier eine GTX560Ti mit dem proprietären Treiber und Compiz am Laufen und wohl auch Tearing (habe mich aber wohl schon so sehr dran gewöhnt, dass es mir nicht auffällt). Habe gerade mal Sync to VBlank aktiviert und es scheint tatsächlich besser geworden zu sein!
 
Habe Ubuntu 16.04 Unity installiert und siehe da: das Problem tritt kaum bis gar nicht auf (0,20 sieht man ein bisschen was).

https://www.youtube.com/watch?v=ODJh3jVT8Yc&feature=youtu.be

Werde jetzt mal den xfce Desktop installieren und schauen, ob der Fehler reproduzierbar ist.
Ergänzung ()

So wieder da. Der Fehler ist unter Xubuntu (sowieso als Oberfläche für Ubuntu), Linux Mint (Mate), Ubuntu Mate reproduzierbar. Dagegen ist er bei Ubuntu Unity und Linux Mint Cinnamon sehr selten bis gar nicht vorhanden - Benutzt wird der nvidia 361.42 Treiber und die 64 Bit Version.

Sehr schade, aber jetzt bleibt nur noch die Wahl zwischen den Beiden Versionen. Danke für die Hilfe! Falls jemand noch eine Idee hat, bitte melden.
 
Na die Idee ist ja sehr einfach: Nutze Xfce mit Compiz (bzw. vielleicht reicht ja schon das eingebaute Compositing des Xfwm). Hier hat das Aktivieren von Sync to VBlanc unter Xfce+Compiz dem Tearing ein Ende bereitet. Mit Unity hat das Problem also nichts zu tun, nur mit dem von Unity verwendeten Compiz.
 
Zurück
Oben