D-Link DWL650 - geht, aber braucht immer Nachhilfe

Michael

Re-aktions-Pinguin
Dabei seit
Okt. 2002
Beiträge
3.211
So, habe nun nach Marcels Anleitung meine neue DWL-G650 PCMCIA-WLAN-Karte zum Laufen gebracht.
Blöderweise übernimmt er aber keinen der "iwconfig ..." Werte. Die muss ich nun immer per Hand eingeben und das nervt.
Ich habe zwar ein Skript geschrieben, welches beim Booten ausgeführt wird, um mir die Arbeit abzunehmen. Das startet aber (weiß der Henker warum) immer erst NACH portmap. Sprich: keine automatischen Netzwerkmappings mehr möglich.

hier der Inhalt meiner /etc/pcmcia/wireless.opts:
Code:
case "*" in
*,*,*,*)

    INFO="ESSID"
    ESSID="meineESSID - die stimmt auch"
    MODE="managed"
    KEY="naebenmeinkey - der stimmt auch"
    CHANNEL="6"
    RATE="auto"
    ;;

esac
Den Punkt "case" verstehe ich noch nicht ganz.
Ich denke mal, der Fehler liegt hier irgendwo, da ansonsten alles wunderbar geht. Jemand eine Idee?
 

marcelcedric

Commodore
Dabei seit
Mai 2003
Beiträge
4.342

Michael

Re-aktions-Pinguin
Ersteller dieses Themas
Dabei seit
Okt. 2002
Beiträge
3.211
Mit anderen Worten, wa in der /etc/pcmcia/wireless.opts steht, ist völlig belanglos, weil es eh nicht funktioniert? OK. Mit meinem skript gehts ja auch.
Blöderweise startet portmap immer noch vor meinem Skript, obwohl es nun erst "99" starten soll. Liegt wohl daran, dass in meiner /etc/fstab ein paar NFS-Mappings stehen.

K10dlink-skript
K35nfs-common
K99portmap

Muss ich nun meine Mappings (nfs-mounts) auch in ein eigenes Skript packen, und es von der /etc/fstab lösen? Das wäre sehr schade.
 

Michael

Re-aktions-Pinguin
Ersteller dieses Themas
Dabei seit
Okt. 2002
Beiträge
3.211
Zitat von marcelcedric:
Dann pass doch die /etc/network/interfaces an?

mfg
dies ist meine (die nicht funktioniert, was wireless angeht):
Code:
auto lo ath0
iface ath0 inet static
        address 192.168.1.94
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
        gateway 192.168.1.1
        wireless_key "s:meinkey"
        wireless_essid meine_essid
        wireless_channel 6
        wireless_mode managed
Also IP usw. werden vergeben, aber beim Booten kommt ne Meldung a la "function not bla bla" oder so. Geht leider so schnell, dass ich es nie zuende lesen kann :D
 

marcelcedric

Commodore
Dabei seit
Mai 2003
Beiträge
4.342
Zitat von Michael:
dies ist meine (die nicht funktioniert, was wireless angeht):
Code:
auto lo ath0
iface ath0 inet static
        address 192.168.1.94
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
        gateway 192.168.1.1
        wireless_key "s:meinkey"
        wireless_essid meine_essid
        wireless_channel 6
        wireless_mode managed
Also IP usw. werden vergeben, aber beim Booten kommt ne Meldung a la "function not bla bla" oder so. Geht leider so schnell, dass ich es nie zuende lesen kann :D
dmesg hilft

mfg
 

Michael

Re-aktions-Pinguin
Ersteller dieses Themas
Dabei seit
Okt. 2002
Beiträge
3.211
Gelöst! Re: D-Link DWL650 - geht, aber braucht immer Nachhilfe

Problem gelöst!
Wie es aussieht, ist die Reihenfolge und Art der Werte und Befehle in /etc/network/interfaces entscheidend. Meine alte Konfiguration steht oben. Hier nun die, die auch ohne zusätzliche Skripte funktioniert!
Code:
iface lo inet loopback

auto lo ath0
iface ath0 inet static
        wireless_essid meine_essid
        wireless_mode managed
        wireless_rate 54Mb
        wireless_channel 6
        wireless_key meinkey
        address 192.168.1.94
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
Knackpunkt ist zum Einen, dass man keine " " verwenden darf. Zum Anderen scheint die Reihenfolge eine Rolle zu spielen. Auch darf beim Key (ich verwende WEP) kein "s:" davor stehen, wie man es oft in Tutorials oder How-Tos findet.
Desweiteren müssen beim System-Start schon die Module mitgeladen werden. Hierzu habe ich folgende Modules in meine /etc/modules hinzugefügt:
Code:
ath_hal
wlan
wlan_wep
So habe ich es gemacht, und es funktioniert. Durch die verschiedenen Treiber-Versionen, die im Laufe der Zeit das Licht der Welt erblicken, sind ggf. bestimmte Parameter von Nöten. Weshalb man in manchen Tutorials un HowTos andere Werte und Parameter findet. Ich habe für die MadWifi-Treiber die Version "1.30 2005/02/22 14:17:19" verwendet.

Lasse ich den Parameter "wireless_rate 54Mb" weg, bekomme ich nur 33Mb spendiert. Durch die schlechte Übertragungsqualität (30%) macht das aber auch nichts - die Geschwindigkeit beim Kopieren einer 50MB-Datei ist gleich - etwas über 3 Megabyte pro Sekunde.
 

marcelcedric

Commodore
Dabei seit
Mai 2003
Beiträge
4.342
Re: Gelöst! Re: D-Link DWL650 - geht, aber braucht immer Nachhilfe

Zitat von Michael:
Problem gelöst!
Wie es aussieht, ist die Reihenfolge und Art der Werte und Befehle in /etc/network/interfaces entscheidend. Meine alte Konfiguration steht oben. Hier nun die, die auch ohne zusätzliche Skripte funktioniert!
Code:
iface lo inet loopback

auto lo ath0
iface ath0 inet static
        wireless_essid meine_essid
        wireless_mode managed
        wireless_rate 54Mb
        wireless_channel 6
        wireless_key meinkey
        address 192.168.1.94
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
Knackpunkt ist zum Einen, dass man keine " " verwenden darf. Zum Anderen scheint die Reihenfolge eine Rolle zu spielen. Auch darf beim Key (ich verwende WEP) kein "s:" davor stehen, wie man es oft in Tutorials oder How-Tos findet.
Desweiteren müssen beim System-Start schon die Module mitgeladen werden. Hierzu habe ich folgende Modules in meine /etc/modules hinzugefügt:
Code:
ath_hal
wlan
wlan_wep
So habe ich es gemacht, und es funktioniert. Durch die verschiedenen Treiber-Versionen, die im Laufe der Zeit das Licht der Welt erblicken, sind ggf. bestimmte Parameter von Nöten. Weshalb man in manchen Tutorials un HowTos andere Werte und Parameter findet. Ich habe für die MadWifi-Treiber die Version "1.30 2005/02/22 14:17:19" verwendet.

Lasse ich den Parameter "wireless_rate 54Mb" weg, bekomme ich nur 33Mb spendiert. Durch die schlechte Übertragungsqualität (30%) macht das aber auch nichts - die Geschwindigkeit beim Kopieren einer 50MB-Datei ist gleich - etwas über 3 Megabyte pro Sekunde.
Danke, ich werde mein HowTo mal anpassen. ;-)

mfg
 
Top