Fedora 12 64bit, Synology DS210j & NFS

Nobody2311

Ensign
Dabei seit
Jan. 2008
Beiträge
211
Hallo

Ich möchte den root von volume1 in /mnt/Volume1 einhängen, doch das bricht mit einem Fehler ab.
Meldung:
mount.nfs: an incorrect mount option was specified

Mein Versuch:
mount -t nfs 192.168.1.125:/Volume1 /mnt/Volume1 -o user=Downloaduser,password=******

Was mach ich falsch?

Gruss
nobody23
 

Nobody2311

Ensign
Ersteller dieses Themas
Dabei seit
Jan. 2008
Beiträge
211
Hallo

NTFS ist das Filesystem von Windows
NFS heisst soviel wie Network File System und wird hauptsächlich von Linux unterstützt.

Gruss
Nobody
 

Nobody2311

Ensign
Ersteller dieses Themas
Dabei seit
Jan. 2008
Beiträge
211
Wegen Port?

Spann mich bitte nicht auf die Folter, dass mit NFS ist schon ein 2-Tages Ärgernis...

Gruss
Nobody23
 

Sug82

Lt. Commander
Dabei seit
Juni 2005
Beiträge
1.754
NFS kennt keine Benutzer und Passwort Authentifizierung, erst bei NFS4 übernimmt hier offiziell Kerberos-Implementierung die Benutzeridentifizierung.

Deswegen steht in deiner 1. Post mount.nfs: an incorrect mount option was specified und wenn du man nfs genauer durchliest (spart sicher die 2 Tage), gibt die von dir angegebenen Optionen unter NFS nicht.
 

Nobody2311

Ensign
Ersteller dieses Themas
Dabei seit
Jan. 2008
Beiträge
211
Mit welchem Befehl, kann ich nun mein NAS mit NFS in Fedora 12 einbinden?

Im Fedora Forum gefunden:
mount -t cifs //192.168.1.xx/share /mnt/share -o user=<username>,password=<passwort>,domain=<DOMAIN>
Bringt mir das was?

Gruss
Nobody2311
 
Zuletzt bearbeitet:

Sug82

Lt. Commander
Dabei seit
Juni 2005
Beiträge
1.754
Das bringt dir nur was, solange wenn du samba share hast.
 
R

resusseleman

Gast
mount -t cifs ... wird dich da nicht weiterbringen, weil "cifs" nen anderes Protokoll ist (unter Klickibunti äh Windows auch als Ordnerfreigabe bekannt).
Was Sug82 wohl eher meinte war, dass du deinen mount-Befehl mal ohne user und password machen sollst, da erst NFS4 was damit anfangen kann.
Und "mount.nfs: an incorrect mount option specified" heißt soviel wie "eine falsche mouns option/parameter angegeben".
 

Nobody2311

Ensign
Ersteller dieses Themas
Dabei seit
Jan. 2008
Beiträge
211
Hab das jetzt versucht
Code:
Befehl:
mount -f -v 192.168.1.125:/volume1 /mnt/volume1

Ausgabe:
mount: kein Typ angegeben – aufgrund des Doppelpunkts wird NFS angenommen
mount.nfs: timeout set for Mon May 24 20:50:08 2010
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 192.168.1.125 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying 192.168.1.125 prog 100005 vers 3 prot UDP port 892
mount.nfs: trying text-based options 'addr=192.168.1.125,vers=3,proto=tcp,mountvers=3,mountproto=udp,mountport=892'
2ter Versuch:
Code:
mount -v 192.168.1.125:/volume1 /mnt/volume1
mount: kein Typ angegeben – aufgrund des Doppelpunkts wird NFS angenommen
mount.nfs: timeout set for Mon May 24 20:52:18 2010
mount.nfs: prog 100003, trying vers=3, prot=6
mount.nfs: trying 192.168.1.125 prog 100003 vers 3 prot TCP port 2049
mount.nfs: prog 100005, trying vers=3, prot=17
mount.nfs: trying 192.168.1.125 prog 100005 vers 3 prot UDP port 892
mount.nfs: trying text-based options 'addr=192.168.1.125,vers=3,proto=tcp,mountvers=3,mountproto=udp,mountport=892'
mount.nfs: mount(2): Permission denied
mount.nfs: access denied by server while mounting 192.168.1.125:/volume1
Gruss
Nobody2311
 
R

resusseleman

Gast
Beim 2. Versuch wird dir der Zugriff verweigert. Hast du auf deiner DS auch die entsprechenden Zugriffsrechte auf Volume1 vergeben?
 

Anhänge

Nobody2311

Ensign
Ersteller dieses Themas
Dabei seit
Jan. 2008
Beiträge
211
Guten Morgen

Es funktioniert soweit, eine einzige Frage ist noch offen.
Wie oder was muss ich machen, damit die gemounteten Ordner auch nach einem Reboot wieder gemountet werden.

Gruss
Nobody
 

Nobody2311

Ensign
Ersteller dieses Themas
Dabei seit
Jan. 2008
Beiträge
211
Hallo Miteinander

Code:
/dev/sdb1               /media/DL                       auto    rw,users,owner,exec,dev,suid,   0 0
192.168.1.125:/volume1/download /mnt/volume1/download   nfs     rw,users,exec,dev,suid,rw       0 0
192.168.1.125:/volume1/video /mnt/volume1/video         nfs     rw,users,exec,dev,suid,rw     0 0
192.168.1.125:/volume1/photo /mnt/volume1/photo         nfs     rw,users,exec,dev,suid,rw     0 0
192.168.1.125:/volume1/music /mnt/volume1/music         nfs     rw,users,exec,dev,suid,rw     0 0
192.168.1.125:/volume1/unpack /mnt/volume1/unpack       nfs     rw,users,exec,dev,suid,rw     0 0
Der Zugriff auf mein NAS funktioniert, aber sobald ich auf sdb1 zugreifen will, wird der Zugriff verweigert.
Die gesammte Partition sdb1 ist als root eingebunden (Besitzer wie Gruppe) und wenn ich als root per chown dem Besitzer ändern will, so wird dies nicht verweigert.
Wie kann ich nun auf meine 2te lokale Festplatte ohne root Rechte zugreifen?

Gruss
Nobody
 

Nobody2311

Ensign
Ersteller dieses Themas
Dabei seit
Jan. 2008
Beiträge
211
Guten Tag

Heute musste ich leider mein Fedora neu aufsetzen, hatte aber vorhin meine fstab gesichert.
Doch leider ging das nicht so leicht wie ich dachte.
Trotzdem kann ich nicht auf die Ordner und Dateien zugreifen.

Einträge fstab:
Code:
192.168.1.125:/volume1/download /mnt/volume1/download   nfs     rw,users,exec,dev,suid,rw       0 0
192.168.1.125:/volume1/video /mnt/volume1/video         nfs     rw,users,exec,dev,suid,rw     0 0
192.168.1.125:/volume1/photo /mnt/volume1/photo         nfs     rw,users,exec,dev,suid,rw     0 0
192.168.1.125:/volume1/music /mnt/volume1/music         nfs     rw,users,exec,dev,suid,rw     0 0
192.168.1.125:/volume1/unpack /mnt/volume1/unpack       nfs     rw,users,exec,dev,suid,rw     0 0
Was mach ich falsch?

Gruss
Nobody2311
 
Zuletzt bearbeitet:
Top