Mainboard: Fujitsu-Siemens D2812 Grafikkarte: Gigabyte Nvidia Geforce 1030 GT und BIOS

KI-Bot

Cadet 1st Year
Dabei seit
Jan. 2021
Beiträge
13
Direkt zur Lösung


Hallo liebe Leute.

Bin eigentlich GNU/Linux Nutzer, die Windows Maschine ist nur für's Gaming.

Fujitsu-Siemens P7935
Auch mit neusten verfügbarsten Treibern bekomme ich die vom Gerätemanager den Code 35 :
"Die Systemfirmware enthält nicht genügend Informationen, um das Gerät richtig zu konfigurieren und zu verwenden. Fordern Sie beim Computerhersteller ein Firmware- oder BIOS-Update an, wenn Sie das Gerät verwenden möchten. (Code 35)"

Siehe auch den Screenshot im Anhang.

Ich bekomme halt nicht die Leistung die ich gewohnt bin von der Karte (hatte die vorher in einem alten Lenovo ThinkCenter).

Hier gibt es die offiziellen BIOS Versionen (JS verseuchte Seite, will auch Cookies, Frames...; -> "Select a new Product", "Product Search" -> p7935 eingeben, "Selected Operating System" Independent wählen und dann auf den Reiter "BIOS"):
https://support.ts.fujitsu.com/IndexDownload.asp?lng=com

Meine BIOS-Version ist:
6.00.1.03 (02/10/2008)
Aktuellste, verfügbare BIOS-Version ist:
6.00.1.19 (05/11/2009)

Es gibt dort mehrere Einträge, die unterschiedliche Dateien liefern.
Über den Eintrag "Flash BIOS Update - Linux Boot Disk" bekommt man lediglich ein shell-script, was vermutlich zum flashen des BIOS über installiertes Linux laufen soll, auf der Maschine ist aber nur Windows installiert.
Desk ist so eine Update-Software für und von Fujitsu, die aber bei mir nicht wirklich zu funktionieren scheint (zeigt nur weißes Bild und beendet dann).
Ich hatte versucht zu flashen, indem ich aus der .exe (bekommt man, wenn man den Eintrag "Flash BIOS Update - USB Stick" auswählt) eine .img extrahiert habe, da ich keine .iso finden konnte, auch nicht in dem zip...
Die Extrahierung habe ich vorgenommen, mit irgendeinem Drittprogramm aus den Tiefen des Internets (würde ich niemals unter Linux tun xD), da ich gelesen habe, dass BIOS flashen mittels Windows Probleme machen kann und ich keinen Bock auf einen Ziegel habe.
Ich hatte zweimal die .img auf einen Stick geschrieben, einmal via dd, wie ich das mit einem .iso machen würde und einmal via cp auf einen vorher unter windows formatierten, bootbaren USB-Stick.
Eine Methode hatte funktioniert, die andere nicht, weiß nicht mehr welche, musste mich in den letzten Tagen um andere Dinge kümmern.
Der Stick wurde im Boot-Menü angezeigt und ich konnte ihn auswählen, aber danach hatte ich nur Schwarzbild mit links oben blinkendem Cursor, habe jedes Mal mehrere Minuten gewartet, aber nichts weiter passierte.
Ich habe schon einmal ein BIOS geflasht, in einem Thinkpad T61 das Stock BIOS mit einem Custom Rom überschrieben (Middleton), hatte super funktioniert, aber das gab es auch als .iso-Datei....
Außerdem mehrere flashes mit libreboot, aber das ist anderes Terrain (wesentlich Nutzerfreundlicher IMHO...).

Momentan steckt in dem Rechner eine Gigabyte Nvidia GeForce 8500 GT (die Gigabyte ist leider dort nicht gelistet), die nach installieren der letzten Treiber für diese Karte optimal funktioniert.
Zwischen der und der 1030 liegen allerdings 10 Jahre...
Auch habe ich eigentlich vor in den Tower eine 1050 GTX Ti (75 Watt) einzubauen, die ich mir allerdings nicht kaufen möchte wenn ich von vornherein ausschließen kann, dass sie funktioniert.

Ok nun meine Windows-Noob-Frage:
Liegt es tatsächlich an dem BIOS?
Mal angenommen ich bekomme das mit dem BIOS-Update noch hin (juhu wieder wegen irgendeinem Lebenszeit fressendem Sche** das Internet durchstöbern!!1!elf!), funktioniert die Karte dann und wenn ja auch eine 1050er?
PCIe ist ja abwärtskompatibel, deshalb dachte ich bisher ich muss lediglich auf die Stromversorgung des Slots (hatte schonmal einen mit maximal 25 Watt [Dell...]), auf's Netzteil und aktuelle OS Treiber achten.
Ich wusste bis dato nicht einmal, dass das BIOS eine Rolle spielt, die Treiber sind doch alle OS (Kernel) seitig, oder?

Herzlichen Dank für eure Aufmerksamkeit.
=)

Direkt zur Lösung
 

Anhänge

  • nvidia_geforce_1030_gt_windows_7_64bit_geraetemanager.png
    nvidia_geforce_1030_gt_windows_7_64bit_geraetemanager.png
    150,5 KB · Aufrufe: 34
Zuletzt bearbeitet:

EDV-Leiter

Lt. Junior Grade
Dabei seit
Juni 2014
Beiträge
310
Mach doch einfach unter Windows das BIOS-Update. Ich hatte bei knapp 150 Rechnern dieser Bauart (verschiedenste Fujitsus der letzten 15 Jahre) nie Probleme mit dem BIOS-Update.
 

KI-Bot

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
Jan. 2021
Beiträge
13
Hallo EDV-Leiter.
Ich hatte halt u.a. das hier gelesen: [P7935]Kann BIOS nicht updaten

Ich frage mich halt auch einfach wo da der Sinn ist, die Unterstützung einer Grafikkarte von 2017 mittels eines BIOS von 2009 zu gewährleisten...
 

puri

Commodore
Dabei seit
Apr. 2011
Beiträge
4.762
Hallo EDV-Leiter.
Ich hatte halt u.a. das hier gelesen: [P7935]Kann BIOS nicht updaten

Ich frage mich halt auch einfach wo da der Sinn ist, die Unterstützung einer Grafikkarte von 2017 mittels eines BIOS von 2009 zu gewährleisten...
Macht schon Sinn, die neueren Karten brauchen oft ein UEFi-fähiges Bios auf dem Motherboard, sonst laufen sie gar nicht ( hatte ich mit Rechnern von 2013 und damals neuesten Quadro- Karten) oder eventuell nur in einem kompatiblen Notlaufmodus..
 

KI-Bot

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
Jan. 2021
Beiträge
13
Hey puri.

Und das neuste für mein Board ist UEFI-fähig?
Wikipedia sagt UEFI gibt es seit 1998.
 

puri

Commodore
Dabei seit
Apr. 2011
Beiträge
4.762
Das kann Dir keiner sagen, aber mit dem neustmöglichen Bios hast Du zumindest bessere Chancen. So richtig durchgesetzt hat sich UEFi nämlich erst in den 2010ern..
 

KI-Bot

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
Jan. 2021
Beiträge
13
Eijeijei... ich vermute mal, weil das alles proprietäres Zeug ist, das keiner einsehen kann?
Gibt es kein Changelog für sowas?
Aber vermutlich gibt es ja auch zig Varianten von ein und derselben BIOS Version, je nach Board?
It's a mess...
Ergänzung ()

Kann ich denn irgendwie herausfinden, welche Karten noch maximal unetrstützt werden ohne BIOS Update?
Ich hab echt schiss mir das Board "kaputt" zu machen (kaputt in quotes, da wenn der ganze Kram quelloffen wäre es immer einen Rettungsweg gäbe, notfalls den Flashchip extern flashen).
 
Zuletzt bearbeitet:

puri

Commodore
Dabei seit
Apr. 2011
Beiträge
4.762
Wenn ich von den Quadro-Karten ausgehe, waren die Fermis die letzten, die ohne dieses "Feature" kamen. Das hieße für den Consumermarkt also die Nvidia 5xx- Serie.. Bei AMD ist das eventuell anders, aber die Infos dazu sind einfach spärlich. Ich selber hatte auch noch 2 solche alte Scherben, wie Deinen PC, bis vor kurzem im Einsatz gehabt (Dell 755 von 2008) und hatte als neueste Grafikkarte eine Nvidia 210 im Einsatz.
 

KI-Bot

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
Jan. 2021
Beiträge
13
Ok ich habe mal etwas geschaut mit Hilfe von Wikipedia und mit der Intention das die Karte maximal 75 Watt ziehen darf und auf der Fermi Architektur basiert.

Bleiben als drei beste Optionen die GeForce 545, die GeF440orce 440 und die Quadro 2000.
Beim Vergleich fällt mir auf, dass jede in bestimmten Spezifikationen Vorteile gegenüber den beiden anderen hat...

Welche ist für's Gaming empfehlenswert?
 
Zuletzt bearbeitet:

KI-Bot

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
Jan. 2021
Beiträge
13
Ok die Quadro 2000 gibt es mit maximal 1GB und die 2GB Version der 440 kann ich nirgends finden.
 

KuestenNebel

Lt. Commander
Dabei seit
Aug. 2019
Beiträge
1.981
Was spricht denn gegen die GTX 750? Alternativ wäre noch die GTX 650 denkbar, diese gibt es auch in einer Variante mit 2 GB.
 

KI-Bot

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
Jan. 2021
Beiträge
13
Da liegen ja Welten zwischen denen und den von mir aufgeführten, danke!
=)
 

BFF

¯\_(ツ)_/¯
Moderator
Dabei seit
Okt. 2017
Beiträge
14.964
@KI-Bot

Du solltest Dich langsam entscheiden in welchen Thread Du zu der ollen Hardware des Fujitsu-Siemens P7935 eine GPU haben willst.

BFF
 

KI-Bot

Cadet 1st Year
Ersteller dieses Themas
Dabei seit
Jan. 2021
Beiträge
13
BrollyLSSJ hat mich ermutigt es doch mit dem BIOS Update via Windows Executable zu versuchen und es hat geklappt.

Ich habe

Flash BIOS Update - Desk Flash Instant
Version (Build/Date) 6.00.1.19 (05/11/2009)

oder

DeskView Instant BIOS Management (BIOS Update & Settings) - V6.65
Version (Build/Date) 6.65.0181 (18/12/2014)
Size 6.81 MB
(nur zu finden wenn man als Betriebssystem Windows 7 x64 wählt und dann im Reiter Applications schaut!)

benutzt.
Ich weiß es nicht mehr genau, da es sehr spät war, ich sehr verzweifelt war und ich mehrere .exe Dateien in dem Verzeichnis liegen hatte.

Im BIOS habe ich vorher alles auf die default settings gesetzt und den Passwortschutz deaktiviert.
Ich habe die Fujitsu Dateien in ein extra Verzeichnis auf den Desktop kopiert (lieber nicht vom USB starten, wer weiß...) und als Admin ausgeführt.
Es öffnete sich ein quasi Terminal das endlich mal halbwegs vernünftigen Output gab, anstatt immer nur diese bunten Fenster mit Hexcode oder was auch immer...
Rechner startete ca. 2 Minuten später neu (einfach nix machen nachdem man auf die .exe geklickt hat) und nach einem weiteren manuellen Neustart sah ich in der BIOS Übersicht, dass die letzte offiziell verfügbare Version drauf war.
Danach die 1030er eingebaut, Treiber installiert, neu gestartet und siehe da es geht tatsächlich!

Danke an alle die geantwortet haben und hoffentlich hilft dieser Thread irgendwem anders ein ander Mal ebenfalls.
 
Zuletzt bearbeitet:
Top