OpenVPN mit Synology NAS

goblingift

Lieutenant
Dabei seit
Juli 2006
Beiträge
736
Hallo zusammen,

ich hoffe hier kann mir jemand helfen. Ich besitze eine Synology Diskstation DS213+ und möchte mich mit dieser per OpenVPN zu einem VPN-Anbieter verbinden. Um dann fortan den Internetverkehr darüber abzusichern.

Nur bekomme ich einfach keine Verbindung zustande :freak:
Ich habe mir vom VPN-Anbieter das Verbindungszertifikat (trustedroot.pem) heruntergeladen und bei der NAS ausgewählt. Nur leider verbindet er nicht...Habe auch schon die Ports im Router freigegeben, auch ohne Erfolg.

Falls jemand sowas schonmal versucht hat, wär ich über Feedback dankbar :)
 

derChemnitzer

Fleet Admiral
Dabei seit
Jan. 2011
Beiträge
12.429
mal Google versucht das spuckt viele Antworten aus ;)

welche Ports genau hast du freigegeben?
was steht in deiner Log Datei?
 

goblingift

Lieutenant
Ersteller dieses Themas
Dabei seit
Juli 2006
Beiträge
736
Ja gegoogelt habe ich die letzten Tage schon, aber nix triftiges gefunden :(

Ports habe ich freigegeben (Sowohl in NAS als Router): 1194UDP, 1723TCP. Synology FAQ

Allerdings kann ich mich ja mit meinem Desktop Rechner und dem OpenVPN-Client auch per openVpn problemlos verbinden- ohne welche Ports freizugeben. (Und der Rechner hängt auch hinter dem Router).

Log gibt es nicht für die VPN Verbindung auf der Nas...
 

chrigu

Fleet Admiral
Dabei seit
Mai 2012
Beiträge
22.975
mhhh.. du willst also ein tunnel zwischen nas und einem vpn anbieter... und wie verbindest du dich? normal über webzugriff?

normal sind das punkt zu punkt-verbindungen... also z.b. vom händy auf ein nas, oder von pc-privat zu pc-büro.... von händy/pc/tablet zu vpn anbieter um "sicher" zu surfen..
aber nicht von pc zu nas zu vpn anbieter... oder habe ich dich falsch verstanden?
 

mansior

Cadet 3rd Year
Dabei seit
Mai 2010
Beiträge
53
Hey,

ich bin mir nicht sicher, wie es derzeit in der GUI aussieht, aber als ich mein NAS eingerichtet habe, bot die GUI nur die Möglichkeit als OpenVPN Server zu fungieren. Das willst du ja gar nicht. Den Server hast du vom Anbieter.

Daher habe ich die "Client" Konfiguration ganz normal wie unter Linux durchgeführt. Ein paar Autostart Scripte benötigt man dann allerdings auch. Schliesslich soll es ein reconnect bei Neustart des Nas geben...


Viele Grüße,
Mansior
 
Top