Passwörter per Outlook versenden

Bob.Dig

Captain
Registriert
Dez. 2006
Beiträge
3.969
Ich versende öfters Zugangsdaten (verschlüsselt) per E-Mail an meine Kollegen.
Leider ist es dann oft so, dass z.B. hinter dem Passwort noch ein Leerzeichen steht, obwohl ich dieses dort nicht eingetragen habe und ich dieses auch nicht effektiv löschen kann.
Selbst wenn ich eine Tabellenzelle mache, befindet sich dort noch ein Leerzeichen.
Wenn jetzt nicht sauber kopiert wird, führt das zu einem Fehler bei der Anmeldung und unnötigen Rückfragen.

Daher mein Frage, gibt es da eine einfache Möglichkeit, eine Zeile, ggf. aus nur einem (Pass-)Wort, sauber und ohne Satzzeichen oder sonstigem zu "schließen"?
🤨
 
Zuletzt bearbeitet:
kopierst du das kennwort woanders raus? z.B. aus nem sharepoint o.ä.? da kenn ich es dass man beim kopieren gern mal ein leerzeichen dazu bekommt.
outlook ist es grundsätzlich ja egal was da steht und es fügt nicht von selbst leerzeichen ein, ich würde eher an der quelle suchen.
 
Ist mir bisher nicht aufgefallen, dass Leerzeichen aus dem Nichts erscheinen.
Was heißt denn verschlüsselt? Irgendwie mit einem Plugin was das Leerzeichen rein zaubert?
Oder die Mail nicht als HTML sondern "Nur Text" versenden.
 
@robertsonson Nope, schreibe die tatsächlich selbst und hinterher steht dann ein Leerzeichen (vermutlich) dahinter oder etwas, was so aussieht.
Ergänzung ()

Smily schrieb:
Was heißt denn verschlüsselt?
S/MIME

Welches Format genau benutzt wird, kann ich nicht mal sagen, glaube text/HTML und nicht nur HTML oder so ähnlich. Das mit der Verschlüsselung habe ich nur erwähnt, damit sich keiner unnötig aufregt. 😉
Ich meine, das Problem besteht auch bei unverschlüsselten E-Mails.
 
Zuletzt bearbeitet:
komisch. also du tippst das pw, drückst dann enter und er macht dir dann da ein leerzeichen rein?
das hab ich auch noch nie erlebt, da bin ich dann leider raus...
 
robertsonson schrieb:
komisch. also du tippst das pw, drückst dann enter und er macht dir dann da ein leerzeichen rein?
Nein, aber wenn Du das "Wort" doppelklickst, wird mehr als das "Wort" markiert, obwohl da kein Leerzeichen ist. Vermutlich das "Enter"... der Zeilensprung oder wie immer man das nennt.

Vielleicht hat ja jemand schon das selbe Problem gehabt und gelöst.
 
Habs grade mit Outlook probiert, ist so wie beschrieben.
Auch wenn man definitiv kein Leerzeichen anhängt, kann der Empfänger das Geschriebene und ein Leerzeichen in der EMail markieren.
Hab da jetzt auch keine Lösung.
 
  • Gefällt mir
Reaktionen: Bob.Dig
robertsonson schrieb:
outlook ist es grundsätzlich ja egal was da steht und es fügt nicht von selbst leerzeichen ein, ich würde eher an der quelle suchen.
Das ist vollkommen normales Verhalten, jedenfalls unter Windows. Doppelklick in $Anwendung doch mal ein Wort, dann selektiert er das plus den Whitespace dahinter - das passiert im Explorer in der Run-Box, Outlook, Word, Notepad, Firefox, ... Keine Ahnung wie die Konvention unter Linux oder macOS ist.

@Bob.Dig Besorgt euch nen gescheiten Passwortmanager. Oder bring den Leuten halt bei, dass sie nur das Passwort kopieren sollen und ggf. unnötiges Whitespace entfernen. Man sieht doch bereits auf einen Blick, dass wenn das Passwort u9QN9iBhpvRl0fYw6Ufikibzz3ZeoKCR ist und das Whitespace dahinter ebenso markiert wurde, dies wohl nicht dazugehören kann... Alternativ halt in Anführungszeichen setzen (+ dem Vermerk, dass die Anführungszeichen nicht dazu gehören, weil bis drei zählen und so...).

Doppelklick auf das Passwort im letzten Satz zeigt auch wunderschön die Problematik auf.

1596444072263.png


Bei XFCE ist es bspw. so, dass wenn ich auf den linken Teil eines Wortes Doppelklicke, er links das Whitespace mit kopiert, sich also gänzlich "anders" verhält.

1596444170618.png
 
  • Gefällt mir
Reaktionen: Fanchen und Bob.Dig
Das ist wirklich nichts Neues und mir auch schon oft passiert (Zugangsdaten per Mail erhalten, unverschlüsselt wohlbemerkt xD).

Würde nun vermuten dass es am HTML-Body liegt, schließlich folgt dem Zeilenumbruch vermutlich im Quellcode ein oder mehr Leerzeichen (eingerückter Code). Wäre interessant, wie es sich bei text only Mails verhält?
 
Yuuri schrieb:
Oder bring den Leuten halt bei, dass sie nur das Passwort kopieren sollen und ggf. unnötiges Whitespace entfernen.
Ich arbeite nicht in der IT und ich würde das Problem meinen Kollegen und mir gerne irgendwie ersparen. Deshalb hier gefragt, wer vielleicht eine Lösung kennt.
 
Nimm einen linuxkonformen Editor wie Notepad++.Dann passiert so etwas auch nicht bzw. erkennst du es direkt.
 
maxblank schrieb:
Nimm einen linuxkonformen Editor wie Notepad++.Dann passiert so etwas auch nicht bzw. erkennst du es direkt.
Hm, Du hast die Aufgabe offensichtlich nicht verstanden... Und für immer Tschüss.
 
Bob.Dig schrieb:
Nein, aber wenn Du das "Wort" doppelklickst, wird mehr als das "Wort" markiert, obwohl da kein Leerzeichen ist. Vermutlich das "Enter"... der Zeilensprung oder wie immer man das nennt.

i know, aber kopier dann mal das markierte und füg es irgendwo anders ein, dann ist nix mehr dahinter.

/edit:
kommando zurück, ich hab es eben nur im neue mail-fenster getestet. bei einer vorhanden email tritt das verhalten bei mir genauso auf.
 
@maxblank Was soll er erkennen? Er versendet die Passwörter ja nur und die Empfänger kopieren versehentlich das Leerzeichen mit. Soll er denen nun alle n++ mitgeben? xD

Edit: @robertsonson also bei meinem Test eben wurde das Leerzeichen mit kopiert und eingefügt.
 
  • Gefällt mir
Reaktionen: Bob.Dig
Ganz simpel.
Einen harten Umbruch mit Shift + Enter nach dem Passwort machen und das Enter wird bei Doppelklick nicht ausgewählt.
 
  • Gefällt mir
Reaktionen: Mickey Cohen, Der Lord, Bob.Dig und eine weitere Person
Wenn ein korrektes Passwort entsprechend versendet wird jemand dann ein Leerzeichen dazu kopiert, sollte man beim User ansetzen und das Ganze nicht technisch zwanghaft lösen wollen.
 
robertsonson schrieb:
i know, aber kopier dann mal das markierte und füg es irgendwo anders ein, dann ist nix mehr dahinter.
Ist wohl von der Anwendung abhängig?

Hab mir gerade mal so was nach hause geschickt, aber Thunderbird macht es gleich richtig und markiert keinen "Whitespace".
Thunderbird auch mal im Vorteil. 🥳
 
Wenn ich das mit einem anderen Email-Client verschicke - ich nutze emclient - wird kein zusätzliches Leerzeichen mit übertragen. Da Word in Outlook integriert ist, vermute ich das hier der "Hund begraben ist".

Also definitiv ein "Microsoft-Macke".
 
Das Problem ist hier der Client der das anzeigt und der User der blind das übernimmt.

Ggf. hilft noch ein Satz in die Passwort-Mail wie "bitte darauf achten, dass KEIN Leerzeichen nach dem letzten Zeichen folgt und dieses bitte nicht damit einfügen...".
 
Ist das setzen des Passwortes in Anführungszeichen keine Option? Wenn man auf ein Wort in Anführungszeichen doppelt klickt, werden diese afaik nicht mitmarkiert. Müsstest halt noch einen Strg-c, Strg+v "Disclaimer" dahintersetzen, dass die Anführungszeichen nicht Teil des Passwortes sind.
 
  • Gefällt mir
Reaktionen: Bob.Dig, Der Lord und Cordesh
Zurück
Oben