Plötzliche Performanceprobleme nach längerer Laufzeit

warti

Lt. Junior Grade
Dabei seit
Juli 2005
Beiträge
461
Hallo,

alle paar Wochen/Monate - habe ich plötzlich heftige Performanceprobleme auf meinem Heim-Server, dann verringert sich die Festplattenperformance dramatisch:

Code:
----------------------- Problem ------------------------------------
/dev/sda3:
 Timing cached reads:   876 MB in  2.00 seconds = 437.72 MB/sec
 Timing buffered disk reads:   8 MB in  3.50 seconds =   2.29 MB/sec

/dev/sdb3:
 Timing cached reads:   924 MB in  2.00 seconds = 461.96 MB/sec
 Timing buffered disk reads:   8 MB in  3.19 seconds =   2.51 MB/sec
nach einem "reboot" sind aller Probleme verschwunden!

Code:
-------------------------- "Normal" ------------------------------
/dev/sda3:
 Timing cached reads:   1572 MB in  2.00 seconds = 785.65 MB/sec
 Timing buffered disk reads: 132 MB in  3.01 seconds =  43.88 MB/sec

/dev/sdb3:
 Timing cached reads:   1586 MB in  2.00 seconds = 793.15 MB/sec
 Timing buffered disk reads: 266 MB in  3.02 seconds =  88.13 MB/sec
Meine Hardware/Software:

* AMD e350 - ASUS E35 M1-M (neustes BIOS)
* Debian - Squeeze
* Kernel 3.3.5 (hatte ich auch bei Älteren)
* Samba
* Virtualbox
* etc.

Google sagt mir leider nichts :( Irgendwie glaube ich an ein HW Problem ....

Hat irgendjemand eine Idee?
 

warti

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juli 2005
Beiträge
461
Ich antworte mir mal selber:

Ist wohl ein Problem des Mainboards mit dem Kernel:

May 16 21:52:25 server2 kernel: [93978.185788] irq 19: nobody cared (try booting with the "irqpoll" option)
May 16 21:52:25 server2 kernel: [93978.185836] Pid: 0, comm: swapper/1 Tainted: G O 3.3.5 #1
May 16 21:52:25 server2 kernel: [93978.185843] Call Trace:
May 16 21:52:25 server2 kernel: [93978.185849] <IRQ> [<ffffffff810979ed>] ? __report_bad_irq+0x2c/0xb7
May 16 21:52:25 server2 kernel: [93978.185875] [<ffffffff81097bf0>] ? note_interrupt+0x178/0x1fa
May 16 21:52:25 server2 kernel: [93978.185886] [<ffffffff81095f29>] ? handle_irq_event_percpu+0x166/0x184
May 16 21:52:25 server2 kernel: [93978.185898] [<ffffffff81013ca5>] ? read_tsc+0x5/0x16
May 16 21:52:25 server2 kernel: [93978.185909] [<ffffffff81075db2>] ? update_ts_time_stats+0x2b/0x6d
May 16 21:52:25 server2 kernel: [93978.185919] [<ffffffff81013ca5>] ? read_tsc+0x5/0x16
May 16 21:52:25 server2 kernel: [93978.185928] [<ffffffff81095f7c>] ? handle_irq_event+0x35/0x55
May 16 21:52:25 server2 kernel: [93978.185938] [<ffffffff8109825b>] ? handle_fasteoi_irq+0x8d/0xdc
May 16 21:52:25 server2 kernel: [93978.185949] [<ffffffff8100fbf7>] ? handle_irq+0x1a/0x23
May 16 21:52:25 server2 kernel: [93978.185959] [<ffffffff8100f431>] ? do_IRQ+0x45/0xaa
May 16 21:52:25 server2 kernel: [93978.185969] [<ffffffff81341bee>] ? common_interrupt+0x6e/0x6e
May 16 21:52:25 server2 kernel: [93978.185975] <EOI> [<ffffffff81010c5e>] ? restart_nmi+0x7/0x7
May 16 21:52:25 server2 kernel: [93978.185993] [<ffffffff8100de74>] ? cpu_idle+0x99/0xf7
May 16 21:52:25 server2 kernel: [93978.186004] [<ffffffff81339cb6>] ? start_secondary+0x1fc/0x202
May 16 21:52:25 server2 kernel: [93978.186011] handlers:
May 16 21:52:25 server2 kernel: [93978.186067] [<ffffffffa01e19d8>] ahci_interrupt
May 16 21:52:25 server2 kernel: [93978.186100] [<ffffffffa03d7000>] mantis_irq_handler
May 16 21:52:25 server2 kernel: [93978.186129] Disabling IRQ #19

https://bugzilla.kernel.org/show_bug.cgi?id=39122

Seit Januar gibt es eine neue FW: 1401.
Die probiere ich mal aus. Wenn es mit der neuen FW auch Probleme gibt, kommt ein neues Board/Prozessor rein ...
 

freak01

Commander
Dabei seit
März 2002
Beiträge
2.677
wie der bug schon sagt, du könnest mit pci=irqpoll booten,

ob das jetzt die optimalste Lösung neben den FW-Update ist,

wird sich zeigen

*daumendrück*, dass das Update problemlos über die Bühne geht


der Einbruch ist ja schon arg :o
 

warti

Lt. Junior Grade
Ersteller dieses Themas
Dabei seit
Juli 2005
Beiträge
461
Das System ist dann kaum bedienbar.

wie der bug schon sagt, du könnest mit pci=irqpoll booten,

ob das jetzt die optimalste Lösung neben den FW-Update ist
So wie ich verstanden hab schaltet Linux sowieso in den irqpoll Modus. Deshalb der Leistungseinbruch - speziell bei dem schwachen Prozessor.

Bis jetzt ist aber das Problem noch nicht wieder aufgetreten. Das hat aber noch nichts zu sagen. Wenn es jetzt mal 6-8 Wochen durchläuft, dann ....

So wie ich die Fehlerbschreibung verstehe betrifft es die PCIe-PCI Bridge ASM1083. Der wird wohl öfters verbaut.

Die Alternative wäre ganz auf PCI zu verzichten und so was zu kaufen:
http://www.linuxtv.org/wiki/index.php/TeVii_S470

Wäre wohl billiger als ein neues Board plus Prozessor. Und meine "Server TV HD Karte" könnte in meinem DesktopPC arbeiten ...

Edit: 25.05.

SO, jetzt ist es wieder passiert. Also das neue FW bringt null. Ich kann nur jeden warnen ein aktuelles Mainboard (speziell ASUS) mit ASM1083 mit PCI Karten einzusetzen!!

Die neue PCIe DVBS Karte ist im Zulauf ...
 
Zuletzt bearbeitet:
Top