Synology DS218 Absturz und Startprobleme

sthyen

Lieutenant
Registriert
Apr. 2011
Beiträge
527
Hallo zusammen,

ich habe seit etwa 2,5 Jahren eine Synology DS218 mit einer Ironwolf 4TB HDD.

Vorab: Ein Backup aller wichtigen Daten liegt vor, einige Daten (z.B. selbst digitalisierte DVDs) sind nicht im Backup.

Seit etwa April/Mai (vermute ich) war sie manchmal im Netzwerk nicht erreichbar und komplett abgestürzt. Die Ein/Aus-LED blinkte blau. Es half nur den Stromstecker ziehen und wieder einstecken. Das geschah selten, etwa alle zwei bis vier Wochen.

Vor ein paar Tagen war sie wieder abgestürzt und ich wollte sie mit Strom weg wieder neu starten, das klappte aber nicht (auch nach mehreren Stunden warten ist nichts weiter passiert). Es blinkte lediglich die blaue Ein/Aus-LED. Auch der Synology Assistent hat die DS nicht im Netzwerk gefunden.

Nach einiger Recherche bin ich etwas weiter gekommen.
1. ein neues Netzteil hat nicht geholfen.
2. HDD vor dem Start entfernen --> DS startet und wird vom Assistenten gefunden.
2a. HDD im laufenden Betrieb wieder einsetzen --> geht, Assistent schlägt vor, das Betriebssystem zu installieren.

Ich möchte das Betriebssystem aber erstmal nicht auf die HDD installieren, denn ich gehe davon aus, dass dann alle Daten weg sind und ich möchte meine DVDs nicht schon wieder digitalisieren:( Außerdem bin ich mir nicht sicher, wie gesund die HDD noch ist und ich habe wenig Lust die DS komplett neu einzurichten.

Deshalb habe ich die Platte per USB Adapter am Rechner angeschlossen um die Smartwerte auszulesen.
CrystalDisk.jpg
Was sagt ihr zu den Smartwerten? Ist die Platte noch brauchbar?
Habt ihr eine Idee, wie ich die (unwichtigen) Daten retten kann?
Habt ihr weitere Tipps oder Ideen, die mich weiterbringen?
 
Wenn die Platte am PC hängt, kannst Du doch auf die Daten zugreifen oder?
Ich habe kein Synology aber deren OS basiert doch auf Linux. Da würde ich vermuten, dass du ggf. mit Linux an die Daten kommst, wenn es mit Windows nicht geht.
 
  • Gefällt mir
Reaktionen: sthyen
Nein, das geht leider nicht, sie wird im Explorer nicht erkannt, sondern nur in der Datenträgerverwaltng.
Ich bisher nicht auf die Idee gekommen einen Laufwerksbuchstaben zuzuweisen, aber probiere das gleich mal aus.

Edit:
Die Datenträgerverwaltung lässt nur das Löschen der Partition zu. Einen Laufwerksbuchstaben setzen kann ich nicht (ausgegraut).
 
Smart Werte sind super, würde mir da ehr um das NAS Sorgen machen.
Weiches Dateisystem hat die Platte? Btrfs oder Ext4? Für beide gibt es Auslesesoftware, einfach Googlen.
 
  • Gefällt mir
Reaktionen: sthyen
Rufus erstellt gerade einen USB STick mit Ubuntu 20.04.
Wenn der durch ist, probier ich mal, was dann geht.

Topflappen schrieb:
...würde mir da ehr um das NAS Sorgen machen.
Schade, das wäre der teurere Posten und auf die HDD ist noch Garantie.
Weiches Dateisystem hat die Platte? Btrfs oder Ext4? Für beide gibt es Auslesesoftware, einfach Googlen.
Weiß ich gar nicht genau, ich werde es mit Ubuntu vermutlich rausfinden...
Ergänzung ()

Ich komme in Ubuntu nicht weiter. Das mounten der Platte klappt nicht...

Bisher gemacht:
  • HDD im Zweitrechner eingebaut und an SATA + Strom angeschlossen
  • PC mit Live Ubuntu gestartet
  • Diese Anleitung ab Punkt 6 durchgeführt und nach Neustart nur nach Punkt 10
Problem: ich kenne den Device_Path nicht und versuche das Beispiel unten einzugeben. Fehlermeldung: mount: /mnt: Spezialgerät ... ist nicht vorhanden

Wie finde ich bei diesem Befehl
Code:
 $ mount ${device_path} ${mount_point} -o ro
device_path und mount_point raus?
Oder wo liegt der Fehler?

Info: Im Dateiexplorer von Linux kann ich unter "andere Orte" die SSD des Systems sehen und den USB Stick. Die angeschlossenen HDD sehe ich allerdings nicht...
 
Zuletzt bearbeitet:
Ich bin einen Schritt weiter.
Über sfdisk -l habe ich rausgefunden, dass ich /dev/sda5 mounten muss (größte Partition der HDD).
Und über die Befehlsfolge der Anlteitung hat das mounten jetzt geklappt.

Aber wie greife ich auf /mnt zu? :confused_alt:
Es erscheint nicht im Dateiexplorer und das Terminal kenne ich nicht so gut...

(Boah mir raucht echt der Kopf)
 
Ich habe keine Ubuntu hier...
Aber wage kann ich mich daran erinnern, dass links in der Leiste die Platten angezeigt wurden bzw. angezeigt werden können. Ich gibt es sicherlich noch jemanden der da weiterhelfen kann.
Startmenü - Systemüberwachung - Dateisysteme
 
es gibt extra "ext"-treiber, damit windows die ds platte lesen kann.
 
@chrigu:
Kannst du bitte einen Link nennen, wo man einen "ext"-Treiber für Windows herunterladen kann, dessen Funktion nicht zeitlich limitiert ist? Das, was ich bisher gefunden habe, sind leider alles Testversionen...
 
dafür reicht es.
 
Himbaer schrieb:
Ich habe keine Ubuntu hier...
Aber wage kann ich mich daran erinnern, dass links in der Leiste die Platten angezeigt wurden bzw. angezeigt werden können.
Ja, so funktioniert das auch bei der internen SSD, aber die HDD wird dort leider nicht angezeigt. Auch nicht im Dateiexplorer unter nmt.

chrigu schrieb:
es gibt extra "ext"-treiber, damit windows die ds platte lesen kann.
Ich habe es mit ext2explore versucht. Trotz Admin-Rechten findet das Programm leider gar nichts. Wahrscheinlich besteht ein Problem, weil Synology einen Raid-Status für die Platte gesetzt hat...
Könntest du mir sonst noch einen ext Treiber nennen? Damit würde ich es dann nochmal versuchen.
 
@chrigu das war der Tipp des Jahrhunderts. :schluck: Nach dem ganzen rumgefrickel habe ich mir aus dem Link den Linux Reader installiert und hatte sofort Zugriff auf die Daten. Da mir gerade die Zeit fehlt, werde ich es später ausgiebieg testen.

Zum Glück hat es geklappt, denn ich habe festgestellt, dass die Handybilder meiner Frau nicht im Backup sind. Das wäre fast ein Scheidungsgrund :freak:
 
Bei mir hat es geklappt.
Ich denke aber, dass es abhängig vom verwendeten Raid des NAS ist. Ich hatte nur ein Platte und somit auch kein RAID eingerichtet.

Ich hatte Zugriff auf alle Daten und habe die entsprechenden Dateien nochmals gesichert. Die NAS werde ich in den nächsten Tag wieder neu einrichten und dann mal sehen, ob der Fehler häufiger auftritt.
 
Ich habe die DS mit der alten HDD nun neu eingerichtet. Komplett fertig bin ich noch nicht, aber die alten Nutzer sind angelegt, Backup etc. einrichten kommt noch.
Das interessante: Ich musste gar keine Daten des Backups einspielen, da alle Daten nach dem Einrichten noch vorhanden waren. Auch die alten Netzwerklaufwerke funktionieren wieder, nachdem ich die alte IP wieder eingetragen habe. Das war also alles viel einfacher, als ich vorher gedacht hatte.
Es bleiben zwei Gedanken:
1. Diesmal werde ich ein Backup der Einstellungen machen, das hatte ich vorher nicht.
2. Was ist schiefgelaufen, als die DS nicht mehr funktionierte? Gibt es bei Synology ein gutes Analysetool für die HDDs und die DS selbst?
 
Zurück
Oben